Jump to content
Ghost Recon.net Forums

Tom Clancy's Ghost Recon: Blood Oil


Recommended Posts

I was playing BO and after thesecond or third mission, all the guns on my team made the same sound, regardless of type. The first time i noticed this, they all sounded like the M240 on full auto, then they all made a chirping sound. I then tried a map on "Firefight" and got the same results, but the sounds returned to normal once I de-activated Blood Oil. Upon restarting Blood Oil, the sound issue returned, with all weapons having only one sound, regardless of type.

Any idea what is causing this?

The below fix seemed to do it for others.

The M32 is listed twice in the effects file. 2 ways to fix this.

1: Locate 1 of the lines same as below and delete it. Then at the top of the list, change count 109 to count 108

<Entry Filename = "n_gl_ss.wav" Length = "2.139" Min = "1.000" Max = "2000" Rolloff = "75"/>

2: Download THIS new effects.xml and put it in your Blood oil / Sound folder and overwrite.

:rolleyes:

Link to post
Share on other sites
  • 4 weeks later...
  • Replies 407
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Still having good fun with Blood Oil    

Finally finished another old mod.Started this when it came out a few years back but quit playing because of the Waterfall day mission. That's one screwed up and buggy mission not to mention saves caus

Really enjoying Blood Oil so far. I'm on M5, but something's bothering me. My riflemen and demos for the current playthrough are almost all non-M4 actors, and something odd occurs when I equip any

How am I supposed to capture the leader on Mission 11 (River Bend Day)? My AI teammates always shoot him.

EDIT: I managed to do it, but shouldn't he be a non-enemy?

Edited by Malleus
Link to post
Share on other sites

Very good point. Again this is down to me scripting the missions for coop. How it should work is, you take out the enemy near his location, and once you get close enough, he gives up his arms and surrenders. Obviously this is not working with the freindle AI then.

I would really like to add Thumper to the credits for this mod, lot of reticles and textures etc, used without a mention. Do have a few small other things that have come up in the past too. I can make a small patch at some point, no problem, will change that mission for SP, and have him as non enemy, unarmed. Thnx for bringing it up.

:thumbsup:

Link to post
Share on other sites

Well, he was unarmed (at least when I got to him), but considered an enemy by the friendly AI. I managed to capture him getting to him before my teammate shot him. :) (I work with three 2-man teams).

One small thing at the last mission: the Destroy SAM objective didn't register, and it showed up as failed after the mission, yet I could finish the mission without problem. Also, power-nitpick - the insertion car on the River Bend mission has the wheel on the right side, but AFAIK Nigeria is a right-side-driving nation. ;)

Anyway, as you can see, I just finished this mod, and it was awesome. Special mention goes to the ambient sounds. For example, the dog on the Hotel level was a funny surprise :), and things like the airplanes passing by in the distance on the Railyard Night level, it was cool. The weapon sounds were also great.

Speaking of the Railyard Night level, there are some pretty crazy stealth missions in there Tinker - now I learned to be afraid when I see "map & mission by Tinker" at the briefing. :) These missions are interesting, and they certainly put GR's gameplay into a new light. You don't see this kind of thing in the original campaigns.

So thanks for all the work everyone put into it, Blood Oil was great. :thumbsup:

Edited by Malleus
Link to post
Share on other sites
  • 3 weeks later...

Hey, I tried starting the BO campaign a while back, but never played passed the first mission. Today I tried to launch the second mission and CTD'ed every time. Before I tried though, I extracted the newest patch. I'm wondering if somehow I patched it wrong. Is there some way I can check before downloading it again?

last line in Ike.log says:

Loading map c:\red storm entertainment\ghost recon\mods\blood_oil\map\bo02\bo02_v_10-lit2.map

Link to post
Share on other sites

There was several mission fixes. Whenever missions are fixed and a patch comes out, I would always recommend deleting save files and starting again. Pretty much same deal with any game really.

You may need to edit the unlocked_missions file in the main gr folder, and remove any BO missions it may reference. Also any unlockedhero files that refer to BO. All I could suggest. I did play through the campaign in SP after the patch, other`s have reported it to be fine also.

Use autowin and unlockhero to get past mission 1 again if needed.

Link to post
Share on other sites

If I remember the vehicles were changed, if there is something wrong there, it will ctd and not give any clues in the ike. I would check them first.

Suspect is:

truck_mog_1.vcl

change that to:

jeep_mog_1.vcl

Open C 01 mission file with notepad and scroll down past the actors until you find the vehicles and change it there, or do it in Igor.

Link to post
Share on other sites
  • 3 weeks later...

Just downloaded Blood Oil and spent an hour or so playing the first mission: amazing work!

However, I can't find the lock codes. I have killed every bad guy, searched the generators and looked in every office, every cubicle and every out building I can find, but no codes. I'd hate to autowin the first mission.

Link to post
Share on other sites

Been awhile since I played this.

I am sure the lock out codes are to be found on the second level of the large office building in the NW portion of the map. They are set randomly in the north end of the building in one of the 20 cubicles found in that room.

But first you must rescue the hostage on the first level of the same building.

If she is killed or you do not rescue her finding the lockout codes is disabled in the script.

Link to post
Share on other sites

One of the three hostages will have the codes info, then any of the PC stations (with a tower) could actually have the codes....first or second level of the main building for that...all of it is random...

migph34r.gif

Link to post
Share on other sites
  • 2 months later...

I hope that I can get a little help here.

Did a clean installation of GR and all of its modules.

Installed Blood_Oil v. 2.7, used 7zip to apply Patch v. 1.4b, and then I placed the sound file inside the mod's Sound directory. I then activate the mod (it's the only one installed).

The game keeps crashing during the loading of Mission 1. The only item that I have "saved" are my customized keybinds. I haven't even tried a default GR campaign.

What's strange is that I can play the default quick firefight of the Keep with the mod on, without experiencing any problems. Yet as soon as I quit said firefight, and then try starting up Mission 1 of the campaign, it once again CTDs during loading.

Any detailed advice would be greatly appreciated!

Link to post
Share on other sites

Not sure what it could be!

I have also a fresh install of GR from the weekend. Just downloaded BO and the patch from our download section. Activated it and selected campaign, played fine here.

Does the IKE.log have anything listed in it as missing?

Link to post
Share on other sites

Y'know Tinker, you're a genius on so many different levels, it almost disgusts me!

Great missions. Great mods. Always helpful to others in need, lending advice in a detailed way, and now you just asked the million dollar question, because, it turns out, it was the right one to ask. Here are the results of opening up my Ike.log...

***** User's system configuration *****

CPU: GenuineIntel 2993 MHz Pentium 4

RAM: 2048 MB

O/S: Microsoft Windows 2000 5.1 Service Pack 3 build 2600

Ghost Recon (RELEASE) version = 1.4.0.0(0)

RSDisplayMgr::CreateGameWindow: Creating a 1024x768 window at 0,0 on monitor Plug and Play Monitor attached to Radeon X1950 Pro

RSDisplayMgr::CreateGameWindow: Game running on primary display Plug and Play Monitor attached to Radeon X1950 Pro

HAL (hw vp): Radeon X1950 Pro R5G6B5

RSFILEDATA: FindFile could not find file ike_fx_fire_type2.tga

RSFILEDATA: FindFile could not find file ike_fx_fire_type2.rsb

Unable to find ike_fx_fire_type2.tga anywhere.

RSFILEDATA: FindFile could not find file lighthalo_effect3.rsb

RSFILEDATA: FindFile could not find file lighthalo_effect3.rsb

Unable to find lighthalo_effect3.rsb anywhere.

RSSoundMgrPC: Selecting sound device SB Audigy 2 Audio [CF00]

driver is ctaud2k.sys

RSSoundManager: EAX 2.0 Support Detected

RSSoundMgrPC: Selecting sound device SB Audigy 2 Audio [CF00]

driver is ctaud2k.sys

RSSoundManager: EAX 2.0 Support Detected

Loading map c:\program files\red storm entertainment\ghost recon\mods\origmiss\map\mp06_castle\mp_castle.map

RSFILEDATA: FindFile could not find file opposing_force_7.atr

RSFILEDATA: FindFile could not find file opposing_force_5.kit

Loading map c:\program files\red storm entertainment\ghost recon\mods\origmiss\map\mp06_castle\mp_castle.map

RSFILEDATA: FindFile could not find file opposing_force_15.atr

RSFILEDATA: FindFile could not find file opposing_force_5.kit

RSFILEDATA: FindFile could not find file c:\program files\red storm entertainment\ghost recon\mods\blood_oil\save\game\blood oil start.csf_bin

SOUND: Cannot Find: BO _briefing.wav

Loading map c:\program files\red storm entertainment\ghost recon\mods\blood_oil\map\bo01\bo01l.map

RSFILEDATA: FindFile could not find file c05_intelligence_papers.rsb

RSFILEDATA: FindFile could not find file c05_intelligence_papers.rsb

Unable to find c05_intelligence_papers.rsb anywhere.

It looks like a whole mess of stuff is missing. So, while I wait for a reply for someone, I'm going to take this bull by the horns, try redownloading the file from the same source you used, and see how it goes.

Thanks for the tip, as it certainly dug up something!

Link to post
Share on other sites

Oh man, I think that I just remembered something that if true would be mighty embarrassing: I think that I extracted the initial mod without using 7.zip.

Doing so now, for sure, and reinstalling with the patch & sound file. Will sheepishly report back, especially if I'm correct on making this gaff!

Link to post
Share on other sites

Nothing to be embarrassed about!

Redownloaded the mod from GRN. Used 7zip to extract it, its patch, and the Sound fix.

Could play default Castle quick mission with no issues.

Also could play Blood_Oil's 1st map through the quick mission screen, the one with the huge oil tanker that's located immediately behind the player. The goal was to wipe out approx. 125 enemies. That too posed no issues for me.

But once I started up a new campaign... It would CTD every time. The latest Ike.log follows my signature.

Good night!

Kyle

Oct. 29, 2010

***** User's system configuration *****

CPU: GenuineIntel 2993 MHz Pentium 4

RAM: 2048 MB

O/S: Microsoft Windows 2000 5.1 Service Pack 3 build 2600

Ghost Recon (RELEASE) version = 1.4.0.0(0)

RSDisplayMgr::CreateGameWindow: Creating a 1024x768 window at 0,0 on monitor Plug and Play Monitor attached to Radeon X1950 Pro

RSDisplayMgr::CreateGameWindow: Game running on primary display Plug and Play Monitor attached to Radeon X1950 Pro

HAL (hw vp): Radeon X1950 Pro R5G6B5

RSFILEDATA: FindFile could not find file ike_fx_fire_type2.tga

RSFILEDATA: FindFile could not find file ike_fx_fire_type2.rsb

Unable to find ike_fx_fire_type2.tga anywhere.

RSFILEDATA: FindFile could not find file lighthalo_effect3.rsb

RSFILEDATA: FindFile could not find file lighthalo_effect3.rsb

Unable to find lighthalo_effect3.rsb anywhere.

RSSoundMgrPC: Selecting sound device SB Audigy 2 Audio [CF00]

driver is ctaud2k.sys

RSSoundManager: EAX 2.0 Support Detected

RSSoundMgrPC: Selecting sound device SB Audigy 2 Audio [CF00]

driver is ctaud2k.sys

RSSoundManager: EAX 2.0 Support Detected

Loading map c:\program files\red storm entertainment\ghost recon\mods\origmiss\map\mp06_castle\mp_castle.map

RSFILEDATA: FindFile could not find file opposing_force_15.atr

RSFILEDATA: FindFile could not find file opposing_force_5.kit

Loading map c:\program files\red storm entertainment\ghost recon\mods\blood_oil\map\bo01\bo01l.map

RSFILEDATA: FindFile could not find file c05_intelligence_papers.rsb

RSFILEDATA: FindFile could not find file c05_intelligence_papers.rsb

Unable to find c05_intelligence_papers.rsb anywhere.

RSFILEDATA: FindFile could not find file opposing_force_15.atr

RSFILEDATA: FindFile could not find file opposing_force_5.kit

Loading map c:\program files\red storm entertainment\ghost recon\mods\blood_oil\map\bo01\bo01l.map

RSGameStateMgr::ProcessMessage() duplicate state change request

RSFILEDATA: FindFile could not find file c:\program files\red storm entertainment\ghost recon\mods\blood_oil\save\game\bo start.csf_bin

SOUND: Cannot Find: BO _briefing.wav

Loading map c:\program files\red storm entertainment\ghost recon\mods\blood_oil\map\bo01\bo01l.map

RSFILEDATA: FindFile could not find file c05_intelligence_papers.rsb

RSFILEDATA: FindFile could not find file c05_intelligence_papers.rsb

Unable to find c05_intelligence_papers.rsb anywhere.

Link to post
Share on other sites

This is 1 time the ike.log is of no use. <_<

You unzipped blood oil and have Blood_Oil in your mods folder.

Then unzip the patch into the Blood_Oil folder.

Your modscont should state 1.04 ?

1: Try starting a default campaign.

2: Try deleting the save game folder inside blood oil. Then right click blood oil folder and check properties.

1.34GB

3,787 files

116 folders

Link to post
Share on other sites

I'm wondering if I'm doing something wrong with the additional compressed files that are sitting inside the Blood_Oil folder when it's first installed.

Specifically, I'm speaking of the following files:

bo_full.7z

bo_reduced.7z

I haven't found a Read Me that describes exactly what they do. And, in hindsight, it might've been helpful had I mentioned what I did in an earlier post. Here's the step that I forgot to mention. After installing the initial Blood_Oil mod, I then use 7zip to "Extract Here" the bo_full.7z file, assuming that it installs improved graphics, models, textures, and whatnot. I leave the bo_reduced.7z file alone. I then "Extract Here" the BO_Patch_1_4_b.7z file within the Blood_Oil directory, and then install the sound fix into sound file within the Blood_Oil directory.

I'll try starting a default GR campaign later, following the advice that you recommended above.

At this point in time, when I check Blood_Oil's properties, I get the following info:

Size: 1.39 GB

Size on disk: 1.41 GB

Contains: 3,791 Files, 119 Folders I'm assuming that the larger numbers are due to leaving the above-mentioned .7z files still sitting in the structure. Should I remove them?

Attributes: the Read-only box is CHECKED. Should it be? I wonder if that's preventing the patch from overwriting necessary files?

I'll check back here later in the day just before I set out to follow through on your advice.

Thanks again for your help.

Link to post
Share on other sites

bo_full.7z

bo_reduced.7z

These are fine left alone, I have them too. So no need to touch them at all.

They are for anyone having performance problems with BO, they can unzip the reduced file and it will change all the textures to reduced sizes. (256x256) The full file will restore the textures back to higher res if needed.

You have: 3,791 Files, 119 Folders

I have: 3,787 files, 116 folders

Both fresh install/ I guess if you remove the save folder from blood oil, these would then match?

Link to post
Share on other sites

Yes, removing the Save file results in an exact matching of the numbers as you provided them.

Started a normal GR campaign, and it worked fine.

Played a Quick Mission in Firefight mode on the first map with the giant tanker. Worked fine, and as I neglected to mention it before, looked wonderful and was entirely immersive. My only observation regarding said map is that the burnoff stacks should be tremendously loud. I would say that one would certainly hear them by the time one got off of the dock that one starts out on, if not earlier. There would be no question that the roaring from those stacks would certainly make the map more challenging, as one's ability to detect the direction or the emission of other sounds would be substantially reduced as one got closer to a stack. Still, visually this map is some extremely fine work.

Then I tried playing a Quick Mission in Mission mode, and after a minute's worth of loading up the first mission, it CTD, just as if I was playing it through the regular Campaign mode. :(

What in the world is going on? How is it that I can use this tremendously creative mod in the regular GR campaign with no issues, play it on one of the customized maps in a Firefight, and have no issues, yet when I try to experience the campaign through either the main Campaign interface or through the Quick Mission interface, it fails? Weird!

Maybe these extra details will give just enough info to figure out what's going on. I hope so, yes indeed I do! :yes:

Link to post
Share on other sites

Tinker,

Thank you for your very robust efforts to assist me.

I installed your Campaign save, entitled something like BO 00:01:14 on the screen. but just as before, a minute into the loading endeavor, and it CTD.

I've never had an antivirus program do this before, but is it possible that Kaspersky would so specificly intercept a particular game execution, thinking that it's a virus doing something malicious? I'm grasping at straws here, but I'm putting it out anyway.

Do you want me to do another completely fresh install of the game (eep!), or delete/reinstallation of the mod with all of its patches, or...?

Link to post
Share on other sites

Kyle you are sure having a time of it!

Grasping at straws here too suggesting this but it seems you have tried everything else.

Delete any saves for Origimiss, MP1 and MP2.

All of them; campaign, mission, firefight, defend and recon missions.

And for good measure delete any replays.

Maybe not the solution but only thing that comes to mind.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...