Map crashing...

11 posts in this topic

Posted

Im haveing a problem booting map "bogie pollux day v.2"...

after wanting to join mission... the map thats booted is map "coop waterplant"..

then I get this crash report...

Error in application : Crash in application version: 30899.3048

Unhandled exception - access violation

C STACK:

graw2 (???) : ???

Renderer: threaded

Physics : threaded

what is going wrong ?? do I have to delete map "coop waterplant"??

Share this post


Link to post
Share on other sites

Posted

Game crashing .. sorry .. not map crashing ...

Share this post


Link to post
Share on other sites

Posted

These type of crashes doesn't give you much idea as to the cause.

As it's crashing when loading make sure you don't have any older versions of the same map in your custom_levels folder.

It could also be that you have reached the limit as to how many maps you can have installed, try removing some of the bundles other than the ones that you are trying to load.

This crash can also occur when the PC is running low on resources, I don't think this is the case here as it normally happens when you are playing a mission.

Both the coop waterplant and Bogie Pollux don't usually give any problems.

Share this post


Link to post
Share on other sites

Posted

These type of crashes doesn't give you much idea as to the cause.

As it's crashing when loading make sure you don't have any older versions of the same map in your custom_levels folder.

It could also be that you have reached the limit as to how many maps you can have installed, try removing some of the bundles other than the ones that you are trying to load.

This crash can also occur when the PC is running low on resources, I don't think this is the case here as it normally happens when you are playing a mission.

Both the coop waterplant and Bogie Pollux don't usually give any problems.

tkx John.. have to check if there are any doublets of maps in my custom level folder ..

but if there arent... why does map " waterplant" start when I want to play " pollux" .. ?

Share this post


Link to post
Share on other sites

Posted

ok .. no double maps in my custom level folder...

and exact 96 maps in that folder.. dont know what to do other than to try to delete "waterplant" and next time "Pollux" is on to try and playagain . hmmm ...tkx for reply ..

Share this post


Link to post
Share on other sites

Posted

You have 96 bundle files in your custom_levels folder? :o

IMO that's far to many, I normally have around 10 in mine, best thing is to keep them to a minimum as the game needs to load all the information so it can display the maps in the sever list, it looks at the world.xml then loads all files needed, when you have all those bundle files in your game it's bound to cause problems, after all you can only play one map at a time.

I would remove most of them and try the mission that is giving you problems again. :thumbsup:

Share this post


Link to post
Share on other sites

Posted

not bundle files ... single maps ...have always loaded single maps only .. and you need em to play .. dont understand ..

if no maps .. always have to load again .. when a map changes .. ?

has always worked so far !!just this one map wont load .. loads "waterplant " instead of "Pollux".. then game crashes ..

Share this post


Link to post
Share on other sites

Posted

The thing is that each bundle file can contain more than one mission, the bundle "Bastion de Pollux" contains 12 missions even though there is only one map. But, the game sees them as 12 separate missions.

The problem isn't the amount of bundle file but the amount of separate missions (not maps) you have installed.

There has been a lot of discussion about how many separate missions we can have installed at one time before it starts to cause problems.

Reaching the limit on the amount of missions

Another reason for asking you to remove some of the bundle files is to eliminate the "to many missions" crash which can give the error you posted, if after removing some of the bundle file the game still crashes then we will know this isn't the problem.

Share this post


Link to post
Share on other sites

Posted

well which bundle files am i suposed to delete ? can you tell me if the pollux or waterplant map/mission is in any bundle and which one ??then I can delete where is duoble... tkx ..

Share this post


Link to post
Share on other sites

Posted

First thing to make sure you don't have any old version of the same maps (with the same name) in your custom_levels folder, which you said you have already done.

Each bundle file has it's own name and should reflect the name of the mission, coop_bogie_pollux_v2.bundle contains the Pollux missions.

After that just delete any bundle file you don't use but leave in the two that are causing problems. I would remove at least half of them then test the map that is giving you problems again, if all is well you know that you had to many missions installed.

If it still crashes then remove them all apart from the Waterplant and Pollux maps, if it works ok then just keep re-adding your bundles and testing the mission until you start having problems.

It's just a process of elimination to find which map is causing a conflict.

Share this post


Link to post
Share on other sites

Posted

well at the moment no problems .. :)

ill see what happens when map" bogie Pollux" comes up in cycle again .. thank you John ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now