Ghost Recon Downloads
Discussion Forums


 

NEW FOR 2020 GHOST RECON ULTIMATE MOD COLLECTION

ON MASSIVE 64GB USB FLASH DRIVE

Ghost Recon Mod Collection

WATCH SHOWN FOR SIZE ILLUSTRATION ONLY

GHOST RECON MOD COLLECTION NOW ON 64GB FLASH DRIVE BY POST.

OVER 1000 GHOST RECON, GRAW, GRAW2 MODS AND WILDLANDS MEDIA FILES FULL DETAILS HERE

       
   

 

Ghost Recon Downloads Help

» Ghost Recon Downloads » Ghost Recon Advanced Warfighter 2 » Mods - Weapons » Brettzies GRAW2 Weapon Pack

Brettzies GRAW2 Weapon Pack
Added: 22/07/07 17:44:51
Description: 12 July 2010 New version v3.02 released

v3.02 Additions
·Fixed god mode in SP campaign to "off."
·Increased Sig552 secondary to have 5 mags in stead of 3

9 July 2010 New version v3.01 released
v3.01 Additions
This is a small fix for a bug that switched the mk14 with the Mrc in MP games on the client side.

v3.0 Additions
Several weeks ago, Radiator released his BlackHawkDown misison for Graw2 which was incompatible with my weapons pack. Since I love the BlackHawk story, tragic as it is, I wanted my weapons to work with it. Radiator also did some excellent work organizing sound xmls to make it easy for modders to not conflict with each other’s custom sounds and also allow for easy expandability. With those two things in mind, I spent about a week cleaning up my pack which resulted in v2.07. I’m never really happy just releasing fixes like that, especially if they require a lot of work. Fixing up the pack was satisfying but I really want to update it with something worth downloading and had forgotten how fun Graw2 can be to mod, time consuming, but fun.

After using the Mk14 EBR in Modern Warfare 2 and seeing several failed attempts to get one legitimately into this game, I decided to go ahead and attempt one myself. Previously I had not liked the design of this weapon, but over time have come to think it looks really cool. It did seem like a very appropriate weapon for the Ghosts, and was actually in the xbox360 version of the game. Modeling the bolt action was a little tricky, and I did attempt to use normal mapping with this one, which slowed my progress, but I’m fairly happy with the end results. Textures, as always could be improved, but that’s never been my strong point or interest with so much else to worry about getting it to a working game state.

Marcinko suggested adding a shortdot scope, which wasn’t difficult to model, but took some time getting all of the bitmap icons for the SP campaign done. It also required adding many more kits to MP/Coop since it can be attached to not just the Mk14, but several of my other weapons as well. In the end, I think it was a good suggestion and makes the mod that much more complete.

Though I’m not sure many people are still playing this game, I hope the few that are can get some enjoyment out of these efforts. I know I’ve had lots of fun making it and I have to say thanks to all the people who have downloaded and used it over the years. The interest and support of even a few people, especially the community at GhostRecon.net, really make it worthwhile and encouraging to complete projects like this.

Enjoy!


Mk14 Mod 0 EBR

This is the new weapon system added to the mod.

·7.62mm
·20 round mag
·semi auto and full auto fire modes
·custom tweaked sounds
·suppressor attachment
·tactical grip
·multiple scope attachments


Shortdot CQB Scope

·new scope seen above available on most of my weapons


Multiplayer Kits

·added multiple sniper kits to all modes except RvA
·added multiple assault kits to all modes except RvA
·added multiple rifleman kits to all modes except RvA
·added multiple aimpoint support kits to all modes except RvA
·added one recon Mk14 kit to RvA

Misc.
·adjusted m4shotgun, l85a2, and sig552 anim sets to be “less” glitchy looking
·changed bullet texture to be Graw2 style instead of shiny Graw1 style
·made sig552 use m4 scope attachments to free up MP attachment slots

Patches
·acu Patch - acu style uniforms for the ghosts (OTS version included)
·ots Patch - provides 3rd person perspective
·bhd Patch - compatible with Radiator's BlackHawkDown mission

22 May 2010
As usual, this "addition" took much longer then expected and was pretty much unplanned in the first place. For some reason, adding this one weapon and scope took quite a bit of time. I did have a list of small fixes and changes that I made to the overall mod as well. The download is rather big because it includes both bundled and unbundled versions in it. I recommend trying the bundled one first as it is faster to load and easier to use with the patches provided. Instead of making a whole mod for OTS, I just included a small patch which can be applied to achieve the same result. I also included the ACU camo patch and BHD patch for Radiator's mission, since all the patches are relatively small.


Possible Solutions if the mod doesn't run:
----------------------------------------------------------
1. if you have a local/english dir, try renaming or deleting it. (strange but sometimes works)

2. try the un-bundled version (usually works for people with issues)

3. if you're on vista, there's a method to delete xmb(complied game) files, which can cause problems:


>>> To clean out XMB files in Vista, go to your user folder, into
>>> AppData/Local/GRAW2 and kill all XMB files except those in the
>>> "settings" folder. Then it will recompile with whatever mod you are
>>> using.
>>>
>>> It usually works.
>>>
>>> Remember that to stop using the mod you may need to to the same
>>> thing again.







Creator/Author: Brettzies
Version: 3.02
Screenshot: Screenshot
Movie Format: Teaser Movie
File Size (MB): 220.4
Discussion Link: Public Release Thread
Last Download: 27/01/23 23:31:29
Downloads: 37673
Rating:
(230 Ratings) 
Tags: m4, mk.23, m4a1, m16a4,
Report Broken Link

 

Download


Webmasters : link to the page URL, not the download URL



PLEASE SCROLL DOWN TO LEAVE A COMMENT!

Posted By des209 on 14/02/08 19:39:31

It dose not work with 105 patch...Frown

Posted By mr47 on 14/02/08 23:33:17

Hi there Brettzies, Awesome mod! but after the update to ver 1.5,  the mod doesnt work and everytime you try to use one the few mod models it CTD Yell.  let me know if we can find a workaround and see what is going on...

Posted By joem423 on 17/02/08 08:51:50

Hi Brettzies,

Thanks for the 1.5 Update. Your hard wor is greatly appreciated by myself. If only ran into one problem and that is that the MRC is no longer a selectable weapon for the main character in a mission. Is there a fix for this?

Best Regards,

Joe

Posted By joem423 on 17/02/08 09:01:02

Hi again Brettzies,

I also just noticed that the M8 is no longer a selectable weapon along with the MRC for the main character when you play a mission. Is there a setting we can make on our end to make these weapons selectable as Primary for the main character?

Thanks again for your hard work,

Joe

Posted By loubamboo on 17/02/08 10:48:17

Dear Brettzie, hi!

I have tried your mod on a retail version install, as well as

patched to 1.02, 1.03, 1.04 and 1.05 versions. The mod works fine, but the new headgear of the ghosts is not displayed: Mitchell is displayed with no headgear at all and the other ghosts have the original "crosscom" helmets. The bodies have your modified uniforms on. So, there must be a problem with the headgear...

  Can you please help me fix this?

                                             Thank you,

                                             Lou

Posted By Fr3ddy on 18/02/08 15:49:08

Crash in application version: 30621.2989Unhandled exception - access violationC STACK:                        graw2   (???) : ???SCRIPT STACK:    data\lib\managers\briefingmanager.dsf(0)    data\lib\managers\briefingmanager.dsf(0)    data\lib\managers\briefingmanager.dsf(0)    data\lib\managers\briefingmanager.dsf(0)    data\lib\managers\briefingmanager.dsf(0)Renderer: threadedPhysics : threaded

 

WHAT is this??? please help!!!!!1

It happens everytime when i try to change my weapon b4 the mission or using a MULE supply truck

Posted By loubamboo on 19/02/08 07:12:35

  Dear Brettzie and fellow GRA Warfighters, hello!

  The good news is you can ignore my previous

post. The mod is working perfectly now.

I installed the 1.05 patch - 1.04 to 1.05 - because

i was running the 1.04 version and after that i installed the Brettzies weapons mod, version 1.41.

Everybody, just make sure you are running GRAW2, version 1.05 with Brettzies weapons mod, version 1.41.

Oh, and the mod is just beautiful! Congrats, Brettzie!

Now, Brettzie, can you tell me how i can make

the ghosts look like US Marines?

                                       Thank you,

                                       Lou

Posted By jericho on 19/02/08 18:15:46

for some reason with mod 1.41 and 1.05 i cant select any of the extended kits... this makes me a saaaaad paaanda!

Posted By Assault Panda on 19/02/08 18:17:28

oh, thats in coop mp, lan

 

Posted By Bundler manic on 19/02/08 20:27:54

i was wondering if its possible to bundle the bp_wpnpack folder so as to makes things a little cleaner... also was wondering if its possible to use this mod with any other mods, like the ultragor mod... cause ultragore would be cool, but the weapons are cooler....

 

Posted By ulatragore mod m16 on 19/02/08 22:07:08

was wondering if anyone has succesful conjoined these two mods(ultragore and bpweapon pack)?

 

Posted By JKGTR on 27/02/08 08:23:02

Thanks for the mod excellent work and runs fine for me, any thoughts on doing a mk43 mod1 ??? graw needs a m60 you all know it!

Posted By DJLD50 on 17/03/08 20:09:12

Hello I cant get the Mod to work! I have the V1.15 version of the patched game and I cant get it to work! I did the manual way and the easy way and not luck can you help me!!??

Posted By DJLD50 on 17/03/08 20:11:15

re: I have the 1.5 whatever of the patch and I tried all day to get it to work and now I am tired and mad, as to why if it is SOOO eeasy, why I cant get it to work... Email me @ DamienLD50@aol.com if you need to please... I am NewB when it come to modding and all.. so PLEASE HELP ME! :)

Posted By DJLD50 on 17/03/08 20:48:20

Hello! I just uninstalled my game and RE installed  it and installed the V.1.04 patch and I still dont get it to work!... LOL... can ANYONE tell me how you got it to work!? I extracted the "Local" (without quotes) File in the Local file in GRAW2: Local and that is not working. What am I doing wrong!? I have extracted the .rar file to my Local file under my GRAW2: Local as well and that does not work, I even tried the Manual way and I cant get it to work! ANY HELP IS GREATLY APPRECIATED!!! This is supposed to be EASY, but for me, Easy is like Hard... LMAO! :)

Posted By DJLD50 on 17/03/08 20:52:42

ok I got it to work but then this happens..............

 Crash in application version: 30621.2989

Unhandled exception - access violation

 

C STACK:                        graw2   (???) : ???

SCRIPT STACK: data\lib\managers\briefingmanager.dsf(0) data\lib\managers\briefingmanager.dsf(0) data\lib\managers\briefingmanager.dsf(0) data\lib\managers\briefingmanager.dsf(0) data\lib\managers\briefingmanager.dsf(0)

Renderer: threadedPhysics : threaded

 

what does this crash mean and how can I fix it?

Posted By DJLD50 on 17/03/08 22:03:55

OK! Sorry for all the posts... I was just moving stuff all around and got things to work FINE now! It is amazing what you can do when you "play" around with things... LOL... but anyway I downloaded the Version 1.05 patch and everything seems fine now. No crashes as of YET! Thanks for this weapon mod it is SOOO AWESOME!!! These weapons are soo much better, to me, than the ones already there!Smile

Posted By Solo on 18/03/08 16:36:37

Ni chuja nie chodzi na MP

Posted By sam on 22/03/08 15:56:09

i dont understand how to install it.....

Posted By aochi on 30/03/08 08:43:31

how i do to use the weapons?

Posted By rocwiler0 on 12/04/08 21:52:35

so i downloaded the new update how do i know if it is working

Posted By Mom on 14/04/08 09:33:58

How do I install this? No specific instructions here.

Posted By DJDXL on 24/04/08 18:03:49

the game crashes if i even click to change the primary weapon. None of the others, jsut the "Primary Weapons" And then I get this error:

 

 Crash in application version: 30621.2989Unhandled exception - access violationC STACK:                        graw2   (???) : ???SCRIPT STACK:    data\lib\managers\briefingmanager.dsf(0)    data\lib\managers\briefingmanager.dsf(0)    data\lib\managers\briefingmanager.dsf(0)Renderer: threadedPhysics : threaded

 

Any sugestions? 

Posted By NonLethalWeapon on 16/05/08 11:50:31

Brettzie can you make a GRAW mod with all these things in coz i dont have GRAW2 :(

Posted By Ewen on 17/05/08 17:14:49

Grenade Launcher for M4 and M16 doesnt work, seems to fire grenades direct upwardsanyone else have this problem or just me??

Posted By KrnSniper on 19/05/08 12:08:09

Is there a way to incorporate the MAGPUL MASADA mod into this mod? It would be nice to have the option to use the MASADA ontop of the other weapons within this mod.

Posted By KrnSniper on 19/05/08 12:11:43

I forgot to mention that I tried to copy some of the scripts and files from the MAGPUL MASADA mod into the Brettzies GRAW2 Weapons Pack mod (i.e. the xml documents and texture files), but the game would crash. So I just went back to the original Brettzies mod.

Posted By dsd on 04/06/08 16:04:29

krt

Posted By EST_Svennu on 04/06/08 16:07:07

Is there chance to play this mod on regular servers? if i go MP servers ses "you cant play with you version" or something...

Posted By Akira on 12/06/08 17:37:04

Hello, my previous 1.2 gave me a lot of kits in MP coop mode, now the 1.41 with 1.05 patch give me only new look and a kit with m1014, nothing more.

Is it possible? no m4, no m16, no sig552, why? sigh.....

 

Posted By neil on 19/06/08 02:57:46

 Brettzie, I cant get this mod to work. I was able to get the masada mod working, but no luck with this one.  I am using GRAW2 with the 1.05 patch installed and weapons pack v1.41 I chose to do the manual install method. The video plays but it crashes when I try to load a game. This is what the Error message says

Crash in application version: 30899.3048 data\lib\managers\groupmanager.dsf(-1): cant find member: base in type <void> SCRIPT STACK:     data\lib\managers\groupmanager.dsf(0)     data\lib\managers\instancedescriptionmanager.dsf(0)     data\lib\script_network\gametype\gametypecampaign.dsf(0)     data\lib\script_network\gametype\gametypecampaign.dsf(0)     data\lib\script_network\gametype\gametype.dsf(0)     data\lib\script_network\gametype\gametype.dsf(0)     data\lib\script_network\gametype\gametype.dsf(0)     data\lib\script_network\gametype\gametypecampaign.dsf(0)     data\lib\script_network\gametype\gametypecampaign.dsf(0)     data\lib\script_network\networkmanager.dsf(0)     data\lib\script_network\networkmanager.dsf(0)     data\lib\setups\setup.dsf(0)     data\level\level.dsf(0) Renderer: normal Physics : threaded

help me please.  Thank You, Neil - nswshadowarrior.neg@hotmail.com

Posted By ChallengerCC on 31/07/08 09:20:09

Work this mod with other langueges like german ??? I get everytime a crash if i start a singleplayer or mp game.

Posted By Paulie on 06/08/08 14:31:10

Does this replace any standard weapons?

Posted By I want this mod! on 09/08/08 10:00:06

I dont think I installed it right, but yet I did exactly as the manual said. Help please.

Posted By icewind on 23/08/08 06:20:59

This just sucks, sorry. I installed the 1.05 patch as told in the readme, install everything as in the readme, but it will always crash with these crash in application errors. I will try older patches now...

Posted By akira on 15/10/08 07:26:45

I dont know why, but 1.47 version doesnt work... I can play but the only new weapon I can use is m1014.. others I dont see...

Posted By kaiser on 16/10/08 09:22:42

well , i tried it but it didnot work i get the move toturial only and i made sure to follow your instructions threw but no matter how i try it did not work ? mind you also the Context.xml included is falty also.

any comments pls.

Posted By Jedo on 15/11/08 18:54:55

I installed this one on version 1.5 and I get an error.

 

Crash in application version: 30899.3048data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: material in type <void>SCRIPT STACK:    data\lib\units\types\weapons\bulletweapon.dsf(0)    data\lib\units\extensions\inventory.dsf(0)    data\lib\units\extensions\inventory.dsf(0)    data\lib\managers\instancedescriptionmanager.dsf(0)    data\lib\managers\instancedescriptionmanager.dsf(0)    data\lib\script_network\gametype\gametypecampaign.dsf(0)    data\lib\managers\briefingmanager.dsf(0)Renderer: threadedPhysics : threaded 

What the...

Posted By akira on 25/11/08 12:36:16

l reinstalled the game, patched 1.5 and installed the mod, it work perfectly!!!!

l have only one question, what is 1.47 mod version? l use 1.41...

Please, now implement p90pdw and m14 ebr....

Thanks. 

Posted By wicked end on 25/12/08 09:40:36

i have the 1.04 patch, will it work?

will it work with the magpul masada mod? 

Posted By Caribe95 on 27/01/09 07:47:33

Thanks, will try it

Posted By Ramster on 28/01/09 04:06:29

Excellent mod...been trying to install the older version for months,,,this one worked first try and "WOW" what a difference it made...well done Brett...really appreciate all the work you do...Cheers and thanks again

Posted By Pestbeule on 28/01/09 04:32:07

Thank you... Nice to see this awsome mod going forward...

Posted By Wrolak on 30/01/09 00:46:43

 Hi. I get this crash when i try to go to singleplayer so plz could somebody help me! TY

 

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"SCRIPT STACK:    data\lib\managers\groupmanager.dsf(0)    data\lib\managers\groupmanager.dsf(0)    data\lib\script_network\gametype\gametypecampaign.dsf(0)    data\lib\script_network\networkmanager.dsf(0)    data\lib\setups\setup.dsf(0)    data\level\level.dsf(0)Renderer: threadedPhysics : threaded

Posted By ZombiePhalanx on 31/01/09 06:50:17

Man you did it again - thx i love it Cool

Posted By Johnny on 03/02/09 10:56:17

the mod is very good. i only use the new weapons. but i miss the oldscool ghost scins. the digital camo ghosts. maybe you can create a special version with all the features of version 2.0 but with the standard ghosts

 thx greets

johnny

Posted By Wingman on 04/02/09 23:27:46

YES!! NEW VERSION!!!   2.0

Posted By Meek on 05/02/09 16:07:32

Theres still problems with the "No soldier template named stone" issue.

Fresh install of Graw2 -> updated to 1.05. Fresh Install of Vistax64 as well, no difference.

Loved all your mods though :)

Posted By Meek on 05/02/09 16:08:58

Sorry forgot a small matter. It was with Mod version 2.04b, the other versions links are dead. So cant speak for the other versions..

Posted By Meek on 05/02/09 17:47:35

I should had read the forum correct. the unbundled 2.0 worked as a charm. beautifull mod.

 

Sorry about the nonsense above

Post Comment
Posted By:

© GhostRecon.net