Jump to content

Launch Issue


Recommended Posts

Hello! Like many others I am experiencing launch issues. The game tries to boot but then kicks back to Steam with no error message. My computer specifications are as follows:

  • Make/Model: Lenovo Legion T5 28IMB05
  • Windows Version: Windows 10: 19041.867
  • CPU: Intel i7-10700 2.90GHz
  • Sound card: Not sure
  • Sound card driver: Not sure
  • Video card: NVIDIA GeForce RTX 2060
  • Video card driver: NVIDIA Studio Version 461.92
  • DirectX version: DirectX 12
  • System Ram: 16GB 
  • Video Ram: 6GB
  • IKE.log: ***** User's system configuration ***** 
          CPU: GenuineIntel 2903 MHz Pentium II
          RAM: 2048 MB
          O/S: Microsoft Windows NT Family 6.2  build 9200
    RSOptions: Could not open options file options.xml for reading, using defaults
    Ghost Recon (RELEASE)  version = 1.4.0.0(0)
    RSDisplayMgr::CreateGameWindow: Creating a 1920x1080 window at 0,0 on monitor Generic PnP Monitor attached to NVIDIA GeForce RTX 2060
    RSDisplayMgr::CreateGameWindow: Game running on primary display Generic PnP Monitor attached to NVIDIA GeForce RTX 2060
    RSDirect3DRenderer::Initialize3DEnvironment: Could not create device
    RSDirect3DRenderer: Could not initialize 3D environment
    RSDisplayMgr::CreateRenderer: Could not initialize renderer
    RSUIMgr::Initialize() : Could not initialize mDisplayMgrIkeGameMgr::Initialize() : Could not initialize UI_MGR: -1
  • IKEcrash.log: GhostRecon caused an Access Violation in module GhostRecon.exe at 0023:0051c320.
    Exception handler called in Main Thread.
    Error occurred at 4/4/2021 10:47:20.
    E:\SteamLibrary\steamapps\common\Ghost Recon\GhostRecon.exe, run by.
    16 processor(s), type 586.
    2048 MBytes physical memory.
    Read from location 00000008 caused an access violation.

I have tried the following fixes:

  • Renaming the "dbghelp.dll" file
  • Verifying game files
  • Flicker fix
  • Clean boot
  • Compatibility mode
  • Updating Windows and graphics driver
  • Adding an exception for Ghost Recon to Data Execution Prevention
  • Full McAfee scan
  • Disabled User Account Control
  • Verified application was not read-only
  • Disabled background apps

Any assistance would be greatly appreciated!

Link to comment
Share on other sites

This is a link to an options.xml you can drop in the main GR directory.
https://www.mediafire.com/file/bpnrsc7aumtncmc/options.xml/file

One is not present until the first successful launch so worth a try.
It can be edited with notepad and if you wish you can try it so that GR launches in windowed mode by editing this line in the options.xml
        <FullScreen>TRUE</FullScreen>  change TRUE to FALSE
If you get it to launch you can reset most of the options in the menus. The menus are displayed in 640x480 but ingame resolution can be set to whatever you wish in the menus.

You have already tried all things I would normally suggest. The Flicker Fix is no longer necessary as Microsoft fixed that several years ago.
I only started using Windows 10 after that problem was fixed. I’m using 19041.867 too.

The problems I have had was trying to run a disc version on Win7 and 10. The Steam version was the solution for me.
A couple of years ago I had an AMD GPU that I had to roll the drivers back to get GR to work.
Since that problem I updated the drivers for another game but renaming dbghelp.dll fixed it that time.
I never had any problems with a Nvidia card.

 

 

Edited by wombat50
  • Like 1
Link to comment
Share on other sites

Oh wow it worked thank you so much! I had to edit it as you suggested to launch in windowed mode for it to work. After it launches in windowed mode is there any way to force it into fullscreen rather than different display ratios?

Also, even though I do not have it installed on my system it is loading Island Thunder. Is there a way to only have it load the base game and Desert Siege? I ask because I typically play with my family who believe it or not is still playing on eMac computers and will not upgrade (Island Thunder was not made for Macs).

Link to comment
Share on other sites

My only suggestion is to turn this line in options.xml back to TRUE.         <FullScreen>FALSE</FullScreen>
I had heard some people had luck launching GR in Windowed Mode. I don't know the cause why it will not work full-screen.

I compared my current options.xml to the one I uploaded. I don't know if it makes any difference but
Make sure these line in the options.xml read as follows:
        <ShellBackgroundIndex>2</ShellBackgroundIndex>
        <FullScreen>TRUE</FullScreen>
        <VideoResolution Width = "1920" Height = "1080" BitDepth = "32"/>
        <CharVertexWeight>TRUE</CharVertexWeight>

To use base game and Desert Siege:
Launch GR and from the menus go to Options>Mods Tab and high light Island Thunder, press deactivate. Finally, press Accept

I am not familiar with Apple computers but there is a modder named ApexMods that has gotten Island Thunder to work on Macs.
I think his mod Heroes Unleashed is Mac friendly.
 

       

 

 

  • Thanks 1
Link to comment
Share on other sites

That seems to be the case for my computer as well. It will only launch GR in Windowed Mode for whatever reason. But it works! 

I was able to deactivate Island Thunder. All my issues have been resolved thank you very much for your assistance!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...