Jump to content

Screen flickering with Windows 10...


twcrash
 Share

Recommended Posts

The "mod" is a folder called "FXAAENBmotionblur", which I extracted the contents of the folder to my root GR installation. Not the mod folder itself, just the contents. After a quick revert of my previously modified options.xml file (I had changed the full screen settings from TRUE to FALSE prior) everything worked without any need for input, just launching GhostRecon.exe

  • Like 2
Link to comment
Share on other sites

Thanks for your very quick answer but no way ....i do that the first time i download the file : copy at the root of GR folder the content of "FXAAENBmotionblur" (8 files + one folder "injFX_Shaders") on my 2 pc 's with Windows 10 ...on one, i cannot launch GR with error message like " you have not direct x installed " or something like that and on the second , i can launch it but the screen flicker same way than prior to install the utility . Some idea ????? :bye:

Link to comment
Share on other sites

So I am about to try this, tomorrow probably.

If I am understanding this fix correctly, all that has to be done is to extract the contents of this package to the ROOT folder of the Ghost Recon install. Then nothing else is required to be done, no running of anything other than Ghost Recon executable?

Link to comment
Share on other sites

Not precisely. That package contains a folder, which has several files in it. The files in the folder need to be extracted to GR's root directory, not the parent folder of the "mod". Then, with the files moved, you do not need to do anything else to enable this.

Link to comment
Share on other sites

Yesss :bounce: it work for me also now , i put only the 3 directx .dll from the ENB folder in the root directory of GR but i have an error message for a d3dx9_26.dll missing and not present in ENB folder ...So , i find it on internet , put it also at the same place and "tadaaa ! " So , for me , i need 4 directx.dll to work but it's work ! Hope that trick survive the futures updates of Windows 10 ! and many thanks to have find the way to overcome this problem ....

Edited by Acehole
  • Like 3
Link to comment
Share on other sites

I believe the problem is related with refresh rate and vsync. GR runs well on window mode and with ENBSeries because in those modes it becomes limited to 60 fps (verified on steam overlay).
I tried to force vsync activation=ON on Nvidia control panel (both on global and program settings) to match display refresh rate @60hz (and this way to force 60 fps), but somehow the game when at fullscreen ignores the setting, boosting up to 2500fps on game's menu and 170fps in-game.

If we could make vsync to work maybe the game can be ran without any patches.

Any ideas?

Using final version of Windows 10 + latest Nvidia drivers.

  • Like 2
Link to comment
Share on other sites

Interesting contribution ruben. I've been a bit slow to try out the fix, busy busy, but I might be able to test your theory out because I have a gsync monitor which eliminates vsync issues by matching the display with the GPU output. I'll try it out ASAP....

  • Like 2
Link to comment
Share on other sites

I don't see where that would pertain to me or others in my boat. I haven't changed monitors or videos cards in 3 years and it only changed when Windows updated and we no longer downloaded DX9. Hence why it works when we drop the DLL's into the main folder. I personally didn't add any ENB stuff just the DLL's. So it couldn't be ENB or my refresh rate since it hasn't changed.

Edited by twcrash
Link to comment
Share on other sites

I just dropped one ENB's DLL into the main folder and it worked, but still it's a workaround... this DLL behave like a proxy to the DX's API and is limiting the refresh rate to 60 fps.

I had the game working on Win 8.1 before upgrading to Win 10. I believe the way that Win 10 renders the desktop and it's windowed apps is all in one big frame "3D accelerated", to support fluid animations and the switching on the fly from classic desktop to Tablet Mode (and further the "elasticity" of the apps to different resolutions and devices). I was able to verify this on VMware Fusion: putting the MS Word in Unity mode rendered a big white frame around me Word's application. This new overall render mode may be in sync with the monitor's refresh rate to avoid tearing (a thing that a end user does not want to see when using productivity apps).

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...