Jump to content

Recommended Posts

Yesterday, my brother and I tried to play the main game in Coop but we couldn't.

Same problem happened when we tried to connect in Guerrilla and Online match.

Last time I tried to play Coop campaign with my brother (about a month ago), we had the same problem. The only mode i can play online is Conflict and I cannot invite any friend for a match or join their game.

Is the Ubisoft servers not working? is this a problem with the Uplay account?

Anyone experienced this kind of trouble trying to play Coop?

Edited by diegomatias
Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...