Jump to content

Ghost Recon on Mac OS X 10.7 (Lion) and later


ApexMods
 Share

Recommended Posts

Ok, so I got it to work after doing the command.  When playing there is a stripe of brightly colored pixels whenever I move around in the map.  The FixMe.command itself had a runtime error (see below).  Same thing happened on wife's computer.

____________________

Clearing quarantine from /Users/claw/Downloads/Ghost Recon Wrapper

xattr: [Errno 1] Operation not permitted: '/Users/claw/Downloads/Ghost Recon Wrapper/Ghost Recon.app/Contents/Resources/dosdevices/z:'

xattr: No such file: /Users/claw/Downloads/Ghost Recon Wrapper/Ghost Recon.app/Contents/Resources/drive_c/users/Wineskin/Desktop/My Mac Desktop

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

[Process completed]





 

Link to comment
Share on other sites

Have a look at the ReadMe how to access the Wineskin utility. Launch it, click „Advanced“, then „Tools“, then „Refresh Wrapper“. Wait for it to finish, close Wineskin, and try the wrapper again.

Link to comment
Share on other sites

Sorry to hear that. I feel your pain, my little MacBook is falling apart, too. Guess the times when Apple produced quality are long gone. Ever since Steve left us, it‘s been going downhill. Shame.

Link to comment
Share on other sites

Hi - I have my new macbook pro (2020).  I tried the new file, did the fixme.command and then when I started up the game it blacked out the screen as it was about to begin (like normal), then I saw my mouse cursor enlarged a bit on the screen, then the program stopped and my desktop screen returned to normal.   Weird.  I tried refreshing the wrapper, but nothing changed.

  • Like 1
Link to comment
Share on other sites

I think I may know what’s going wrong there. It has something to do with the intro movies.

You could fix that by either installing Perian (which is probably no longer supported), or disable the quartz override in Wineskin > Advanced > Wine Config (not trivial).

I’ll try to work an easier solution.

Link to comment
Share on other sites

This is weird. Tried the wrapper again on another macOS Catalina MacBook Air without issues. Maybe it’s your MacBook Pro switching from integrated to discrete graphics card the wrapper doesn’t recognize or handle right. You can force which card to use with this: https://github.com/CodySchrank/gSwitch

Maybe that helps.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

Just came upon this thread today and wanted to give this a try on a ~2013 MacBook Pro running 10.13.6 but the Dropbox links in the OP seem to be broken.  @ApexMods, would greatly appreciate if you can look into that when you have a moment.  Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...