Jump to content

Beta is not loading?


TheMazinTar
 Share

Recommended Posts

I've gotten a beta key, downloaded the beta, gotten into gunsmith, but whenever I try to join a game it goes immediately to the screen with the Xbox controller and says it's loading, but nothing is happening! I must have been watching the screen for the pas twenty minutes!

Any help would be awesome.

Edited by Tinker
Title changed
Link to comment
Share on other sites

Welcome to the beta! This is pretty much status quo with this game since late lastnight. I tried again this morning and same issues. If you get connected to an inprogress game it seems to hang at the load. If you're lucky enough to get tossed into a loading lobby the game then seems to load ok after that.

Link to comment
Share on other sites

Welcome to the beta! This is pretty much status quo with this game since late lastnight. I tried again this morning and same issues. If you get connected to an inprogress game it seems to hang at the load. If you're lucky enough to get tossed into a loading lobby the game then seems to load ok after that.

Yeah, that's exactly what happened; I had to wait 'till the afternoon to get it to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...