Jump to content
Ghost Recon.net Forums

whats wrong with this script?


Recommended Posts

Can someone please tell me what is wrong with this script.

its supposed to activate a area and then the enemy that is placed just up from the area but nothing happens the game starts and runs the map but no enemies show up when i run through the area???

and its just me that is playing this on LAN.

area name is :area1

enemy id is:temp_wave

please help!!

the script follows:

<?xml version="1.0" encoding="ISO-8859-1"?>

<World>

<!-- World -->

<load_scene file="/data/levels/custom_levels/my_level/my_level.diesel" use_lightset="true" materials="/data/levels/custom_levels/my_level/materials.xml">

<object name="world_bb" hidden="true"/>

<object name="room01" hidden="true"/>

<object name="Plane01" hidden="true"/>

<global_ambient color="60 60 40"/>

</load_scene>

<load_scene file="/data/objects/lens/normal_lens.diesel">

<object name="normal_lens" hidden="true"/>

</load_scene>

<load_scene file="/data/objects/lens/zoom_lens.diesel">

<object name="zoom_lens" hidden="true"/>

</load_scene>

<script_data>

<xi:include href="/data/levels/common/common.xml#xpointer(/common/*)"/>

<area_group name="area1" area_name="area1" group="mp_players" interval="0.3" condition="1"/>

-<user name="user" type="once">

<trigger type="UnitInArea" area="area1"/>

<event name="activate_temp"/>

</user>

<event name="start_game">

<element type="UnitInArea" area=" area1" state="activtate" start_time="3"/>

<event name="activate_temp">

<element type="ActivateGroup" group_id="temp_wave" start_time="2"/>

<element type="UnitInArea" area="area1" state="deactivate" start_time="3"/>

</event>

<player name="player1" mod_name="OnFoot">

<spawn unit_name="ghost_player" object="spawn_player1"/>

</player>

<player name="player2" mod_name="OnFoot">

<spawn unit_name="ghost_player" object="spawn_player2"/>

</player>

<player name="player3" mod_name="OnFoot">

<spawn unit_name="ghost_player" object="spawn_player3"/>

</player>

<player name="player4" mod_name="OnFoot">

<spawn unit_name="ghost_player" object="spawn_player4"/>

</player>

<gametype_info name="enemies_to_kill" value="65"/>

<spawn_manager>

<!--<xi:include href="/data/levels/merge_xml/common_spawn.xml#xpointer(/to_include/spawn/*)"/> -->

</spawn_manager>

</script_data>

</World>

id be grateful for any help thank you in advance.

Edited by Tinker
Removed 4 other topics all asking the same question? Please do not cross post.
Link to post
Share on other sites

hi,

i wonder it doesnt crash! well anyway i quoted the script you posted and marked the things i seen in red.

1. the - infront of the trigger, dont know if it does a difference but it shouldn't be there.

2. that space in front of the area name, double check on that. 1 space will make it not work.

(hint: never use space use _ instead)

3. major mistake, you didn't close the start_game event.

change those and it should work.

<area_group name="area1" area_name="area1" group="mp_players" interval="0.3" condition="1"/>

-<user name="user" type="once">

<trigger type="UnitInArea" area="area1"/>

<event name="activate_temp"/>

</user>

<event name="start_game">

<element type="UnitInArea" area=" area1" state="activtate" start_time="3"/>

</event>

<event name="activate_temp">

<element type="ActivateGroup" group_id="temp_wave" start_time="2"/>

<element type="UnitInArea" area="area1" state="deactivate" start_time="3"/>

</event>

Link to post
Share on other sites

I suggest using a text editor with XML syntax highlighting, like Notepad++. It helps you avoid a lot of small mistakes by simply seeing that there are matching tags and is the highlighting breaks, doesn't show the right colors on parts you know are correct, you know you've done something wrong.

Even better is to use an editor that actually tells you where there is an error and why, like Eclipse.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...