Jump to content
Ghost Recon.net Forums

Objective not completing after vehicle destroying


Recommended Posts

Back again folks...sorry :dunce:

I have a vehicle to destory as an objective. As i enter area1 the mission objective appears in the hud and the waypoint shows, i explode the c4 destroy the vehicle but the objective does not update to complete neither does it disappear.


<event name="start_area1">

       <element type="UnitInArea" area="area1" state="deactivate"/>

       <element type="ActivateGroup" group_id="group1" start_time="0"/>

       <element type="ActivateGroup" group_id="gun1" start_time="0"/>

       <element type="ActivateGroup" group_id="gun2" start_time="0"/>

       <element type="EnableUnit" name_id="c4_aa1" start_time="3"/>

       <element type="Objective" id="obj1" state="add" headline_id="mx_obj1_head" txt_id="mx_obj1_txt" waypoint_id="mx_obj1_wp" waypoint="-281 1550 51" mode="1" start_time="3.0"/>

</event>       

       <event name="aa1_trigger">

       <element type="DisableUnit" name_id="c4_aa1" start_time="15"/>

</event>

       <event name="update_objective1">

       <element type="Objective" id="obj1" state="add" headline_id="mx_obj1_head" txt_id="mx_obj1_txt2" waypoint_id=" mx_obj1_wp" waypoint="-281 1550 51"mode="1" start_time="3.0"/>

</event>       

<event name="complete_objective1">

       <element type="Objective" id="obj1" state="remove" headline_id="mx_obj1_head" txt_id="mx_obj1_txt2" waypoint_id=" mx_obj1_wp" waypoint="-281 1550 51" mode="1" start_time="0.0"/>

</event>

Do i need to make the objective the c4?

Im obviously missing something but my tiny brain hasnt worked it out..any help would be appreciated

:wall:

Link to post
Share on other sites

shouldn't

state="remove"
be
state="complete"

? just an idea.

i might be making a stab in the dark here

and the start time on the Remove script is 0 not sure if that needs to be changed or not?

Edited by Zeealex
Link to post
Share on other sites

hi,

i never tried around much with the objective since it doesnt work on a dedicated server (even worse it will crash a dedi server),

but the remove objective line seems wrong.

try this event, that should at least remove it. it worked for me once.

<event name="complete_objective1">

<element type="Objective" id="obj1" state="remove" mode="1" start_time="0"/>

</event>

are you sure the trigger is right? you can always add tihs element for testing purpose:

its only usefull for testing, since only the host of a server will see that line.

<element type="ShowMessage" msg="you can type any text you want here!!!"/>

maybe that will help you a bit.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...