Jump to content

How to edit weapons for coop?!


Spik@
 Share

Recommended Posts

Try using the unbundler from the GRAW2 wiki. It's always worked for me.

Brettzie is right, the coop_templates xml from the patch contains 6 support kits and 14 assault kits (they added some shotgun kits).

PM me your email address and I will send you a copy.

Rahn

Link to comment
Share on other sites

  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

Ro ahn, :thumbsup:

Got your email today! Thanks!

I was awaiting them all day, but did not see them. They ended up between a mail for viagra (which I have no need for.... - no really I don't!) and a russian chick who somehow would like to be my friend?! Lmao,...guess she does not know me all that well! :D I'm going to get busy with it (the files that is!) and let you know how things went!

Have a nice day,

Spik@

Link to comment
Share on other sites

Rahn,

I have just tested the files and all seems well!!!

At first I did not place the coop_ranks.xml, but that did not seem to matter at all. Just to be sure I have added the folder .../levels/common and placed it anyway.

Nice!!! The browsing of kits does not cause crashes anymore. Now I'll just copy/paste some of my earlier work.

Untill next issue....ever so grateful.

Spik@

p.s. On behalf of my gf: do people still make new maps/coop missions for GRAW2?

_EDIT_

The shotgun rocks!!!!

Lol....while playing with the shotgun, my girlfriend started laughing loudly...Turns out me handling the shotgun doesn't show on her screen and it looks like I am some sort of monkey running around empty handed! LMAO!

If she is using the shotgun, I can't see it either, but she will still hold the primary in her hand on my screen. This is also with the M32.....

Is there no animation for these weapons?!

I copy/pasted all my changes from the old to the new xml's and at first I had a crash, but due to the excellent advise on the xml marker, I made the necessary changes rapidly.

I was thinking (yes I was :huh: ) of the following...Could it be possible to change/add some files, so we can use the option of artillery in coop (like there was in one of the missions)?

As we are playing with just the two of us I pumped up the kits, but this would be a neat addition too.

Edited by Spik@
Link to comment
Share on other sites

Spik@,

Glad to hear it! You will not need the coop_ranks.xml unless you decide to add more kits.

Yes there are people out there who still make missions. JohnTC02 is the most active and is an administrator on this site.

Artillery is controlled by the mission script and is not under the control of the player ........ too bad ...... would be cool. You can call in an artillery strike in campaign mode. It would be great to be able to do that in coop but that would be a question for John.

If you can't see the weapon in another players hands then it sounds like you have a problem with your 3rd person textures. Maybe you still have a problem with the patch. Don't really know how to help you there except to say you could try uninstalling/reinstalling the game and then install the patch, put your mods back in and see what happens.

Cheers,

Rahn

Link to comment
Share on other sites

Rahn,

Thanks. I'm glad too! :rocky:

Also pleased to hear that there are still some people out there who are willing to make maps/missions for this game! I think we are playing John's maps right now and enjoy them ever so much. (John, thank you for that).

[O/T removed]

As for the 3rd person textures/animation....I guess it's fine for now...As long as I see my gun, it's not a biggie.

Spik@

Link to comment
Share on other sites

  • 4 months later...

Hello All,

Here I am again.....I have managed to edit several kits to my liking and keep having fun with all the maps I've dl-ed.

Now I want to change some weapon stats, but as my changes don't crash the game, they do not work either....

Example: I want the SAW to have a little less recoil and be able to use all fire rates. 1/3/full auto.

I unbundled the weapon file (unit/weapons) and changed the stats there. I also changed the settings in the weapons.xml, but still nothing.

Can this be done and if so, how?!

Thanks,

SPik@

Link to comment
Share on other sites

Hey Spik@,

As far as I know you would need to edit the settings in the u_"weapon" xml inside the units/weapons folder. Reducing "spread" variables should make the guns more accurate. Reducing "recoil" variables should reduce recoil. Adjusting available rates of fire is done by changing the "fire_modes" variable: 1 = semi, 2 = semi+auto, 3 = semi+auto+burst etc.

I know for certain that the info for the fire_modes is accurate since I have worked with them personally. I think the "spread" variable does have an impact because I adjusted them while working with the shotgun for my mod. I'm not sure about the recoil variables and whether they work or not. I do know that weapon damage is controlled throught the weapon_data xml and not the u_weapon xml.

If you are interested in studying someone elses work, here is a link to the lonesoldiers' GRAW1 mod which focused on changing the behavior of the weapons to make them feel more like the real weapons. His work may be helpful.

Rahn

http://www.ghostrecon.net/files2/index.php?act=view&id=1249

Link to comment
Share on other sites

Rahn,

Thansk for your quick reply (as always).

I have changed these settings accordingly, but I feel it didn't change anything....

For instance I have changed the recoil and spread on the SAW and M240, but they keep 'bouncing' all over the place. And as for the fire rate...eventhough I changed this setting, it still only fires on full-auto.

As far as I can tell, I have changed the correct files and placed them in the correct location, but still no noticable change.

There is one thing that might be the reason, but I can't be sure (maybe you know?). As I still can't unbundle the patch bundle, I have used the u_weapon files from the quick.bundle. Could this be the reason? :unsure: IF this is the reason, would it be a lot of effort/work for you to send me the u_weapon files from the patch.bundle?

Also thanks for your earlier help with the adjusting of the kits. I have managed to create some awesome kits for ourselves and used more slots/weapons, which turned out to be very pleasant! At first I got a little crazy with it (ofcourse) and made some kits where we had way too much and any ordinary soldier would crumble under the sheer weight of it! :shifty: Just had to tweak it a little and divide the necessary equipment between the two of us.

Thanks & Best regards,

Spik@

Link to comment
Share on other sites

Rahn,

Thanks for the link, but I already found it before and indeed it was enlightning to some extent. But, as I changed the stats accordingly and the result is zero, I am kind of guessing it has more to do with me using the u_weapon xml's from the quick.bundle.

Eventhough perhaps the recoil and spread etc. is different (although I cannot notice any -significant- change), the rate of fire is not working. I have changed the settings in the u_weapon file and also in the weapons.xml (eventhough that doesn't do anything ingame). The fire rate for the SAW and M240 is still only full-auto.

I even thought it could have something to do with the sort of weapon (support) and maybe it will not allow you to change these specific guns, but I also tried the RX4 to get it to fire at 1/3/full auto, but this doesn't work either.

Just for your information and to check if the path is the correct, I have placed the u_weapon xml's in; ...Local / English / Data / Units / Weapons.

Thanks for your support,

Regards,

Spik@

Link to comment
Share on other sites

Spik@,

There must be some sort of problem since the rate of fire should definintely change for you. I will put together a little mod for you and send you a link to it. I'll try and work on it later this evening.

Rahn

Link to comment
Share on other sites

Rahn,

Thanks.

Can you confirm that it is not the mapstructure or the fact that the u_weapon files come from the quick.bundle instead of the patch.bundle?

If I know this is all correct, I can see if there is something else going on....

Thank you for taking the effort of helping me!!!

Spik@

Link to comment
Share on other sites

Spik@,

You do need to include and change the .xmls from the patch.bundle as they override the ones in the objects.bundle.

u_saw.xml and u_m240.xml.

Bob

Bob,

Thanks. So the fact that I used the u_weapon xml's from the quick.bundle and not the patch.bundle is the problem?

Regards,

Spik@.

p.s. Are you Mexbob that made some maps? :rocky:

Link to comment
Share on other sites

Bob,

I have recieved the zip file and I will see if this will do the trick. Thank you for sending me this. I don't know how much effort this will cost, but as I cannot unbundle the patch.bundle (Unbundler and another way Rahn showed/send me, both dont work for me!?) I would like to have all of the weapons.xml's..... :unsure: Would it be too much to ask to zip all others for me too?

If you can't, don't want to or it is too much of an effort, consider this request as too cheeky of me. :rolleyes:

Also I would like to thank you for making the maps!

We (me and gf) downloaded a whole bunch of them (inlcuding yours) and everytime it's a real suprise to see what effort has been put into them!

Already being on 'the path of cheeky-ness'....: more coming??? 0:)

Best regards,

Spik@

Link to comment
Share on other sites

Spik@,

Here is the small Local file override that I put together. If you run it and pick the rx4 it should start out in single shot and you can scroll through all three firemodes. So you can see that the firemode override does work. The group_manager file is one that I copied from my mod since I could not find the original. But it still works fine.

I don't know if it will help but I have had a similar problem with my system. I am running win7 64 bit and I have noticed that any changes that I make to a given file may not actually save unless the file itself is first moved to the desktop. If I try to make changes to any folder/file which is still inside of of another directory (other than actually on my desktop) then really wierd things happen. Some changes may save and others won't. This caused me no end of frustration and I am supposing has something to do with the new security features of win7. So you may try moving any files you want to edit directly to your desktop and open/edit them from there. It's something to try at least ........... Either that or make sure that your security settings allow you to make changes inside the GRAW2 directory.

http://www.mediafire.com/?da8fzb86tyg758l

Cheers,

Rahn

Link to comment
Share on other sites

Rahn,

Thanks for the file(s). I haven't had time to play with them as I have been 'running around' in the Military Aviation Musuem today! :rolleyes:

I am also running Windows 7 - 64 bit, but the other files I editted before (coop_templates.xml) where in the Local folder when I did the editting and these changes worked fine?! I guess that if, what you describe, was the problem, these files shouldnt work either?!

Oh well,...I will drag myself to my PC and play around with the files you guys mailed me and I will let you know what works and what not (but, I have faith in you guys, so I am sure that with your assistance I will be able to make to changes I want)

@Mexbob: Sorry I asked for new maps. I didnt realize that you made one not so long ago! :shifty:

Thanks & regards,

Spik@

Link to comment
Share on other sites

Bob,

Are you sure you zipped the whole weapons file from Local? Both zip files you mailed me only contain the SAW, M240, Barrett, HK21e, M1014 and Add-Ons.xml

Or is this the weapons folder from the patch and does it only contain these weapons?

Thx,

Spik@

#EDIT#

I think I figured out what I did wrong.....

The path where I had put the files was: Local / English / Data / Units / Weapons.

The correct path should be...Local / English / Data / Units / Weapons (So WITHOUT the map Data in it)

All u_weapons files from the quick.bundle work, so it had nothing to do with which bundle they came from, but everything to do with where the files were located!

@Rahn: RX4 does work now and the other changes I made work too!

Edited by Spik@
Link to comment
Share on other sites

Rahn,

You are so right! :thumbsup: Thinking you've done all the steps and things don't seem to work anyway. It can get to you!! :shifty:

Thanks to your file I noticed that Data does not belong in the path. As soon as I removed that step, all my changes worked.

I keep trying to tinker with it and everytime I think of something I want to figure it out, so I guess I will be back!

One thing I was wondering....is it possible to use the C4 on all vehicles, eventhough they are not part of a script or objective? I have seen the u_c4.xml and I started wondering if that could be done....(maybe use it as a boobytrap or distraction).

Thanks!

Spik@

Link to comment
Share on other sites

Spik@,

I believe it is possible to put C4 on just about anything. JohnTC02 figured out a way to do it a while back. Unfortunately, I believe it has to be scripted into the mission. I don't think it can be controlled from the player side.

Rahn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...