Jump to content

Canon 40D and Error 99


Fletch
 Share

Recommended Posts

Nah, did the firmware first and then all the fixes listed here and there on the net, (remove both batteries, lens, clean lens contacts, reassemble) and nothing worked, in fact it got worse. Went from Error 99 everytime I pressed the shutter to the camera shutting off when I pressed it. Took it to the Service Center, out of warrenty of course, so it will be my cost to repair.

Link to comment
Share on other sites

  • 4 weeks later...

Just got the camera back today, they replaced the shutter motor assembly and fixed the power diaphragm assembly in the Lens as well. Cost $189.00, plan on taking it out this weekend and test it out.

Link to comment
Share on other sites

  • 3 weeks later...

I was finally able to get out this Sat and take a couple of photos. I like this one of this Feral Cat up at the Aiea Height Trail. If you look close it appears he stopped on a yellow X and posed for the picture.

AieaTrailCat2.jpg

Edited by Fletch
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...