Jump to content

Can't get GR to start (Valve/Steam issue?)


traycerb
 Share

Recommended Posts

Steam had a Ghost Recon package deal over the weekend, so I jumped on it.

Tried playing the original GR on my machine (xp/sp3, 2.4ghz c2d, radeon 3850, 4gb ram), but it gave a "ghostrecon.exe has encountered a problem" error and closes to desktop. My Ike.log is below, and searching the forums, I found one person with the same issue, but that was 5 yrs ago :blink: and the solution was to revert to DX8 :blink: . Steam has an option to "verify integrity" of the game cache, and it checks out. Any ideas? My other non-ghost-recon games on Steam work fine (eg HL2, CS:S, etc). Microsoft support site has an error article about xp+recon, but their advice is to unhelpfully suggest reinstalling.

I'll add the a brief version of the dxdiag output, but i don't think thats the problem (the sound tab is mysteriously empty below, but all sound works fine on my system)

********************Ike.log*************

***** User's system configuration *****

CPU: GenuineIntel 2400 MHz Recent Intel

RAM: 2048 MB

O/S: Microsoft Windows 2000 5.1 Service Pack 3 build 2600

RSOptions: Could not open options file options.xml for reading, using defaults

Ghost Recon (RELEASE) version = 1.4.0.0(0)

RSDisplayMgr::CreateGameWindow: Creating a 1920x1200 window at 0,0 on monitor Plug and Play Monitor attached to ATI Radeon HD 3800 Series

RSDisplayMgr::CreateGameWindow: Game running on primary display Plug and Play Monitor attached to ATI Radeon HD 3800 Series

RSDirect3DRenderer::Initialize3DEnvironment: Could not create device

RSDirect3DRenderer: Could not initialize 3D environment

RSDisplayMgr::CreateRenderer: Could not initialize renderer

RSUIMgr::Initialize() : Could not initialize mDisplayMgrIkeGameMgr::Initialize() : Could not initialize UI_MGR: -1

********************DXDIAG*************

------------------

System Information

------------------

Time of this report: 2/9/2009, 12:11:31

Machine name: E6600CORE2DUO

Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp.080413-2111)

Language: English (Regional Setting: English)

System Manufacturer: GBT___

System Model: GBTUACPI

BIOS: Award Modular BIOS v6.00PG

Processor: IntelĀ® Core2 CPU 6600 @ 2.40GHz (2 CPUs)

Memory: 3326MB RAM

Page File: 1985MB used, 1434MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 10.0 (4.10.0000.6000)

DX Setup Parameters: Not found

DxDiag Version: 5.03.2600.5512 32bit Unicode

------------

DxDiag Notes

------------

DirectX Files Tab: No problems found.

Display Tab 1: No problems found.

Sound Tab 1:

Music Tab: No problems found.

Input Tab: No problems found.

Network Tab: No problems found.

Link to comment
Share on other sites

RSDirect3DRenderer::Initialize3DEnvironment: Could not create device

RSDirect3DRenderer: Could not initialize 3D environment

RSDisplayMgr::CreateRenderer: Could not initialize renderer

I had this a month or two ago. Unlike you I couldn't play any games.

I have had GR installed on this format for a year or more.

Not sure how I sorted the issue but I did update my vid card drivers.

I did not have to reinstall GR.

Sound Tab 1:

Unsure about this one.

GR can be touchy about sound card and vid card drivers.

If they are on the oldish side it may improve overall computer performance to update them and may on the off chance let you play GR. As you probably know your computer is more then capable of playing GR.

Hope you get it sorted.

Link to comment
Share on other sites

Hmmm, it looks like you are trying to play at 1920x1200 and that you do not have an options.xml. I would suggest that you start by creating an options.xml (you may need someone to send you one), and setting it to initially start the game at a lower resolution and to run it in a window. It may well be that GR is just not sure how to initialize DirectX at that resolution properly.

The bit about "RSDirect3DRenderer::Initialize3DEnvironment: Could not create device" is a clear indication that the game is having trouble getting DirectX properly initialized.

Link to comment
Share on other sites

start by creating an options.xml (you may need someone to send you one), and setting it to initially start the game at a lower resolution and to run it in a window.

thanks for the responses all. will try them all out. Thought I'd be out of luck trying to play an older game.

anyway, anyone willing to PM me an options.xml? Or, better yet, post one to a file-sharing site, in case anyone else needs one besides?

Link to comment
Share on other sites

options.xml

http://files.filefront.com/13255475

Allot of this can be set to your liking in Main Menu/Options

if it gets the game to launch.

It's odd the game didn't install an options.xml.

Did you look in the GR main directory to see if it was there or not?

Keep posting ike.log if you still have trouble.

Link to comment
Share on other sites

It's odd the game didn't install an options.xml.

It's actually normal. Options.xml isn't created during install, it's created on first successful run, as long as you get to the main menu. If you don't get that far, the file won't exist.

Link to comment
Share on other sites

options.xml

http://files.filefront.com/13255475

It's odd the game didn't install an options.xml.

Did you look in the GR main directory to see if it was there or not?

thanks mate. that did the trick. Changed the full-screen option to FALSE in the .xml file and GR loaded fine. I guess that means no full-screen, but I can change the resolution within the game, including to a windowed 1920x1200 (my monitor's natural resolution).

yeah, it's odd the options.xml file wasn't loaded with the game, and it definitely wasn't there before. I had searched not just the ghost recon directory, but all of steam's directories before requesting it. GR probably uses internal settings for the initial defaults, then writes them to file when it successfully loads. It just never got to that point... [EDIT: ah Dannik beat me to it :)]

Oh, and at least one other person reports the same problem on the Steam's GR forums. I'll point them over here.

Edited by traycerb
Link to comment
Share on other sites

I think I know what the problem is, or at least a major player.

GR forces a fixed resolution of 640x480 for all non-in-game screens. If your current video card/drivers/monitor can't accept that resolution, the game will never hit the first menu.

Edit: This explains why it worked windowed, but not fullscreen. Displaying a 640x480 window is nothing. But, forcing a modern system to display it fullscreen isn't really that common anymore, and is likely not supported by many people's systems.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

It's not just a issue with the Valve/Steam version of the game. The same problem occurs with the original versions once you install "Island Thunder" or upgrade to version 1.4. I know, it happened to me.

But I might have good news: I because of another thread here, tried changing, once the game had ran (I had the same problem) the full screen false to full screen true in the XML file and the game ran perfectly! Apparently once the game has ran with the false full screen, the video card can "understand" the menu resolution, and you can then change it back to true.

But back up you options file just in case.

BTW the same trick works for Sum Of All Fears. In fact the downloaded options film works fine for getting SOAF to run for the first time.

I have a feeling what happened was that the 1.4 patch somehow messed up the XML options file.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...