Jump to content

Brettzies Weapons Pack V2.*


Brettzies
 Share

Recommended Posts

  • Replies 311
  • Created
  • Last Reply

Top Posters In This Topic

Hey Brettzies, could you help a poor old guy install your mod. I got WinRar and was able to get it unzipped but when I tried to install to LOCAL folder................just doesn't show up.

Once I DL,

I have it on the WinRar

then I extract to the GRAW2 LOCAL folder................what am I missing?

never had this much trouble with GR 1 mods.

Thankyou

Link to comment
Share on other sites

Hey Brettzies, could you help a poor old guy install your mod. I got WinRar and was able to get it unzipped but when I tried to install to LOCAL folder................just doesn't show up.

Once I DL,

I have it on the WinRar

then I extract to the GRAW2 LOCAL folder................what am I missing?

never had this much trouble with GR 1 mods.

Thankyou

I just use winzip myself, but if you look at the readme, it will tell you where to put the files if you have to manually install them. The only thing I forgot to put in there if you do manual install is the .bundle file goes in the /mods folder. Or you can just copy the mods folder into your Graw2 dir which is usually called: Ghost Recon Advanced Warfighter 2. Originally didn't do a bundle so the instructions were for the unbunled version, but it's still pretty much the same thing.

You might be getting confused with the zip inside the zip file(bp_weapons_pack_v2.05b.zip). That's the one you have to extract.

Link to comment
Share on other sites

Some people have asked me how to setup a Brettzies modded server.

Brett Initially helped get me started and was very patient.

If any of you would like to set up a server using this mod I posted detailed instructions of how our server is set up on our forum here.

This is a great mod.

Thanks

Link to comment
Share on other sites

CTD issue using Bretzies v2.05b (not v2.05, I could not connect to the Sparta server with 2.05). Links to each separate download in the last comment post on the GhostRecon.net download page for Bretzies mod.

Version 2.05b .zip file dated : Feb 8, 2009

Version 2.05 .zip file dated : Feb 20, 2009

Server running mission: coop_bogie_occupation_v3

(game would not start while the coop_bogie_occupation_v4.bundle file was present in the "custom_levels" folder, error message about a bad path... but that's a different issue)

Joined okay, in the class selection page I scrolled through the Rifleman classes. When I got past #12, I got the following DTD error message

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "coop_rifleman_13"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\guiscreens.dsf(0)

data\lib\managers\guiscreens.dsf(0)

Renderer: threaded

Physics : threaded

I rather expected to either hit the end of the class and have to scroll backwards or have the class roll over back to #1.

Edited by Satoh
Link to comment
Share on other sites

CTD issue using Bretzies v2.05b (not v2.05, I could not connect to the Sparta server with 2.05). Links to each separate download in the last comment post on the GhostRecon.net download page for Bretzies mod.

Version 2.05b .zip file dated : Feb 8, 2009

Version 2.05 .zip file dated : Feb 20, 2009

Server running mission: coop_bogie_occupation_v3

(game would not start while the coop_bogie_occupation_v4.bundle file was present in the "custom_levels" folder, error message about a bad path... but that's a different issue)

Joined okay, in the class selection page I scrolled through the Rifleman classes. When I got past #12, I got the following DTD error message

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "coop_rifleman_13"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\guiscreens.dsf(0)

data\lib\managers\guiscreens.dsf(0)

Renderer: threaded

Physics : threaded

I rather expected to either hit the end of the class and have to scroll backwards or have the class roll over back to #1.

If you are on Vista, you can try doing this:

>>> To clean out XMB files in Vista, go to your user folder, into

>>> AppData/Local/GRAW2 and kill all XMB files except those in the

>>> "settings" folder. Then it will recompile with whatever mod you are

>>> using.

>>>

>>> It usually works.

>>>

>>> Remember that to stop using the mod you may need to to the same

>>> thing again.

Otherwise, I don't know what to tell you, some people have a really difficult time getting the .bundle version to work which I think is necessary for online play.

Hey brettzies first just wanted to say the mod has come a long wayyy and just gets better and better each time keep up the good work

anyways just wanted do you have any plans on updating the weapon pack ?

Glad you like it. Sometimes I do think about adding more, but it can be a real chore building and texturing just one weapon, let alone different gear(helmets, goggles, etc) for the ghosts to use. I'm kind of surprised this game is still going, but that's cool I guess. Plus, it's still very limited in several ways, attachment id#s are maxed out for Mp.

Link to comment
Share on other sites

If you are on Vista, you can try doing this:

>>> To clean out XMB files in Vista, go to your user folder, into

>>> AppData/Local/GRAW2 and kill all XMB files except those in the

>>> "settings" folder. Then it will recompile with whatever mod you are

>>> using.

>>>

>>> It usually works.

>>>

>>> Remember that to stop using the mod you may need to to the same

>>> thing again.

Oops, forgot to mention I'm on XP ... Did a search through my C: drive for "*.xmb" but didn't come up with anything. I assume the info you provided is somewhere within this thread, I'll do some searching for XP fixes for the issue. Thanks for the reply, and thanks for all the time and effort it has taken to produce such a detailed mod.

Link to comment
Share on other sites

CTD issue using Bretzies v2.05b (not v2.05, I could not connect to the Sparta server with 2.05). Links to each separate download in the last comment post on the GhostRecon.net download page for Bretzies mod.

Version 2.05b .zip file dated : Feb 8, 2009

Version 2.05 .zip file dated : Feb 20, 2009

Server running mission: coop_bogie_occupation_v3

(game would not start while the coop_bogie_occupation_v4.bundle file was present in the "custom_levels" folder, error message about a bad path... but that's a different issue)

I have updated coop_bogie_occupation_v3 to v4

Link to comment
Share on other sites

  • 3 weeks later...

I just reinstalled GRAW 2 and patched it up to 1.05 and installed your mod. The game loads fine up until I go to start any mission. It crashes and I get the following error.

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

I have Vista with 4GB of RAM and i have v2.05b install

Can you upload the unbundled v2.05 in moddb because the filefront doesn't give me permission to download it

Link to comment
Share on other sites

First i should say i have upgraded to patch 1.05, and have installed Brettzies weapon mod via Method 1 according to his PDF. I start the game up and i try to load the tutorial mission. i get this Crash message:

Crash in application version: 30899.3048

data\lib\managers\eventmanager.dsf(-1): cant find member: _unit_name in type <void>

SCRIPT STACK:

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

When i try to start the actual first mission of the game, I get this crash message:

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

I have not played this game before yet and really want to with Brettzies weapon mod. Does anyone know what the problem is and how to fix it?

*i should also add that when i play the game without the weapon mod it runs fine. so any suggestions?

[Merged with relavent thread]

Edited by Tinker
Link to comment
Share on other sites

I just reinstalled GRAW 2 and patched it up to 1.05 and installed your mod. The game loads fine up until I go to start any mission. It crashes and I get the following error.

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

I have Vista with 4GB of RAM and i have v2.05b install

Can you upload the unbundled v2.05 in moddb because the filefront doesn't give me permission to download it

I'm getting the exact same problem. Is this just a problem with the bundled version?

Link to comment
Share on other sites

Okay well the game starts up fine with the new movie brettzie made and and i can get to the main menu. But when i try to start a new campaign, (i just got this game) i get this crash message:

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

I have installed the latest patch and brettzies mod is v.2.0 im not very good at reading these lines and so, does anyone know what the problem is? Please i really want to play this game.

[Merged with relevant thread (same as your previous post)]

Edited by Pave Low
Link to comment
Share on other sites

I just reinstalled GRAW 2 and patched it up to 1.05 and installed your mod. The game loads fine up until I go to start any mission. It crashes and I get the following error.

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

I have Vista with 4GB of RAM and i have v2.05b install

Can you upload the unbundled v2.05 in moddb because the filefront doesn't give me permission to download it

I'm getting the exact same problem. Is this just a problem with the bundled version?

Most likely it's something on your computer. You can try this:

> To clean out XMB files in Vista, go to your user folder, into

> AppData/Local/GRAW2 and kill all XMB files except those in the

> "settings" folder. Then it will recompile with whatever mod you are

> using.

>

> It usually works.

I've also uploaded both version to the moddb in one file since file front is going bye-bye and I don't want to start a new page for it. The download is twice as big but oh well. So, downloading that version will have both bundled and non-bundled versions in the zip file.

Edited by Brettzies
Link to comment
Share on other sites

I added the 3rd Person version to the Downloads in the first post. Because FileFront is going away at the end of this month, Moddb is my only option right now. However, it won't be active until one of the admins over there checks it out and approves it virus free, etc. Sorry for the inconvenience. Not sure when it will go active(but I can't wait around before posting), hopefully in the next few hours. The 1st person version with both bundle and un-bundled files went quick, so cross your fingers if you want to try the 3rd person version out.

Link to comment
Share on other sites

Are the two txt files (eg 2.05_non_bundled_verson.txt) meant to be empty?

I'm confused as to where exactly to put the camera settings.xml, if I put it in the settings folder I don't see a difference between them.

The 3rd person view is really cool though, I'll probably play with this on by default from now on...

Preparing a HD movie now....

Link to comment
Share on other sites

Yes, they are empty. I just put those in so that people would know the difference between the two zip files. I guess I should have written something in there.

The camera_settings.xml goes in local/bp_weapons_pack_v2.05.ots/settings ( i think that's the path). Basically, you just pick which one you want and copy it out of its folder and put it in there. The default is medium, so if you try that one, nothing will be different. I only included it to be safe. I tested this a few times, so it should work, but I'll try it again when I get home.

Link to comment
Share on other sites

Probably a good idea to delete those too. Sounds like on Vista, those get copied somehow into that directory. Since the mod has compile=false then it won't make those into xmb files I suppose, but it could have old xmls that over-ride the mod?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...