Jump to content
Ghost Recon.net Forums

Brettzies Weapons Pack V2.*


Recommended Posts

I will definitely try to get on Sparta's server this weekend. It will be nice to play the mod on a dedicated server (hopefully with other people) which is also running some of the recently released coop maps.

Great job zeno.

Link to post
Share on other sites
  • Replies 311
  • Created
  • Last Reply

Top Posters In This Topic

like the mod but i kept crashin to the desktop after 5 min of play in my friends server with a addon_data crash (and it kept crashin after when i chose a weapon) so i started my server and i played fine but my friend got the same crash after 5 min and could not rejoin either :( wish u could fix it love the guns

Link to post
Share on other sites

like the mod but i kept crashin to the desktop after 5 min of play in my friends server with a addon_data crash (and it kept crashin after when i chose a weapon) so i started my server and i played fine but my friend got the same crash after 5 min and could not rejoin either :( wish u could fix it love the guns

Which map is it? I'm not sure it's the mod, could be the map, or other modifications you might have going on. That error means an attachment is out of range. Did you try the bundle version?

Link to post
Share on other sites

Great Mod, like it very much. Will try it in Coop tonight.

Except bug-killing, what are your thoughts for the future of this project? More weapons/attachments?

So far the only thing that bothers me is the size and brightness of the holosight. A bit too red, too bright... too big maybe too? Just my impression.

Is there a way to fix that on my own?

Link to post
Share on other sites

The Dedicated server runs fine, but we get local crashes with this message.

"Crash in application version: 30899.3048

data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: addon_data in type <Unit>

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : threaded"

Mostly this occurs upon entering the map after weapon selection, but sometime occurs 5 - 10 minutes into the map.

I am trying to isolate the maps where this crash occurs

So far I get crashes after weapon selection on the following maps

coop_Bogie_OccupationDay_v3

coop_Bogie_Oasis_Day_v2

coop_Bogie_OceanicDay_v3

coop_youppi

coop_timber

I do not get post weapon selection crashes on

coop_quarry

coop_invasion

coop_retrieve

coop_crashsite_v2

I will add to this list as I work through the maps

Also when my local game crashes the server jumps immediately to the next map

Anything obviously wrong.

Edited by zeno
Link to post
Share on other sites

The Dedicated server runs fine, but we get local crashes with this message.

"Crash in application version: 30899.3048

data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: addon_data in type <Unit>

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : threaded"

Mostly this occurs upon entering the map after weapon selection, but sometime occurs 5 - 10 minutes into the map.

I am trying to isolate the maps where this crash occurs

So far I get crashes after weapon selection on the following maps

coop_Bogie_OccupationDay_v3

coop_Bogie_Oasis_Day_v2

coop_Bogie_OceanicDay_v3

coop_youppi

coop_timber

I do not get post weapon selection crashes on

coop_quarry

coop_invasion

coop_retrieve

coop_crashsite_v2

I will add to this list as I work through the maps

Also when my local game crashes the server jumps immediately to the next map

Anything obviously wrong.

Thanks for the info. The error is definitely an attachment issue. But, I'm wondering if the maps you listed have a special script they are calling for a weapon with an attachment that is out of "safe" range, since they are all custom maps. Coop_timber seems like it shouldn't crash though. I've looked through parts of that one and don't know why. However, I also don't totally know how maps work and what scipts they inlcude. If they are using a special groups.xml then that most likely has attachments that I took out, such as the flashlight. Technically those attachment are not out, just out of the safe multiplayer range 1-31.

Also, I think if you are running the bundle, then dont' have the non-bunbled version installed also. It should work, but files in the local folder over-ride everything. Even though it's the same, it might cause issues. The only files that should be in the local/bp_weapons_pack_v2.0 should be movies and sound folders.

When it does crash, do you know what's happening? Is a new enemy coming out? I know before the RPG was porbably an issue.

Great Mod, like it very much. Will try it in Coop tonight.

Except bug-killing, what are your thoughts for the future of this project? More weapons/attachments?

So far the only thing that bothers me is the size and brightness of the holosight. A bit too red, too bright... too big maybe too? Just my impression.

Is there a way to fix that on my own?

Yeah. I think you can go into the gui/ folder if you have the non-bundle version and play with the settings for the comabsight gui. It's the same as the mrc one though. I didn't anything special too it. Edited by Brettzies
Link to post
Share on other sites
The Dedicated server runs fine, but we get local crashes with this message.

"Crash in application version: 30899.3048

data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: addon_data in type <Unit>

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : threaded"

Mostly this occurs upon entering the map after weapon selection, but sometime occurs 5 - 10 minutes into the map.

Same for us, had this firt time on coop mission 2, skipped it and at the beginning of M3 my buddy crashed again. This seem to happen only to clients, not to hosts.

Hate to say, but this mod isnt playable/enjoyable in MP so far...

Link to post
Share on other sites

When it does crash, do you know what's happening? Is a new enemy coming out? I know before the RPG was porbably an issue.

As soon as you pick your first weapon and spawn into the map the game crashes locally. 1-2 secs max

Our guys are running online servers off there own pc (not dedicated) with no crashes for hours on end using the same custom maps. Unfortunately noone can join them. I will ask them to note any maps that do crash.

Timber definitely crashes

I checked the local file and it contains only the folders you mentioned.

Edited by zeno
Link to post
Share on other sites

yup same for me and my friend as zeno is gettin and u can add boogie new map relative_sanctuary to the crash list as well and no i dont have any other mods just 2.0 and i tried both versions with same effect

Link to post
Share on other sites

When it does crash, do you know what's happening? Is a new enemy coming out? I know before the RPG was porbably an issue.

As soon as you pick your first weapon and spawn into the map the game crashes locally. 1-2 secs max

Our guys are running online servers off there own pc (not dedicated) with no crashes for hours on end using the same custom maps. Unfortunately noone can join them. I will ask them to note any maps that do crash.

Timber definitely crashes

I checked the local file and it contains only the folders you mentioned.

Okay, I found what I hope is the last problem with these attachments. Turns out some maps also use the ageia_groups.xml This has some attachements out of range like the flashlight and redundant scar tac grip...which is the same as scarh tac grip. I took them all out.

bp weapons pack v2.01 patch - File Front

Try out this little patch(with either version, bundled or not) and see if it fixes the issues. You'll know it's installed when you goto Options at the bottom the game version will have bp_weapons_pack_v2.01 next to it.

To install, use the same as the main version. If you're not using the bunlde, then overwrite the mod_version.xml if promted. Other wise, it should just add two folders, lib and settings.

If this works, I will add it to the main download and as a patch.

Link to post
Share on other sites

Ok I have made the changes

1 I had to change my home setup from local to mod otherwise I couldnt join the server (which I only managed to setup as a mod)

2 Mysteriously your little intro video no longer works, I just get a blank screen then I when I press enter I get the main menu

3 Definite improvement, maps which crashed immediately following weapon selection actually played for a little while

4 every map stock or modded can crash locally and still does

5 although the server does not crash per se, it does move on to the next map when I crash locally (I need to check this when other players are in the server). Having said that the server restarted without a crash report after I crashed locally whist playing coop_bogie_oasis_day_v2

6 Is it normal for the Mk18 (secondary weapon in sniper kit 14) to make no noise at all.

I hope this helps narrow the investigation

[edit - it seems the sig 552 sd is now inaudible so it could be an error in the little patch affecting all silenced weapons)

Edited by zeno
Link to post
Share on other sites

Ok I have made the changes

1 I had to change my home setup from local to mod otherwise I couldnt join the server (which I only managed to setup as a mod)

2 Mysteriously your little intro video no longer works, I just get a blank screen then I when I press enter I get the main menu

3 Definite improvement, maps which crashed immediately following weapon selection actually played for a little while

4 every map stock or modded can crash locally and still does

5 although the server does not crash per se, it does move on to the next map when I crash locally (I need to check this when other players are in the server). Having said that the server restarted without a crash report after I crashed locally whist playing coop_bogie_oasis_day_v2

6 Is it normal for the Mk18 (secondary weapon in sniper kit 14) to make no noise at all.

I hope this helps narrow the investigation

[edit - it seems the sig 552 sd is now inaudible so it could be an error in the little patch affecting all silenced weapons)

Dang. Try getting the full mod on the first page since it has everything bundled again. Sound annomilies are common and usually unexplainable.

I dont' think you should be running a local version of the mod really if you want to play MP. Better for both the server and clients to have the same setup. So, a mod bundle with only the sound and movies in the local folder. I kind of thought the patch might not work for those reasons. But, like I said, there is a full version of the mod bundled now.

Also, if the server wasn't "patched" per se, then none of this would be very stable. You can't just patch your local version and expect it to run smoothly, though, it is possible.

So, just to be sure, both server and client should be running 2.01 as a mod bundle, you still have to set the language folder to "bp_weapons_pack_v2.0" in order to get sound and movies. Installing the bundle should do all this automatically for regular play, but you'll have to make sure the context-dedicated looks the same in terms of mod= and language= as the context_bp.... I put both of those lines at the top for easy access.

Thanks for trying it out. Hopefully you'll have some better luck because I'm running out of options. I thought for sure this might be it because I know timber is using some of the ageia groups and so are the bogie missions. I'm hoping its just a matter of getting your server and clients all setup up correctly.

Edited by Brettzies
Link to post
Share on other sites

I just reinstalled GRAW 2 and patched it up to 1.05 and installed your mod. The game loads fine up until I go to start any mission. It crashes and I get the following error.

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

I installed v2, v2.1, and the v2.1 patch. Any ideas? Really anxious to try this out, it looks great.

Link to post
Share on other sites

Sadly the new bundle is still unstable, same message as before.

I have been able to play quarry from begining to end with no probs and no map crashed on initial spawn for me, though Zebb did experience an immediate crash.

I'll leave the server up for a while, if you want to try it, its called "=SPARTA= Brezzies mod legionofspart.com" on 74.86.116.136:16250 I will pm you the password.

Thanks for your efforts

Zeno

Link to post
Share on other sites

Sadly the new bundle is still unstable, same message as before.

I have been able to play quarry from begining to end with no probs and no map crashed on initial spawn for me, though Zebb did experience an immediate crash.

I'll leave the server up for a while, if you want to try it, its called "=SPARTA= Brezzies mod legionofspart.com" on 74.86.116.136:16250 I will pm you the password.

Thanks for your efforts

Zeno

Thanks. I'll be checking it out as I get all the maps.

coop_bogie_occupation_v3(there's a v4 now) started and ran. After I died and picked a new kit, it brought me back in to a pink screen and I could hear a tank. I don't think it crashed...it might have been switching maps.

coop_youppi the next map, crashed immediately with an addon error, which means it wanted some attachment which is out of safe range. I'm going to look at it and see if there's anything "strange" about the map.

Thanks for leaving the server up though, it's a great help to try and debug things.

Ok I think I found ONE more problem. Not in the map, but in the Aegia groups.

They list all the soldiers' weapon options as a list, and sometimes there are one or two custom guys in there which actually looks like a varialbe so it can be hard to spot. There is one that uses the Barrett which has that scope which I took out of the safe range. Most likely that is causing a crash if that guys is called for on a map. Grrrrrr.

I'm going to run through that map and see if there is a Barret sniper in there.

Edited by Brettzies
Link to post
Share on other sites

Sadly the new bundle is still unstable, same message as before.

I have been able to play quarry from begining to end with no probs and no map crashed on initial spawn for me, though Zebb did experience an immediate crash.

I'll leave the server up for a while, if you want to try it, its called "=SPARTA= Brezzies mod legionofspart.com" on 74.86.116.136:16250 I will pm you the password.

Thanks for your efforts

Zeno

Thanks. I'll be checking it out as I get all the maps.

coop_bogie_occupation_v3(there's a v4 now) started and ran. After I died and picked a new kit, it brought me back in to a pink screen and I could hear a tank. I don't think it crashed...it might have been switching maps.

coop_youppi the next map, crashed immediately with an addon error, which means it wanted some attachment which is out of safe range. I'm going to look at it and see if there's anything "strange" about the map.

Thanks for leaving the server up though, it's a great help to try and debug things.

Ok I think I found ONE more problem. Not in the map, but in the Aegia groups.

They list all the soldiers' weapon options as a list, and sometimes there are one or two custom guys in there which actually looks like a varialbe so it can be hard to spot. There is one that uses the Barrett which has that scope which I took out of the safe range. Most likely that is causing a crash if that guys is called for on a map. Grrrrrr.

I'm going to run through that map and see if there is a Barret sniper in there.

We will leave the server up as long as you want to work on this.

Cheers

Zeno

Link to post
Share on other sites

We will leave the server up as long as you want to work on this.

Cheers

Zeno

Cool. Well, I actually found 3 more errors. I kind of can't believe I missed these. scar_tactical_grip should be scarh_tactical_grip in the global groups manager and two more barretts. I think I missed the barretts because they look so similar to beretta and maybe I'm partially dsylexic, so it gets confusing.

However, I think because your server still has the "old" xmls in the bundle, when I try to join with my edits, they don't match up and it just crashes out at least in certain maps. It's really hard to tell though. I try to run my own dedicated server, but whenever I try to join it, it just keeps thinking. Not sure if I'm doing something wrong or if it's not possible to do with one computer.

Zeno, I'm uploading a new version, v2.02, with the fixes. Should be up in about 15 minutes. If you could swap your server with that version when it's ready, that would be great. You're welcome to try it too of course, maybe some stroke of magic will happen and all will be good. Otherwise I'll just be joining and trying to crash it on my own.

Alright, it's up:

Full Mod: bp Weapon Pack v2.02b - File Front Link

The b is just so I know it's a bundled version. Sometimes people have problems with bundles, so I might make a non-bundled version for them.

Edited by Brettzies
Link to post
Share on other sites

The b is just so I know it's a bundled version. Sometimes people have problems with bundles, so I might make a non-bundled version for them.

Excellent.

I made my own unbundled version of 2.01... to try to add an RPG to the demo coop template.. but it doesn't seem to work.

Will that not work anymore?

Oh... btw ....

AWESOME! mod... that L85 is sweet!! Especially the suppressed version. Looks great and sounds great too!

Ok... I'm a total ###### as I just found the RPG in a different slot as I was used to 1.41.

But is it not possible to add more kits? If so.. I can't recall what I did to do that before.

Edited by AJ59
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...