Jump to content

Map Actor Hide


Stalker

Recommended Posts

I don't know why but this response doesn't work.

I set up a startup trigger with the response Map actor Hide: Hide actor_XXX on the command map for all players!

actor_XXX is an allied actor!

when i start the game I always see the actor on the map.........

any help

Link to comment
Share on other sites

Where you choose/setup the actors themselves, underneath the check boxes for Standing, Crouched etc is one for initially hidden, is that checked????

Have you also tried it with a different trigger to startup too to see if that makes a difference, sometimes a trigger won't work for a certain event but another one will?? Try it using a TimerElapsed trigger set to 1 seconds for example and see if that helps you :)!

Link to comment
Share on other sites

You shouldn't use initially hidden. That will remove him from the game and you will risk leaving a shadow soldier that when shot (before you make him visible again) can crash dedicated servers.

MapActor hide is intended to remove him from the commandmap I think. I have experienced it to not work on an enemy soldier set to HOSTAGE behavior. On a friendly CAPTIVE it will work. I think there are numerous ways to solve this one. I guess Jack57 can come up with an answer. I also think I have seen a solutuion to this one somewhere in this forum.

Link to comment
Share on other sites

Hi Stalker, this MapActorHide is one of the more recalcitrant functions in GR. To be honest I have never been able to get it to work with any sort of consistancy, especially with friendlies.

Chavez is on the money with setting him CaptiveActorOn - why it works in this state is a mystery :wacko: You could have it so that the CaptiveActor is turned off when the players find him so that he will revert to normal behaviour - depends on the requirements of the story you are scripting.

You can use Invisiblity instead of MapActorHide as Zeko suggests, but it only works for enemy, and in any case in a situation where you are wanting to hide an actor on the command map you probably don't want him to be set to InvisiblityOn.

Sorry I can't be more helpful.

Jack :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...