Jump to content

Problems Placing C4


OleGreyGhost
 Share

Recommended Posts

Hi all,

Decided to experiment with the wiki script by placing a "c4 charge" on the vehicle after enemy killed.

<element type="MakeAttachable" attach="true" vehicle_id="panhard01" bomb_type="press_x"/>
I have even tried the variant:
<element type="MakeAttachable" attach="true" vehicle_id="panhard01"/>

This was placed in the start mission event after the "ActivateVehicle" element.

Mission loads OK. Can interact with enemy :devil: . Vehicle spawns with crew & passengers. But the vehicle will not move from the spawn location to the unload location. When you walk up to the vehicle the "press x" to place c4 does not appear, therefore you can't place the charge.

Instructions in chapter 9 were simple enough. Can't seem to figure it out.

Any help will be greatly appreciated. OleGreyGhost

Link to comment
Share on other sites

Hi all,

Decided to experiment with the wiki script by placing a "c4 charge" on the vehicle after enemy killed.

<element type="MakeAttachable" attach="true" vehicle_id="panhard01" bomb_type="press_x"/>
I have even tried the variant:
<element type="MakeAttachable" attach="true" vehicle_id="panhard01"/>

This was placed in the start mission event after the "ActivateVehicle" element.

Mission loads OK. Can interact with enemy :devil: . Vehicle spawns with crew & passengers. But the vehicle will not move from the spawn location to the unload location. When you walk up to the vehicle the "press x" to place c4 does not appear, therefore you can't place the charge.

Instructions in chapter 9 were simple enough. Can't seem to figure it out.

Any help will be greatly appreciated. OleGreyGhost

Not much help but I have had the same problem, I had an abrams tank that I managed to get to patrol through varios waypoints .... however when I made it attachable ... it stayed at the spawn location ..... no matter what I do it seems I can have it moveable, or destroyable .... but not both !! :wall:

Legacy

Link to comment
Share on other sites

No idea why it's not working for you...would have to look at the whole code...

The following code works for a tank.


<element type="ActivateVehicle" vehicle_id="tank01" start_time="4"/>
<element type="MakeAttachable" vehicle_id="tank01" attach="true" start_time="5"/>
<element type="OrderTank" vehicle_id="tank01" ai="true" order="move" world_x="-4248" world_y="363" start_time="6"/>[/code]

You would need to modify it for a panhard which uses a diff. move command.

Let me know how you go.

Dav.

Link to comment
Share on other sites

No idea why it's not working for you...would have to look at the whole code...

The following code works for a tank.


<element type="ActivateVehicle" vehicle_id="tank01" start_time="4"/>
<element type="MakeAttachable" vehicle_id="tank01" attach="true" start_time="5"/>
<element type="OrderTank" vehicle_id="tank01" ai="true" order="move" world_x="-4248" world_y="363" start_time="6"/>[/code] You would need to modify it for a panhard which uses a diff. move command. Let me know how you go. Dav. Dav Gotta hand it to you it worked ... though I still can't understand while mine didn't, only difference i can see is placement of the MakeAttachable ... and start_time (I thought if you left this blank it assumed "0" and started anyway ?)
[code]

<element type="MakeAttachable" vehicle_id="tank01" attach="true"/>
<element type="ActivateVehicle" vehicle_id="tank01" start_time="2"/>
<element type="OrderTank" vehicle_id="tank01" ai="true" order="move" world_x="1455" world_y="6837" start_time="6"/>

Bizzarre eh !!

Legacy

Link to comment
Share on other sites

Davros,

Again you come to the rescue :clapping: . Added the start time and now vehicle moves and can be destroyed.

Legacy, that was a nice catch on the start_time :thumbsup: . Saved me a couple of hours of reading.

The following code works for a tank.

<element type="ActivateVehicle" vehicle_id="tank01" start_time="4"/>

<element type="MakeAttachable" vehicle_id="tank01" attach="true" start_time="5"/>

<element type="OrderTank" vehicle_id="tank01" ai="true" order="move" world_x="-4248" world_y="363" start_time="6"/>

You would need to modify it for a panhard which uses a diff. move command.

Let me know how you go.

From what I can see in the above code, both the "ActivateVehicle & OrderTank" elements have a start_time, therefore making it mandatory in the other element. By our omitting a start_time for the "MakeAttachable" element, this paused the script, not allowing the move order to be acted upon.

I do remember "now" reading in one of the older posts here that if something doesn't work to make sure there is a start_time attribute included.

Cheers, OleGreyGhost

Link to comment
Share on other sites

Excellent....and thanks for the explanation OGG...sounds very logical.

OGG, can I ask a favor...are you able to update the wiki as you discover things?

There is a link on the wiki to request editor rights if you do not already have them (I can't recall if I set you up yet).

I know I am being pushy, but I REALLY need to get some help in capturing items like this one on the wiki so others do not need to repeat mistakes (or read through a gazillion posts here to find the nugget that says you need to use the "time" element.)

It's really easy to do - just ask Legacy....BEG BEG ;)

Cheers,

Dav

Link to comment
Share on other sites

Davros,

In regards to your question,

OGG, can I ask a favor...are you able to update the wiki as you discover things?

Yes. I will give it a try. But I want to advise you, I know nothing about HTML I did an excerpt of the vehicle video which I will try to get into the wiki tonight.

If I am not successful, it will have to wait about four days. I have to go off the grid for my wife. At some point It will get in there.

Cheers, OleGreyGhost

P.S.

There is a link on the wiki to request editor rights if you do not already have them (I can't recall if I set you up yet).

I didn't receive any e-mail notifying me that editor rights were granted, or log-in id. OleGreyGhost

Edited by OleGreyGhost
Link to comment
Share on other sites

SWEEET! Approved your request on the wiki. You now have editing rights.

re. the wiki coding, it's basically all wyswig, no need to touch raw HTML.

Re. the video. Assume you checked out my post on here on how I did the videos. When you upload it to vimeo,

  1. you'll see in the top r.h.s. of the video the overlay text "</> Embed"...
  2. click on that and it'll give you some code, copy this
  3. open the wiki page you want to edit,
  4. click edit tab (you'll see this if you are logged in with edit rights)
  5. click where you want the video to be inserted,
  6. select the "Insert Plugin" icon in the toolar,
  7. select "PBwiki magic" and select "HTML"
  8. paste the code, click preview, ok
  9. save the wiki page and presto!

Thanks OGG and all the best to the wifey and be sure to buy her some flowers from us to say thanks for letting you spend time on this.

Also, happy for you to just add text descriptions too :)...and the pbwiki team have a number of training vid's on how to do stuff on the wiki as well as a good help system.

Dav.

Link to comment
Share on other sites

SWEEET! Approved your request on the wiki. You now have editing rights.

re. the wiki coding, it's basically all wyswig, no need to touch raw HTML.

Re. the video. Assume you checked out my post on here on how I did the videos. When you upload it to vimeo, you'll see in the top r.h.s. of the video the overlay text "</> Embed"...click on that and it'll give you some code, copy this, open the wiki page you want to edit, click edit tab, click wher you want the video to be inserted, and select the "Insert Plugin" icon in the toolar, select "PBwiki magic", select "HTML", paste the code, click preview, ok and save.

Thanks OGG and all the best to the wifey and be sure to buy her some flowers from us to say thanks for letting you spend time on this.

Dav.

OK. Will do when she finishes her ordeal. Ran out of time for today. Have to be out of the house by 0615. I look on the good side of it. No bloodshot code reading eyes & a little bit more shuteye. I'll give you a yell when I return to the grid. OleGreyGhost

Link to comment
Share on other sites

OGG

Glad I could be of some help ... (for a change :) )

Reference editing the Wiki ... it really is easy, took me about 5 mins to put the "Adding Objectives" on the site, and lets face it.... if you can cope with the GRAW2 editor, placing objects, crashes etc..etc..... :wall: and working out the way the mission script should read / run .... the wiki is a nice comfortable almost soothing break :thumbsup:

Hope you get on alright with it .

BTW have you had a go at my recently issued mission yet ...... downloadable from .... you guessed it ... the Wiki

Legacy

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...