Jump to content

Significant Lag In Graw2


Recommended Posts

Hi folks,

So I'm playing GRAW2, but I'm getting significant lag. It's still playable, but it doesn't 'feel' right if you know what I mean. There is lag, which is quite annoying, but I have no idea why. I went to http://www.systemrequirementslab.com/referrer/srtest and passed the GRAW2 test with flying colours. My current specs are

- AMD 6000+ CPU (dual 3Ghz cores)

- Windows XP Sp3

- Gigabyte 512MB 8500GT graphics

- 2GB DDR2 667 RAM

Link to comment
Share on other sites

While in a game, press tab and look at your ping, if its over 200 regular then you will likely lag a little, if its say 350+ then you will have real problems, try to play in servers that you know are based close to where you live in the world. The further the server is based the higher the pings.

Also wireless connections can cause lagging problems too. Good luck.

i.e I am in UK, server is based in the UK and I have pings from 20-50 generally

Link to comment
Share on other sites

Your video card is also pretty low end, so it might be graphical lag due to insufficient GPU power. I'd suggest getting a new graphics card, especially if you play a lot of games. You can get a REALLY good GPU for less than $200 and a pretty good one for $130.

Link to comment
Share on other sites

Sorry I should have been more specific, this is in single-player, not multi-player. My bad. :)

The thing I don't get though is that GRAW runs fantastically, yet GRAW2 lags. I know my graphics isn't the greatest, but still it passes even the recommended specs to play GRAW2.

Edited by Darth Windu
Link to comment
Share on other sites

Unless you're running everything on low at 800x600, it's going to lag up pretty bad. One thing you could try that may help is making sure you have the newest drivers for your video card as well.

Yeah, I was running on a 7600gt and I had to have a mix of low to medium settings. The thing that improved the gameplay speed for me the most I think though was turning that white slider bar all the way to the left in the graphics settings. I think it's for brush and map detail, so I had that turned all the way down.

Even with a 7600 gt though I was able to play with decent frame rates at a resolution of 1280x768 or something like that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...