Jump to content
Ghost Recon.net Forums

bp weapons pack v1.45


Recommended Posts

Try looking through this thread: v1.4 thread

There might be some suggestions in there. A lot of people had problems with the mod for some reason. Unbundling seemed to be the best solution.

you're a rock star dude worked first time

I want to mention though that in your instructions in post 83 Here it says to type "bundler extract -r bp_weapons_pack_v1.4 data"

but its actually "bundler extract -r bp_weapons_pack_v1.4.bundle data"

you may want to consider editing your post. you may also want to consider having an unbundled version of the mod for people who don't want to play online, it seems to work better and it would be alot easier for noobs.

other than that great mod man, i used it when the game first came out but the eotech you made got me to return to the game, you should see if you can get it to go on the m14

-Phil

Hi,

I have exactly the same problem that you had. When I want to change the main weapon, the game crashes and there is a report with this content:

Crash in application version: 30621.2989

Unhandled exception - access violation

C STACK:

graw2 (???) : ???

SCRIPT STACK:

data\lib\managers\briefingmanager.dsf(0)

data\lib\managers\briefingmanager.dsf(0)

data\lib\managers\briefingmanager.dsf(0)

Renderer: normal

Physics : threaded

So, what did you do to run the mod properly?

(Sorry if my English is bad, I'm from Switzerland =) )

Mike

Link to post
Share on other sites
  • Replies 168
  • Created
  • Last Reply

Top Posters In This Topic

I don't get it - where are the new weapons? The file I just downloaded only contains sounds and movies, not especially useful.

Everything is in the bundle file. The movies and sounds would be in there too but when they are, the game doesn't recognize them for some reason. Hence they in the old "language" folder method.

Edited by Brettzies
Link to post
Share on other sites
  • 3 weeks later...

hey Brettzies i downloded and installed the 1.47 pack even though the intro was there i couldnt find the new weapons plus it crashes if you try opening the tutorial

i have the 1.05 patch and eu version (worked with the 1.2 pack)

Pls. help :(

ps: the acog is still there for some reason

Edited by jestinegascon
Link to post
Share on other sites

v1.47 uses a bundle that goes in the mods folder. So you will need this line in the context.xml:

<mod_bundle name="bp_weapons_pack_v1.47"/>

The other folders inside the local/bp folder, I think you can move to the language you are using. Never tried it though.

Link to post
Share on other sites

v1.47 uses a bundle that goes in the mods folder. So you will need this line in the context.xml:

<mod_bundle name="bp_weapons_pack_v1.47"/>

The other folders inside the local/bp folder, I think you can move to the language you are using. Never tried it though.

I think the problem is in the context.xml

Here's what my context.xml says when you press edit:

<?xml version="1.0" encoding="ISO-8859-1"?>

<context>

<script base="data" exec="Menu/Menu" editor="false" language="bp_weapons_pack_v1.47"/>--><!--change to "english" to uninstall-->

<mod_bundle name="bp_weapons_pack_v1.47"/>--><!--delete this line or comment out front with "<!--" to uninstall-->

<!-- <threaded_renderer value="false"/> -->

<layer_config file="\data\settings\layers.xml"/>

<scene_config file="\data\settings\scenes.xml"/>

<unit_database file="\data\units.xml"/>

<sound settings="/data/sound/settings.xml" />

<network settings="/data/settings/network.xml" />

<static_texture_scope file="\data\settings\static_texture_scope.xml"/>

<skeleton_def file="\data\objects\def.xml"/>

<animations def="\data\anims\anims.xml" state_machine="\data\anims\state_machines.xml"/>

<texture base="\data\textures" />

<effects file="\data\effects\effects.xml"/>

<decals file="\data\effects\decals\decals.xml"/>

<!--<keys disable_windows_key="false" />-->

<default_shader_config file="\data\shader\default_shader_config.xml"/>

<default_render_templates file="\data\shader\default_render_templates.xml"/>

<physics settings="\data\settings\physics_settings.xml" fps="60" physx_effects="hardware_or_disabled" multithreaded="true" />

<global_materials file="\data\settings\materials.xml" />

<gui file="\data\gui" optimized="true"/>

<camera shakes="\data\settings\camera_effects.xml" cameras="\data\settings\camera_settings.xml" />

<bundler make_logs="false" />

<nls_lookup size="64"/>

<installer use="false"/>

<calc_video_mem_adjust value="false"/>

<advertisements value="true"/>

<!-- Set all compile flags to false when running bundled version -->

<compile xml="false" texture_db="false" mopps="false" scripts="false" />

</context>

( copy and paste on notepad to see what it really looks like)

But when you open it directly it says:

The XML page cannot be displayed

Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

--------------------------------------------------------------------------------

Incorrect syntax was used in a comment. Error processing resource 'file:///C:/Program Files/aa UBISOFT/Ghost Recon Advanced...

<mod_bundle name="bp_weapons_pack_v1.47"/>--><!--delete this line or comment out front with "<!--" to uninst...

When you try to open it using microsoft word it says:

The XML file context cannot be opened because there are problems with the contents.

Details: Incorrect syntax was used in a comment.

Error location: Line: 4, Column : 99

I think im having the same problem as delta one zero in post:50 page:4

I would download the 1.41 pack instead but it keeps stoping during the process

could you find whats wrong in the context.xml (or whats wrong at all)?

ps: sorry for making you read so much

Edited by jestinegascon
Link to post
Share on other sites

nevermind, i managed to download and install the 1.41 patch perfectly :)

your mods are AWESOME!! by the way, and here are some cool weapons that would be great if thet were in your next mod

hk417

magpul masada acr

xm29 oicw

xm109 barret

hawk mm-1

mk 14 ebr

mk48

i know others are trying to make some of these weapons but i want it to go with your mod :)

also you think you can get a GL for and a 30 round mag for the m468?

and some attachments for the machine guns like an eclan scope,grippod?

and giving the ghosts a multicam pattern would be cool too :)

Link to post
Share on other sites

the magpul masada was already made by snowfella, just go to the download section and you should find it. I would though like to see the Mk 14 EBR because since captainmitchells M14 mod was removed cause he didn't get permission to use someone elses work from AIX mod. And i think the ghost's already have a multicam. I would like to see something different or having the option to at least have a different pattern like ACU, etc.

Link to post
Share on other sites

Hello Brett, I just installed 1.47 on my GRAW2 with 1.5 patch. When I start the game, your new intro movie plays and seems fine. However, when I begin any mission, the game crashes during loading, with an "Error in application" message. I will post the message, I hope you can help. Thanks. (I used the "quick install" method in the readme)

Crash in application version: 30899.3048

data\lib\managers\eventmanager.dsf(-1): cant find member: _unit_name in type <void>

SCRIPT STACK:

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

Edited by meepokman
Link to post
Share on other sites
  • 2 months later...

Well, I installed the MOD on a dedicated standalone server and it works great unitl you grab the RPG. Then the server gives me this error:

Sun Nov 23 21:39:12 2008

Crash in application version: 30899.3048

data\lib\units\types\weapons\rpg.dsf(-1): cant find member: addon_data in type

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : normal

I tried it twice and recevied the same error on both occasions.

I know this might me old but anyone have any ideas???

Thanks

Viper

Link to post
Share on other sites

Well, I installed the MOD on a dedicated standalone server and it works great unitl you grab the RPG. Then the server gives me this error:

Sun Nov 23 21:39:12 2008

Crash in application version: 30899.3048

data\lib\units\types\weapons\rpg.dsf(-1): cant find member: addon_data in type

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : normal

I tried it twice and recevied the same error on both occasions.

I know this might me old but anyone have any ideas???

Thanks

Viper

Sorry, never could figure that RPG thing out. There weren't too many people around to test it out either. Tried a few times to fix it but not sure it worked:

coop fix (rpg fix)

Link to post
Share on other sites

Brettzies. The mod is the best thing since sliced bread. Better actually.

I plan in lan games each week and we would be lost without it.

Thanks so much for the mod and the continued support.

Viper, FYI - we do not get the issue with the RPG (running v1.41) - but then we are playing LAN and not dedicated serever...though I think we did try that once and no issues.

Dav.

Link to post
Share on other sites
  • 4 weeks later...

Well, I installed the MOD on a dedicated standalone server and it works great unitl you grab the RPG. Then the server gives me this error:

Sun Nov 23 21:39:12 2008

Crash in application version: 30899.3048

data\lib\units\types\weapons\rpg.dsf(-1): cant find member: addon_data in type

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : normal

I tried it twice and recevied the same error on both occasions.

I know this might me old but anyone have any ideas???

Thanks

Viper

Sorry, never could figure that RPG thing out. There weren't too many people around to test it out either. Tried a few times to fix it but not sure it worked:

coop fix (rpg fix)

Bret,

Sorry for the delay in responding. I tried the fix you sent but still get dedicated server crash. see below:

Tue Dec 23 00:34:22 2008

Crash in application version: 30899.3048

data\lib\units\types\weapons\rpg.dsf(-1): cant find member: addon_data in type

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : normal

I can pick the RPG but the minute it goes into the map it crashes.

Davros,

Any idea where I can get version 1.41? I like the MOD but sucks that it crashes with the RPG. So of us are RPG whores!!! 0:)

Thanks!!

Viper

Link to post
Share on other sites

Likely in here...bp weapons pack v1.4 :whistle:

I have also made a few changes to this to add in a 6 shot 40mm GL and increase the number of grenades in the kits to 6 as well as a "broken" Zeus..(broken in that the image does not show and when you use it, you can not pick up anothr weapon...I need to spend some quality time on this ...so do not recomend you use my one yet.).

Dav

Link to post
Share on other sites
  • 2 weeks later...

Hello I'm new to GRAW2 and to this forum.

I and a friend of mine are facing troubles using your mod.

we "installed" ist by copying the files to the GRAW directory. The video at the beginning is showing up fine, but when we have created a LAN-Coop server and someone chooses a weapon which was "taken out" of the game (e.g. MR-C etc.) by you it crashes.

we were not able to test your good looking mod, but please help us to get it running.

Regards Schuldi

Link to post
Share on other sites

Hello I'm new to GRAW2 and to this forum.

I and a friend of mine are facing troubles using your mod.

we "installed" ist by copying the files to the GRAW directory. The video at the beginning is showing up fine, but when we have created a LAN-Coop server and someone chooses a weapon which was "taken out" of the game (e.g. MR-C etc.) by you it crashes.

we were not able to test your good looking mod, but please help us to get it running.

Regards Schuldi

Unless you're talking about the campaing coop, you shouldn't be able to pick the MRC since I took it out of all the kits. The main problem is id_mod values. So, if you pick something from the campaign coop, there's a high chance it's out of the range 1-31. I had to reorder things to get mp to work. I could have taken weapons out of the campaign too, but prefer to leave them for sp players. I believe the mrc, m416, barett, and a maybe a few others would cause a crash in mp for players who are not the server.

You could try unbundling the mod and running it that way, might get rid of the crashes. However, you'd still have oddities. Whatever is id#31 will show up in third person for all attachments out of the range. For instance, the sig552 silencer will be used for everything out of the range, scopes, etc. I beleive it only shows up in third person though, the player's 1st view should be correct. Still sucks though.

I've actually been editing the mod this weekend and freed up 4 slots. I could use them for the mrc, but might bring something new in.

Link to post
Share on other sites

Hi Brettzies...

just saw your postt...

"I've actually been editing the mod this weekend and freed up 4 slots. I could use them for the mrc, but might bring something new in."

Interesting! Something new on the way?

Also, if you do release another version, would I be able to addin a change to the composition_manager.xml to enable a certain explosion composition ("MortarDirtExplosion_damage") to do damage? As far as I can see nothing has yet used this composition...and it should do damage as it's name says...see this thread http://www.ghostrecon.net/forums/index.php?showtopic=51431#

Be good to get it into a single release as then mission makers can start using it.

Dav.

Link to post
Share on other sites

Well, I got really busy the 2nd part of the year. I had started something right after the last release but then abandoned it for various reasons. However, the game is still fun to mod despite always running into roadblocks and I do like the "one shot kill" style of the game. When I get going, I get addicted. After cleaning up the M4/M16 using the riser I made for GRAW1, it opened up 6 attachment slots. Plus it looks a little better and the ironsights are usable.

When I was building the below model, I knew it might have issues for aiming, so I stopped a long time ago. But, after messing with the xmls this weekend I added enough to it to see if it would be do-able in game. Intially it didn't work out so well. Either the grip was good with the crye anim set or the reload was wrong and grip slightly bad with the scar anim set. Scar seemed to be a pretty good comprimise with grip and sights working, but I did a little experiment ages ago combining anim sets. The problem was it caused issues for the original weapons not having the right anims. After remembering why I stopped with this one, I figured I'd give it another shot and thanks to some good file re-naming utils I was able to combine the best parts of different anim sets to get a good sa80 anim set. The reload is not accurate, but it's better then nothing. The grip looks good and the sights line up which is the main issue usually.

Still a lot to do on it, not sure when I'll be done. At this point, modding graw/2 is more of a hobby/challenge, though I still get emails from people who have problems installing the mod, so I guess a few people are playing it.

L85_graw_01_500.jpg

L85_graw_02_500.jpg

L85_graw_03_500.jpg

L85_graw_04_500.jpg

L85_graw_05_500.jpg

Link to post
Share on other sites

^

Soon the Redcoats are coming. :thumbsup:

____

Off the wall question but regarding the add-on slots, did you merge any of the duplicate mods like the SCAR (L/H) grenade launchers(14/16) and front grips(13/17) in your weapons mod? And if not could you get away with it?

Link to post
Share on other sites

Oh yeah! come to daddy baby!

Sweet. Brettzies, everyone who is anyone is using your mod. And if they are not, it's only because they don't know about it. It's the best thing since sliced bread! Full stop.

Can't wait for the new release.

Dav.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...