Jump to content
Ghost Recon.net Forums

bp weapons pack v1.45


Brettzies
 Share

Recommended Posts

Delta one zero, yes, use his version 1.41(patch 1.05 compatible) and you can use orig weapons plus new weapons. Versions 1.45/47 were an attempt(after much work) to make Bretts weapons usable for online multiplayer games. 1.41 works fine for sp and lan only gaming. I've always used the language folder route to play his mod, naming it English folder instead of bp weapons and leaving orig context xml and it runs smooth.

Cirap, to unbundle, if you are on xp is as follows:

1)copy bretts bundle into to public tools/bundler folder

2)create datafolder in bundler folder

3)go to command prompt(start/programs/accessories)

4)cd\Program Files\UBISOFT\Ghost Recon Advanced Warfighter 2\public_tools\bundler (paste at end of command prompt opening script) hit enter

4)bundler extract -r bundle name.bundle data data(paste at end of string--forget off top of head how his bundle was named so I used bundle name as example-just insert correct bundle name in place of bundle name)hit enter--unbundled to data folder you created in bundler folder.

Link to comment
Share on other sites

  • Replies 168
  • Created
  • Last Reply

Top Posters In This Topic

Delta one zero, yes, use his version 1.41(patch 1.05 compatible) and you can use orig weapons plus new weapons. Versions 1.45/47 were an attempt(after much work) to make Bretts weapons usable for online multiplayer games. 1.41 works fine for sp and lan only gaming. I've always used the language folder route to play his mod, naming it English folder instead of bp weapons and leaving orig context xml and it runs smooth.

Cirap, to unbundle, if you are on xp is as follows:

1)copy bretts bundle into to public tools/bundler folder

2)create datafolder in bundler folder

3)go to command prompt(start/programs/accessories)

4)cd\Program Files\UBISOFT\Ghost Recon Advanced Warfighter 2\public_tools\bundler (paste at end of command prompt opening script) hit enter

4)bundler extract -r bundle name.bundle data data(paste at end of string--forget off top of head how his bundle was named so I used bundle name as example-just insert correct bundle name in place of bundle name)hit enter--unbundled to data folder you created in bundler folder.

Thank you very very much TRC, greatly appreciate the assistance :).

Link to comment
Share on other sites

Delta one zero, yes, use his version 1.41(patch 1.05 compatible) and you can use orig weapons plus new weapons. Versions 1.45/47 were an attempt(after much work) to make Bretts weapons usable for online multiplayer games. 1.41 works fine for sp and lan only gaming. I've always used the language folder route to play his mod, naming it English folder instead of bp weapons and leaving orig context xml and it runs smooth.

Cirap, to unbundle, if you are on xp is as follows:

1)copy bretts bundle into to public tools/bundler folder

2)create datafolder in bundler folder

3)go to command prompt(start/programs/accessories)

4)cd\Program Files\UBISOFT\Ghost Recon Advanced Warfighter 2\public_tools\bundler (paste at end of command prompt opening script) hit enter

4)bundler extract -r bundle name.bundle data data(paste at end of string--forget off top of head how his bundle was named so I used bundle name as example-just insert correct bundle name in place of bundle name)hit enter--unbundled to data folder you created in bundler folder.

thanks for taking the time to write all that down, but that's what I did. I only get 9 folders

gui

levels

lib

objects

sb_templates

settings

strings

textures

units

no weapons_data.xml file to be found anywhere

Edited by Cirap
Link to comment
Share on other sites

Found a few other things which may have caused crashing in coop Mp games. Here's an attempted fix. Extract the contents into your graw2 dir. It should place 8 xmls in this dir:

Local\bp_weapons_pack_v1.47\lib\managers\xml

coop fix - FileFront Link

Can't gaurantee success, but since I found a few things I thought I'd try fixing it anyway.

Edited by Brettzies
Link to comment
Share on other sites

Found a few other things which may have caused crashing in coop Mp games. Here's an attempted fix. Extract the contents into your graw2 dir. It should place 8 xmls in this dir:

Local\bp_weapons_pack_v1.47\lib\managers\xml

coop fix - FileFront Link

Can't gaurantee success, but since I found a few things I thought I'd try fixing it anyway.

Hey Brett is this a fix for all versions of your weapons pack ?

I am using just version 1.41 at the moment.

Cheers.

CJ

:thumbsup:

Link to comment
Share on other sites

Found a few other things which may have caused crashing in coop Mp games. Here's an attempted fix. Extract the contents into your graw2 dir. It should place 8 xmls in this dir:

Local\bp_weapons_pack_v1.47\lib\managers\xml

coop fix - FileFront Link

Can't gaurantee success, but since I found a few things I thought I'd try fixing it anyway.

Hey Brett is this a fix for all versions of your weapons pack ?

I am using just version 1.41 at the moment.

Cheers.

CJ

:thumbsup:

1.47 is mainly for people wanting to play MP, so if you're just running SP or lone wolf Coop, then 1.41 is better.
Link to comment
Share on other sites

I love this mod and it works fine for me, but my only complaint about this mod is that the awsome sounds for your weapons are way to loud in comparison to the other ingame weapons. I can barely hear a rebels G 36 shooting at me unless I turn the volume up, which results in me going deaf everytime I shoot one of your weapons.

Is there a way I can tone down the volume so that all the weapon sounds are at a more equal level with the stock weapons?

Link to comment
Share on other sites

I'm not sure if the problem is solely to do with this weapon pack (using 1.41) but it seems that whenever I select a grenade launcher mod for any weapon I only ever get one 40mm grenade without exception.

I can't understand why this would be, and I can't see anything in the weapon_data.xml that could solve this problem as the "ammopack_40mm" shows the ammo value being at "4" but obviously I don't get that many as its 1/0 in-game.

Anyone have any suggestions?

Edited by Delta One Zero
Link to comment
Share on other sites

I'm not sure if the problem is solely to do with this weapon pack (using 1.41) but it seems that whenever I select a grenade launcher mod for any weapon I only ever get one 40mm grenade without exception.

I can't understand why this would be, and I can't see anything in the weapon_data.xml that could solve this problem as the "ammopack_40mm" shows the ammo value being at "4" but obviously I don't get that many as its 1/0 in-game.

Anyone have any suggestions?

You should read the v1.4 thread for info on how to fix that. It was a bug introduced with the last patch. Or, you could use the latest v1.47 and not have this problem. But, I'll be nice and just provide a link to the fix:

v1.41 gl fix - not needed for v1.47

Extract into your Graw2 direcotory.

Edited by Brettzies
Link to comment
Share on other sites

Thank you very much Brettzies, greatly greatly appreciated.

Also, awesome work on your pack. I'm absolutely loving all the new guns espiecally the M4A1.

Cheers.

Glad to hear you like it. I'm actually re-playing Graw1 myself and dumping all the extra attachments and weapons I didn't have in there before. Graw2 is better in most ways, but something I like about Graw1 still. Maybe the simplicity of it all.

Link to comment
Share on other sites

launched the SP campaign today and also notice I have that wierd volume anamoly

I kitted myself and another ghost with SCAR-H (with your custom sounds), the other two ghosts with a HK416 and MK46

when I or the other ghost with SCAR-H fire, the sounds are as they should be, but when one of the "stock" guns (416, MK46, enemy G36) the volume is really low. last time I played with your mod (v1.4) I did not have this problem.

I am playing GRAW2 1.05 with version 1.47 of the weapons mod

Link to comment
Share on other sites

launched the SP campaign today and also notice I have that wierd volume anamoly

I kitted myself and another ghost with SCAR-H (with your custom sounds), the other two ghosts with a HK416 and MK46

when I or the other ghost with SCAR-H fire, the sounds are as they should be, but when one of the "stock" guns (416, MK46, enemy G36) the volume is really low. last time I played with your mod (v1.4) I did not have this problem.

I am playing GRAW2 1.05 with version 1.47 of the weapons mod

I don't know what the answer is. I tried to balance them, but they are louder then the original game sounds to begin with. Some people turn off EAX.

Link to comment
Share on other sites

tried with and without CMSS-3D

Tried with and without EAX enabled

tried playing with 2-channel headphone settings, as well as 5.1

tried v1.41

tried uninstalling and installing the game again, then v1.41

the only thing that makes all weapon volumes sound equal is if I uninstall the mod.

next I'm gonna try another set of soundcard drivers

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

any chance a new things could be added to this mod ?

yes i added the acog of brettzies on all rifles and assaul rifles of the game(look my last post in weapon modding ..is a example..you see the g36k with the acog..and i have a screemshot with the acog on the m14..im post the screem later

Link to comment
Share on other sites

  • 1 month later...

Crash in application version: 30899.3048

data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: material in type <void>

SCRIPT STACK:

data\lib\units\types\weapons\bulletweapon.dsf(0)

data\lib\units\extensions\inventory.dsf(0)

data\lib\units\extensions\inventory.dsf(0)

data\lib\managers\instancedescriptionmanager.dsf(0)

data\lib\managers\instancedescriptionmanager.dsf(0)

data\lib\units\extensions\groupunit.dsf(0)

data\lib\units\extensions\groupunit.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

Link to comment
Share on other sites

Hey all,

I need some help here, I'm running graw 1.04 and brettzies mod 1.41 and i get a ctd every time i try to change my loadout for my primary weapon.

i can change and use my pistol and secondary weapons, i even messed around with the sig on the training level but as soon as i press the primary button i get ctd with this error

_____________________________________

Crash in application version: 30621.2989

Unhandled exception - access violation

C STACK:

graw2 (???) : ???

SCRIPT STACK:

data\lib\managers\briefingmanager.dsf(0)

data\lib\managers\briefingmanager.dsf(0)

data\lib\managers\briefingmanager.dsf(0)

data\lib\managers\briefingmanager.dsf(0)

data\lib\managers\briefingmanager.dsf(0)

Renderer: threaded

Physics : threaded

____________________________________

I've tried installing the mod normally and manually but I've had no luck, any help would be appreciated

-Phil

Link to comment
Share on other sites

Try looking through this thread: v1.4 thread

There might be some suggestions in there. A lot of people had problems with the mod for some reason. Unbundling seemed to be the best solution.

you're a rock star dude worked first time

I want to mention though that in your instructions in post 83 Here it says to type "bundler extract -r bp_weapons_pack_v1.4 data"

but its actually "bundler extract -r bp_weapons_pack_v1.4.bundle data"

you may want to consider editing your post. you may also want to consider having an unbundled version of the mod for people who don't want to play online, it seems to work better and it would be alot easier for noobs.

other than that great mod man, i used it when the game first came out but the eotech you made got me to return to the game, you should see if you can get it to go on the m14

-Phil

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...