Jump to content

bp weapons pack v1.4


Brettzies
 Share

Recommended Posts

hi all ive got some problems with the mod too :mellow:

ive installed graw2 new and pathed it to 1.4

than i installed the mod and my old savegame

now i cant play the shooting range - if i try i will get this error message:

Crash in application version: 30621.2989

data\lib\managers\eventmanager.dsf(-1): cant find member: _ammo in type <void>

SCRIPT STACK:

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

if i load a save game ican play it, but there is no weapon showed in the mission menu

please help me - greetings from sweeperone1975(ger)

Link to comment
Share on other sites

  • Replies 166
  • Created
  • Last Reply

Top Posters In This Topic

hi all ive got some problems with the mod too :mellow:

ive installed graw2 new and pathed it to 1.4

than i installed the mod and my old savegame

now i cant play the shooting range - if i try i will get this error message:

Crash in application version: 30621.2989

data\lib\managers\eventmanager.dsf(-1): cant find member: _ammo in type <void>

SCRIPT STACK:

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

if i load a save game ican play it, but there is no weapon showed in the mission menu

please help me - greetings from sweeperone1975(ger)

Your old save games won't work. Sorry. As for the shooting range, did you put anything in levels/training_grounds? That error is usually associated with the mrc. I had to rename it a while ago to get the bitmap icons for the scopes to show up on it. I don't think there is a save game associated with the range, but try removing them all and see what happens.
Link to comment
Share on other sites

It's not the files folks, works fine for me. Only thing I've noticed is in [GR] play, when using rpg/pred I get a "ghost helmet" outline on screen when zooming in on target. I get all weapons, sounds, and new skins. You could try unbundling mod into your language folder as I did to see if it makes a difference(being sp type I always run off english folder setup), but I've yet to have a crash or problem.

Link to comment
Share on other sites

hi im back iv cleaned my save games folder and tried

it once again with a new one :(

i cant see the weapons in my privat weapons list again :wall:

iv i choose one of the normal weapons i will see it, but if i start useing yours iwont see them :(

the problem with the shooting rang is still alive and i havent changed anything

the only thing iv done is iv installed all patches and than iv ziped the mod in the graw folder !!!

please help me - thx

Link to comment
Share on other sites

hi im back iv cleaned my save games folder and tried

it once again with a new one :(

i cant see the weapons in my privat weapons list again :wall:

iv i choose one of the normal weapons i will see it, but if i start useing yours iwont see them :(

the problem with the shooting rang is still alive and i havent changed anything

the only thing iv done is iv installed all patches and than iv ziped the mod in the graw folder !!!

please help me - thx

I wonder if this is a memory issue, a few people have been having similar problems. How much do you have? Do you have a single cpu or dual? How much video memory? Try changing settings to low and see what happens.
Link to comment
Share on other sites

i ve got an amd athlon 64 processor 3700+

2,21ghz 1,00 gbram

geforce 8800gts

Is that 1gb of ram or 2? I hate to say it, but 1gb might not be enough for this mod. 2 should be fine though, that's what I have. Memory wise, when I'm runnning the game, it's around 550-565 mbs + all the OS memory space comes out to around 900mbs. So, it's getting close to 1gb being used. If you have a lot of extra stuff going on, yours could be even higher.

Thanks bret for your MOD!

Its the best i've ever played on GRAW w00t

I'm glad you are able to get it to run and enjoy it. Seems not everyone is so lucky.
Link to comment
Share on other sites

Hmm. So I just ran the game on my machine with the mod installed and without the mod installed on the Joining Forces mission. The memory footprint was almost the same. Around 800megs. I put all the settings to low, just to see what happens. May or may not be a memory issue for some of you guys.

One last ditch thing to try. In the context.xml, change this line:

<physics settings="\data\settings\physics_settings.xml" fps="60" physx_effects="hardware_or_disabled" multithreaded="true" />

So that multithreaded="false"

I don't even know what that is referring to, but it could be causing problems if it's the cpu and you have a single.

Link to comment
Share on other sites

fresh install....

restart pc....

patch 1.0-1.2

restart pc

patch 1.2-1.3

restart pc

patch 1.3-1.4

restart pc

install mod

copied first "paragraph"??? of bp_wp context to original context, local & mod folder overwrites original local & mod folder

restart pc

load GRAW2...intro movie w/ sound...check

team selection...bp_weapons...check

changed my video to fit my monitor...1900x1200...launched mission....CTD and rebooted

restart pc

load GRAW2...lowered video setting to 800x600 w/ everything low...launch training mission and got message:

Crash in application version: 30621.2989

data\lib\managers\eventmanager.dsf(-1): cant find member: _ammo in type <void>

SCRIPT STACK:

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

restarting pc again.... <_<

Link to comment
Share on other sites

uninstalled GRAW2/AegiaPhysx...restart pc...reinstall GRAW/AegiaPhysx...patched using cumulative patch 1.0-1.4..restart...once video was detected...I went straight to training ground...no problem.

restated pc...reinstalled bp_wp 1.4...copied & pasted just the following:

<script base="data" exec="Menu/Menu" editor="false" language="bp_weapons_pack_v1.4"/>--><!--change to "english" to uninstall-->

<mod_bundle name="bp_weapons_pack_v1.4"/>--><!--delete this line or comment out front with "<!--" to uninstall-->

into original context.xml.... and got this message

Crash in application version: 30621.2989

data\lib\managers\eventmanager.dsf(-1): cant find member: _ammo in type <void>

SCRIPT STACK:

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\eventmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\managers\campaignmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametype.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: normal

Physics : threaded

going to replace the entire context.xml with bp_wp's context.ml this time...restart pc....to be continued....

Link to comment
Share on other sites

ok crash seems to be confined to the Training/shooting range...coz it works:

graw2re0.th.jpg

without the skin.... :(

so, now I'll replace the context.xml with original context...copy & paste bp_wp first paragraph into the original context.ml and restart pc again...cross my finger :D

Link to comment
Share on other sites

no dice...I even used Brettzie name as my profile name looking for an easter egg :P ...still no skin...here's current directory and comparison of context.xml and copy of original context.xml:

bpdirjq3.th.jpg

I'm out of resources...going to make some Hawaiian Kona coffee...have a nice day folks

Link to comment
Share on other sites

i got a 8600 gt oc'd

and like 1.5 gb (says 1 gb though)

im sure i did everything correct

and i dont think ram or the gpu would effect

probably has something to do with the files

but the files are correct too >,>

Just a wee note here on oc card, this does cause and is reported on more than a few occasions causing problems.

Your memory is what exactley one 1 gig one 512 are they compatable, is the MB dual channel.

Glitch gpu is more than likely OC, driver, or memory problem.

lol i dont think theres any problem with that though

and the MB is dual channel

ive got alot of games running on my oc'd card and all of those games run fine

its just the mod im having problems with lol

stupid ghost's helmest =(

really like those helmets that brettzies made

Link to comment
Share on other sites

Cpl, I've always gotten a crash at training grounds in past on Brett's previous mods, so I didn't try it this time around. In your post with explorer pages, context file points to english folder--that would cause probs. Create a graw stuff folder in your documents-well away from graw2 program files, put original context there and use Brett's. Do you have anything inside your English folder? If you aren't playing online with others try unbundling the mod file and use original context file and run mod from English folder. Wolfsong has a short method to unbundle, I've always used the windows command prompt route under windows/accessories.

Can't remember which folder I put Brett's bundle in so just copy his bp_weapons_v1.4 bundle into bundle folder and public tools/bundler folder. In bundler folder, create a data folder. Go to command prompt and do the following:

Paste this after > in opening command prompt window (no space):

cd\Program Files\UBISOFT\Ghost Recon Advanced Warfighter 2\public_tools\bundler (hit enter key)

Paste this after next line shows up after the > (no space):

bundler extract -h (hit enter)

Paste this after > (no space):

bundler extract -r bp_weapons_pack_v1.4.bundle data data (hit enter)

It will extract info into the data folder you created in bundler folder (maybe 10 -20 seconds). I just copy and paste contents of data folder into english folder and it's ready to go (using original context xml). Move data folder to your graw stuff folder under your documents should you want to tweak any files in english folder and mess up--you can just copy and paste orig mod files from that data folder. Delete bp_weapons.... bundle from the 2 locations I mentioned. You can do this with any mod bundle--just change bundler extract -r line to reflect mod.bundle name data data.

This is for windows xp. I believe Rocky made a faq under graw 2 with Wolfsong's shorter method from run command.

Link to comment
Share on other sites

One guy sent me an email that he had a problem with the skins working but not weapons. I don't exactly know how he installed, but it sounded like just the existance of the english folder caused issues. So, here's his quote and what he did to get it to work:

I downloaded WP v1.4 and unziped to the GR2 main folder. I had the problem where I was getting the skins but not the weapons. When I renamed the ENGLISH folder the new weapons showed up. I guess this means you can't have English in the folder. My English was the rename of WPv1.2. Hopes this helps.

Doesn't really make sense because I had an English folder the whole time, but who knows. Give it a shot. Just take out the English folder, you never know.

Link to comment
Share on other sites

Unbundling is another good idea that might save some of you since it will only be looking in one spot now.

Bascially you unbundle the bp_weapons_pack_v1.4.bundle and put those folders inside the bp_weapons_pack_v1.4 folder. So everything should be in that folder with the sound and movies folder. You can then delete the bundle and remove the line from the context xml:

<mod_bundle name="bp_weapons_pack_v1.4"/>--><!--delete this line or comment out front with "<!--" to uninstall-->

Funny, the only reason I went with this two style method was to see if mp would work beyond attachment id#31. It didn't, so this was kind of pointless. Perhaps the new patch will help, but this method seems to cause more problems for people for some reason.

Brett,

I'm loving it and I have no problems :thumbsup: . Excellent work and now I'm interested in the game again, even more than I did since I had the game, and that is the biggest compliment I can give you. Thanks!

That's awesome man. I appreciate it. If only it could work seemlessly for everyone and mp wasn't glitched on the attachment side. Edited by Brettzies
Link to comment
Share on other sites

Hey Brett, I have it working now. Required a 100% full reinstall, apparently my campaign status or config had a conflict.

Have TWO more questions for you.

1. Is there supposed to be a physical sight to view through on the eotech sight? I've got the hologram frame but no "cross-hairs"

2. Does the mod affect the weapon_data.xml file? I'm really sick of only have 5 mags for some of my weapons. What do you suggest I do?

Link to comment
Share on other sites

Hey Brett, I have it working now. Required a 100% full reinstall, apparently my campaign status or config had a conflict.

Have TWO more questions for you.

1. Is there supposed to be a physical sight to view through on the eotech sight? I've got the hologram frame but no "cross-hairs"

2. Does the mod affect the weapon_data.xml file? I'm really sick of only have 5 mags for some of my weapons. What do you suggest I do?

Glad you got it working.

1. It should look like the red cross hair from the MRC eotech sight.

2. Yes. But, you can unbundle everything and edit the ammo count if you wish. Or, I think I might put the lib folder up and people can stick that in their folder with the movies and sound. It's probably less then 1meg and has all the essential files for editing ammo, headgear, etc. But let me test it real quick to make sure you can do it without having to unbundle.

Link to comment
Share on other sites

If you don't want to unbundle the whole thing, but still want to be able to customize the headgear or ammo counts, you can download this file and unzip it into your main Graw2 dir. It should put the lib folder in the correct place(local/bp_weapons_pack_v1.4) if you did the normal installation. If not, just move it to whatever folder you have the files in.

bp_weapons_pack_v1.4/lib directory and files

It's very small, less then 1meg.

Edited by Brettzies
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...