Jump to content

Extra animations


Tinker
 Share

Recommended Posts

http://www.ghostrecon.net/forums/index.php?showtopic=9430

Oso:

Neutron didn't use the <dyn> tag in his maps. The Radar dish is a door that is animated to rotate on its helper point. It is flagged to start animating in the map editor plugin with linear rotation. The other thing he did was to set the animation to ping-pong so it rotates to a certain point and then back to the starting point and so on.

I`ll be giving this a shot. If I can add it as a indestructible door, should work?

:pirate:

Link to comment
Share on other sites

Try making it as a <n><dyn> object, with each part that moves as a <n> group within it. Make sure all groups have O helpers.

I assume you added animation key frames, and set the animation to loop? If it doesn't loop, the animation may finish before you even see it.

Link to comment
Share on other sites

Here is what i have done.

Made a flag and animated it to have i wanted it and saved it.

Opened the boat up and merged the flag into scene and positioned it accordingly. At this point i can press play

and see it animating in max.

Added a "O" helper and grouped the helper plus flag as <n><dyn>flag-01

Added in map editor to start animating.

Ungrouped the boat and added the <n><dyn> group to the <n><body> group then regrouped as <n>

<_<

Not sure i know what you mean about looping?

Link to comment
Share on other sites

Open up track view

trackview.jpg

select object and position or rotation (square symbols are object parameters, circle symbols are position/rotation/scale)

Click the parameter curves button.

keyframes.jpg

Click the start and end out-of-range buttons for cycle or loop (they both seem to work the same way). If you want your animation to ping-pong back and forth, select that option.

param-curve.jpg

Make sure your rotation and position animations are linear. That is the only mode that will work.

Select position or rotation, then click the assign-controllers button

controllers.jpg

Make sure linear position and linear rotation are selected as defaults.

pos-control.jpgrot-control.jpg

Link to comment
Share on other sites

:lol:

Still not working! All settings in track view are correct. I think it is the dynamic group that is wrong.I made my flag, animated it, then give it a helper and grouped both as <n><dyn> Am i supposed to animate the group like you would a door?

f_lag.jpg

:wall:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...