Jump to content

New GRAW2 Classes


Recommended Posts

Coming Soon.

It must be advertised so online servers has this mod

I don't think they would want to use it that much right now as the kit setup isn't really good for open servers. Right now all classes are available in MP and Coop. That includes the Grenadier class with M32... for example. The Beta will have different restrictions.

It will be up today. Got it to Rocky last night. :)

So try it out and give suggestions on what restrictions you'd all like to see, and I'll fix as much as I can. Also, give feedback/suggestions on the kits themselves as this is an open alpha released for just that reason, so the users opinions will be part of the final setup.

It will also be interesting to see how heavy people find the game now. 300m draw distance may be too long. We'll just have to test. ;)

Link to comment
Share on other sites

  • Replies 294
  • Created
  • Last Reply

Top Posters In This Topic

Hmm, I'm having some issues with it too. First, I just tried to start a SP mission and it crashed to desktop with an error about missing data.

Then I started it back up and tried to create a LAN game and my PC hard-locked.

I'll keep playing around and see if I can get at least some of it working. Wolf, if you've got any info on what I should/should not be doing to get it to work, let me know ;)

Link to comment
Share on other sites

Yep, same. Bundle in place and using batch file to launch.

EDIT: Ok, got a LAN server set up and working now. Loaded up all the different map types and I can see the new "class types" (eg: tracker, scout, etc) to select from, but it's still selecting the old classes and equipment. GUI problem maybe?

Edited by Faceman
Link to comment
Share on other sites

^

^

(SP) Act 1, Mission 1, played through completion. Draw distance noticeably increased, as well as AI aggressive behavior...the Banditos are much more curious. no hang-ups, CTDs', or glitches.

(MP) I ran the Sierra and Retrieve CoOp maps, and various other PVP maps with no problems, map change is alittle slow, but that might be a result of the 1.05 patch...but it's not that bad. The new kit replacements were accessable as normal.

Link to comment
Share on other sites

Yep, same. Bundle in place and using batch file to launch.

EDIT: Ok, got a LAN server set up and working now. Loaded up all the different map types and I can see the new "class types" (eg: tracker, scout, etc) to select from, but it's still selecting the old classes and equipment. GUI problem maybe?

That's what I get.

Link to comment
Share on other sites

Looks like I missed something when I packed it up... I'll take a look at it tonight and get a new version out ASAP. Should be a small error as it worked when I tested it before packing it up.

Yep, same. Bundle in place and using batch file to launch.

EDIT: Ok, got a LAN server set up and working now. Loaded up all the different map types and I can see the new "class types" (eg: tracker, scout, etc) to select from, but it's still selecting the old classes and equipment. GUI problem maybe?

That's what I get.

Could be your XMB files in the user folder. I had that before I cleaned them out.

Link to comment
Share on other sites

Spoke too soon...3 CTD, back to back

----------------------------------------------------------------------

LAN Only- CoOp Retrieve, on entry to map

Fri Feb 15 05:54:28 2008

Crash in application version: 30899.3048

[TextureDB] Set atlas_gui is both dynamically and statically scoped

SCRIPT STACK:

data\lib\utils\worldinfo.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

----------------------------------------------------------------------

LAN Only-CoOp Sierra, +/-2 mins in, in the process of scoping

Fri Feb 15 05:59:24 2008

Crash in application version: 30899.3048

Unhandled exception - access violation

C STACK:

graw2 (???) : ???

??? (???) : ???

graw2 (???) : ???

??? (???) : ???

Renderer: threaded

Physics : threaded

----------------------------------------------------------------------

LAN Only-CoOp Sierra +/- 5min in

Fri Feb 15 06:03:00 2008

Crash in application version: 30899.3048

Unhandled exception - access violation

C STACK:

graw2 (???) : ???

??? (???) : ???

graw2 (???) : ???

??? (???) : ???

Renderer: threaded

Physics : threaded

Link to comment
Share on other sites

Spoke too soon...3 CTD, back to back

----------------------------------------------------------------------

LAN Only- CoOp Retrieve, on entry to map

Fri Feb 15 05:54:28 2008

Crash in application version: 30899.3048

[TextureDB] Set atlas_gui is both dynamically and statically scoped

SCRIPT STACK:

data\lib\utils\worldinfo.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

this one can be fixed easy. It's an error in the original file, which normally doesn't cause a crash... unless when I have fixed something I found in another file... So I'll fix that tonight.

The others though... Don't know if they are related to this mod. But I'll do some more MP testing this weekend. Mostly tested it in SP, besides starting all the kits.

Link to comment
Share on other sites

Checked the missing "HUME_m09" problem. It has to be an XMB error. It's correct inside the mod.

Gonna look at adding some kind of XMB killer in the BAT file. But not really sure where XP puts the XMB files as I've only used the retail version of the game on Vista.

Gonna look at the texture scope crash now.

Link to comment
Share on other sites

LAN Only- CoOp Retrieve, on entry to map

Fri Feb 15 05:54:28 2008

Crash in application version: 30899.3048

[TextureDB] Set atlas_gui is both dynamically and statically scoped

SCRIPT STACK:

data\lib\utils\worldinfo.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

As I guessed, I don't get this crash either. I was a bit too obvious so I shouldn't have missed it as I got that on another map while testing and fixed that.

So basically I have no changes to do to the bundle right now. I'll look at the installation then.

EDIT:

I've fixed the XMB removal for Vista now. It should be automatic.

I'd like help with one thing though. If someone with XP could run a search on their C: for any XMB files, and post the path to them and you installation path for GRAW2. That way I can also make sure that all XMB files are cleaned from XP users when starting the mod. :)

Remember that XMB files are only XML files, so you always have the original XML files still intact, so it won't destroy your game in any way. :)

EDIT2:

I'll actually set it up as a separate XMB cleaner file so it can be used whenever anyone wants to clean out their XMB files, enabling/disabling local folders or mods or simply wanting to go back to the original game (which would also require cleaning out the local folder manually first though).

Link to comment
Share on other sites

Looks like I missed something when I packed it up... I'll take a look at it tonight and get a new version out ASAP. Should be a small error as it worked when I tested it before packing it up.

Yep, same. Bundle in place and using batch file to launch.

EDIT: Ok, got a LAN server set up and working now. Loaded up all the different map types and I can see the new "class types" (eg: tracker, scout, etc) to select from, but it's still selecting the old classes and equipment. GUI problem maybe?

That's what I get.

Could be your XMB files in the user folder. I had that before I cleaned them out.

Umm, where's this user folder?

I'd like help with one thing though. If someone with XP could run a search on their C: for any XMB files, and post the path to them and you installation path for GRAW2. That way I can also make sure that all XMB files are cleaned from XP users when starting the mod. :)

I'm running XP and did a search on my entire C:\ drive and the only XMB file I found was the mod_version.xmb in the public_tools/bundler folder. Weird.

Link to comment
Share on other sites

WinXP search for xmb

mod_version.xmb GRAW2\public_tools\bundler\

mod_version.xmb public_tools/bundler (I don't understand this search result as I can only see one xmb file when broswing for it, but XPsearch finds 2, each with a different last modified time.)

There were no xmb in my Docs and Settings folder at all.

Local/english has an empty gui folder.

Link to comment
Share on other sites

Hang on, I ran it again in Docs and Settings, this time searching hidden and system folders.

c:\Documents and Settings\<user>\Recent (Type : shortcut)

c:\Documents and Settings\<user>\Local Settings\Temp\Temporary Directory 1 for public_tools.zip\public_tools\bundler ( XMB file) :blink:

Link to comment
Share on other sites

Ok... but XP has to store the XMB files somewhere...

The user folder is you windows account user folder. It stores all application settings for each user.

EDIT: Oh, and you had nothing in the english local folder, right?

Just curious, but why does XP need to store these XMB files? I gather they're are somehow just compiled XML files for the Diesel engine to read, but why cant it simply read straight XML files in the first place?

I've searched through my entire hard drive, specifically double checking the My Documents and my Documents and Settings folders recursively and no other XMBs turned up.

BTW, I don't have an english folder in my local folder... just bp_weapons_pack_v1.41. Could this be an issue?

Hang on, I ran it again in Docs and Settings, this time searching hidden and system folders.

c:\Documents and Settings\<user>\Recent (Type : shortcut)

c:\Documents and Settings\<user>\Local Settings\Temp\Temporary Directory 1 for public_tools.zip\public_tools\bundler ( XMB file) :blink:

Rocky, I'm guessing thats a temp folder for WinZip or whatever ZIP program you use to store stuff you've viewed or extracted from public_tools.zip?

Link to comment
Share on other sites

Like all software, compiled files works better. So it compiles the XML files into XMB files for better access.

So it should compile the XML files at startup, if it doesn't already find a compiled version of that file. With makes starting the game take longer when you don't already have stored XMB files.

I'll have to find some XP computer that I can install the game on and have a look at for myself. It has to store the settings somewhere outside the install folder. I remember Monolith noticed something like that as well when he was playing around with the AI stuff.

Link to comment
Share on other sites

Like all software, compiled files works better. So it compiles the XML files into XMB files for better access.

So it should compile the XML files at startup, if it doesn't already find a compiled version of that file. With makes starting the game take longer when you don't already have stored XMB files.

I'll have to find some XP computer that I can install the game on and have a look at for myself. It has to store the settings somewhere outside the install folder. I remember Monolith noticed something like that as well when he was playing around with the AI stuff.

Why doesn't the bundler just pre-compile these XMLs at the bundle stage? Seems kind of redundant having duplicate (though compiled) files, let alone all over your machine instead of one central location don't you think? And how much processing time can really be saved on reading "compiled" over flat-text XML files?

I might be missing something, but it seems like a very odd "round about" way of doing things IMHO. All the same, it could be this very issue (that XP seeems not to compile and cache these XMB files) that could be causing the problems Rocky and I are both experiencing...

Just out of curiosity, NoQuarter were you testing the mod in XP or Vista?

Link to comment
Share on other sites

It's the way you do it for most software actually.

XML is a markup language made to easily be able to update or add to databases. XMB (B is for binary encoded) is only used to speed up the use of them when they are actually used, but not needed.

It's turned off for XML files in bundles when I think of it. So of course there are no XMB files. My bad. It only stores copies of the XML in XMB format while we are working on the unbundled game. :wall:

I bet it works with a fresh install of GRAW2 with just the patch added. Just like people that where having problem with the weapon mods got them to work with a fresh install. So somehow it stores which files to use at startup to make the software run faster next time. I'll do some more tests to see what I find out...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...