Jump to content

Multiplayer Problems "Waiting for Server"


Recommended Posts

Hello

I've got a problem with GRAW2 and playing Multiplayer online. I had the exact some problem with the demo too.

There are a few problems though i suspect they are all related to the same issue.

I'll list the problems i get below.

1. "Waiting for Server"

This happens alot, will they their waiting for server and i never get in. Currently this happens mainly on the GameArena server. I have been able to get into other servers fine.

2. After Multiplayer game finishes i get stuck at the score screen.

When i do get onto a server, i can play fine. But at the end of the level i always get stuck at the score screen. Only way to exit it, is to press ALT F4. I've never ever been able to play more than one game without getting stuck.

3. Stuck as choose weapon screen.

Sometimes when i do get into a game, i get stuck at the choose weapon screen. Here i can exit the level and try again.

My system.

Vista 32bit.

AMD 5200+ dual core

Nvidia 8800GT video

MSI mother board.

Creative Audigy 2 ZS with ALchemy drivers

My Network.

ADSL 1.5/256k internet connection

Billion 7402L adsl router/modem.

Astaro Security Linux V5

What i have tried so far.

Uninstall all drives and cleared registy. Reinstall all the latest drivers for everything.

Uninstall GRAW2 re installed with UAC disabled.

Ran GRAW2 as admin

Changed network cards

Change audio drivers

Changed video card from 7900gs to 8800gt

Changed OS back to XP

Upgraded firmware on Billion router.

Connect PC directly to router. Removed Astaro firewall.

Upgraded AGEIA to 7.06.25

Ran AGEIA as admin

Ran GRAW2 on another computer. Though this other PC had the exact same specs as mine.

Thats about it. Don't think i've missed anything.

To me it sounds like some sort of network problem, either with my PC, router or even my ISP.

I've posted on the GRAW2 forums, with no luck.

So i'm now sending this to you guys.

Please help.

Also been doing alot of readying alot trying to find help somewhere. :) Somepeople have talk about changing the upload speed into the console in the game. Does anyone know the command to change or look at the current upload speed.

Regards,

Scott

Link to comment
Share on other sites

Hello

Finally some good news.

I've changed over my Billion7402L route/modem, wthi a TP-Link 8810.

I've been able to play GRAW 2 without a single disconnection.

I have no idea what the difference with between the tewo modems, i know there is about $100 difference in price. Being the TP-Link the cheaper one.

Any how it's working at the moment. whooooooo

I might try and reset the Billion7402l to factory defaults at somepoint to see if that fixes the Billion.

At this stage i'm just going to injoy playing GRAW 2 for a while

Hope this bloody long post may help some people having the same problem.

Try a different modem.

Regards,

Scott

Link to comment
Share on other sites

Hello

Finally some good news.

I've changed over my Billion7402L route/modem, wthi a TP-Link 8810.

I've been able to play GRAW 2 without a single disconnection.

I have no idea what the difference with between the tewo modems, i know there is about $100 difference in price. Being the TP-Link the cheaper one.

Any how it's working at the moment. whooooooo

I might try and reset the Billion7402l to factory defaults at somepoint to see if that fixes the Billion.

At this stage i'm just going to injoy playing GRAW 2 for a while

Hope this bloody long post may help some people having the same problem.

Try a different modem.

Regards,

Scott

The difference between those two routers would be handling of UDP fragmented packets.

Link to comment
Share on other sites

Bah Ive given up on Multiplayer GRAW2.

I have so many problems with MP.. Ive tried many times, I couldnt even play one game!

* The servers almost always time out, its a HUGE task for me to connect successfully. I need to try 20 servers to get one working one, and then I get more problems..

* The only time I was actually playing in a level, it kicked me out because someone used my CD key (I bought the game, its 100% legit)

* Another time it thought I had modified files, all ive installed is the game and the latest patch. I havent touched any other files.

* I got stuck in the Team selection screen.

* All my pings are 600ms or over, up to 3000! When I play Jedi Academy, I get 200ms pings on most servers.

I can play BF1942 and JA:MP no problems online. GRAW2 hates me :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...