Jump to content
Ghost Recon.net Forums

on Vista + experience trouble seeing some servers?


Recommended Posts

A message from our Senior Engine Architect here at GRIN

1. If you experience troubles seeing some servers on Vista, it might come from Firewall issues (Vista does not automatically allow ICMP packets even for whitelisted applications)

- go to control panel, Administrative tools

- go to "Windows Firewall with Advanced Security"

- select "Inbound Rules" on the left, and then on "New Rule" on the right

- Choose "Custom", then "Next", "All Programs", "Next", protocol-type="ICMPv4", "Next", "Next", "Next", "Next", Name="ICMPv4", "Finish"

- do the same with ICMPv6

Will investigate if we can do that automatically in the next patch.

Bo

Link to post
Share on other sites

Thanks Bo. Did this as well. Just a note though it's easier to just use the search box and type in "windows firewall with" and select it from the start menu instead of going through the control panel. The search box for Vista is probably the best improvement over XP Vista has. It makes things very easy to find.

Link to post
Share on other sites

A message from our Senior Engine Architect here at GRIN

1. If you experience troubles seeing some servers on Vista, it might come from Firewall issues (Vista does not automatically allow ICMP packets even for whitelisted applications)

- go to control panel, Administrative tools

- go to "Windows Firewall with Advanced Security"

- select "Inbound Rules" on the left, and then on "New Rule" on the right

- Choose "Custom", then "Next", "All Programs", "Next", protocol-type="ICMPv4", "Next", "Next", "Next", "Next", Name="ICMPv4", "Finish"

- do the same with ICMPv6

Will investigate if we can do that automatically in the next patch.

Bo

Just to add, that may also apply if you have a firewall / router that is actively blocking ICMP pings.

So if you think your server list looks small, make sure you're not blocking those ICMP pings.

Link to post
Share on other sites

By doing this (allowing ICMP to pass thru router's firewall) you're becoming visible to the whole Internet... creating a security hole. Why do the server holding the server list have to ping my PC using ICMP ? It already uses UDP (and probably a couple of TCP sessions as well)... is that not enough ?

Compromising local network security to play that game online should be considered a bug, imo. I highly hope there's gonna be a work around for this as I'm not gonna open ICMP protocol on my firewall.

Are these ICMP packets will always coming from the same source ? That way I could simply create a firewall rule allowing ICMP to pass thru only for a specific IP or subnet... a much secure option.

Link to post
Share on other sites

Thanks BO, but even with XP there are trouble seing servers.

What are the differences between GRAW1 and GRAW2 as it comes to hosting?

Now I have a spare PC, good ADSL connection I'd like to be able to host, but my knowledge of firewalls, network routers etc is very limited so it should be fool proof for me.

There is a PC compatibility test for GRAW2 isn't it possible to make such a feature which allows you to see why you cannot host (test connections, ports, internet speed settings and such). Maybe tweakers can make one?

I'd be glad to test it

Edited by Forrester
Link to post
Share on other sites

We're working on removing the need of ICMP support.

As Ichabod said, it's not only an issue on Vista using Windows Firewall, it's an issue for all firewalls/routers blocking icmp packets.

For instance, on XP SP2 using Windows Firewall, go to Control Panel / Security Center / Manage security Settings for Windows Firewall / Advanced / ICMP Settings. Make sure that "Allow incoming echo request" is enabled (afaik you don't need more).

Link to post
Share on other sites

We're working on removing the need of ICMP support.

As Ichabod said, it's not only an issue on Vista using Windows Firewall, it's an issue for all firewalls/routers blocking icmp packets.

For instance, on XP SP2 using Windows Firewall, go to Control Panel / Security Center / Manage security Settings for Windows Firewall / Advanced / ICMP Settings. Make sure that "Allow incoming echo request" is enabled (afaik you don't need more).

thanks, I will try (when I'm allowed <_< )

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...