Jump to content
Ghost Recon.net Forums

Hearing everything except my own gun


Recommended Posts

So i tried the GRAW2 demo yesterday. Everything seemed to be working good, except for the sound. I hear everything, except my own gun. How can i fix this? I didnt see anything about this issue on the "GR:AW 2 - Tech Support" forums. Specs:

AMD Athlon64 X2 5000+

3GB DDR2 ram

ATI Radeon 1950pro 512mb PCI-E

M-Audio Fast Track USB soundcard

I don't think its a soundcard support issue because i can hear everything correct and in perfect 3d sound. :)

Link to post
Share on other sites

Disable EAX and make sure that in the Windows/ your sound card driver's settings to be in the proper speaker setting.

For Windows, go to Start -> Control Panel -> Sound and Audio Devices -> Advanced (Speaker Settings).

Link to post
Share on other sites

Disable EAX and make sure that in the Windows/ your sound card driver's settings to be in the proper speaker setting.

For Windows, go to Start -> Control Panel -> Sound and Audio Devices -> Advanced (Speaker Settings).

Thanks for the replay! EAX is disabled already, and the speaking settings are set correctly.... :(

Link to post
Share on other sites

Disable EAX and make sure that in the Windows/ your sound card driver's settings to be in the proper speaker setting.

For Windows, go to Start -> Control Panel -> Sound and Audio Devices -> Advanced (Speaker Settings).

Thanks for the replay! EAX is disabled already, and the speaking settings are set correctly.... :(

It's your soundcard. It's treating 2d stereo sounds differently than other sounds, making the 1st person weapon (which is a stereo sound played in 2d) lower. We'll patch this for any soundcard that we are informed has this problem - although I suggest you get a better sound card because that would not only fix this issue but make the game sound a lot better overall. Ask anyone who has upgraded to an Creative X-Fi card.

Link to post
Share on other sites

Disable EAX and make sure that in the Windows/ your sound card driver's settings to be in the proper speaker setting.

For Windows, go to Start -> Control Panel -> Sound and Audio Devices -> Advanced (Speaker Settings).

Thanks for the replay! EAX is disabled already, and the speaking settings are set correctly.... :(

It's your soundcard. It's treating 2d stereo sounds differently than other sounds, making the 1st person weapon (which is a stereo sound played in 2d) lower. We'll patch this for any soundcard that we are informed has this problem - although I suggest you get a better sound card because that would not only fix this issue but make the game sound a lot better overall. Ask anyone who has upgraded to an Creative X-Fi card.

Thanks for the replay Desmond22. :) But i bought this soundcard for recording and propper ASIO support. Creative cards do alot less good IMO...

I also have the intergrated soundcard in my computer. Maybe that will work better?

Link to post
Share on other sites

Well the soundcard might be good for music production (I have an M-Audio myself for music production, although that's on a Mac), but that doesn't mean it's suitable for game audio output, which is a blend between mono sounds played in 3d, mono sounds played in 2d and stereo sounds played in 2d.

Creative have had some problems with their OpenAL (which our sound engine is built around) having soundcards treat those different kinds of sounds (mono/stereo, 2d/3d) differently, but an updated driver is coming by the end of this month I've heard.

If Creative doesn't fix it soon enough, we'll fix it - although that means we have to identify each and every soundcard that produces the bug. The fact that you post here on the forum and let us know you have the problem, and also state what sound card you have, is great.

Integrated sound cards generally produce the same problem, but you can try. I, however, would suggest you run the audio in general software mode until we have a fix for this.

Link to post
Share on other sites

Well the soundcard might be good for music production (I have an M-Audio myself for music production, although that's on a Mac), but that doesn't mean it's suitable for game audio output, which is a blend between mono sounds played in 3d, mono sounds played in 2d and stereo sounds played in 2d.

Creative have had some problems with their OpenAL (which our sound engine is built around) having soundcards treat those different kinds of sounds (mono/stereo, 2d/3d) differently, but an updated driver is coming by the end of this month I've heard.

If Creative doesn't fix it soon enough, we'll fix it - although that means we have to identify each and every soundcard that produces the bug. The fact that you post here on the forum and let us know you have the problem, and also state what sound card you have, is great.

Integrated sound cards generally produce the same problem, but you can try. I, however, would suggest you run the audio in general software mode until we have a fix for this.

It all about the Sound Blaster Xi-Fi, Ive got the Fatal1ty and it gains about 3-4 meters when listening for sounds. Almost feel like im cheating. The only problem is you have run auto detect on the sound settings every time you star GRAW 2 demo inorder to activate the "Xtreme" settings. Trust once you get it, you wounder how you lived with out it. Actually if everyone had it I wouldnt gain any advantage. Don't listen to me its crap :P

Link to post
Share on other sites
  • 2 weeks later...

Same thing happened to me right when I switched to Vista. Tforce 550 mobo using onboard sound, worked fine with XP, I installed Vista and now I can't hear my own gunshots and my soundcard isnt even listed under audio,just generic options.

Link to post
Share on other sites

Disable EAX and make sure that in the Windows/ your sound card driver's settings to be in the proper speaker setting.

For Windows, go to Start -> Control Panel -> Sound and Audio Devices -> Advanced (Speaker Settings).

Thanks for the replay! EAX is disabled already, and the speaking settings are set correctly.... :(

It's your soundcard. It's treating 2d stereo sounds differently than other sounds, making the 1st person weapon (which is a stereo sound played in 2d) lower. We'll patch this for any soundcard that we are informed has this problem - although I suggest you get a better sound card because that would not only fix this issue but make the game sound a lot better overall. Ask anyone who has upgraded to an Creative X-Fi card.

Thanks for the replay Desmond22. :) But i bought this soundcard for recording and propper ASIO support. Creative cards do alot less good IMO...

I also have the intergrated soundcard in my computer. Maybe that will work better?

When you say creative sb cards do a lot less good iyo, do you get bad feedback or crackling, or latency (lag) issues when recording stuff on ya pc with creative sb hardware? i have never tried any other sound card other than creative soundblasters, i have been using sb creative hardware for a long time now i can't recall having many if realy any issues when composing music on pc. I'm no music genious but i do like to mess around with music software now and again (have used cubase vst5 and various music demos, FL7), i have a Axiom25 midi controller and use a sb X-FI extreme music card, i find the creative asio drivers work a treat in win xp i can get down to 2ms and i don't suffer with hardly any latency issues and when i finish with trying to master the jean michelle jarre techno classic moog magic stuff i can just switch over to gaming goodness within the creative audio console.

But i guess each to there own and what they get on best with, but i do like the fact creative have covered most decent options with there hardware and it's a bonus when developers support your hardware too.

Same thing happened to me right when I switched to Vista. Tforce 550 mobo using onboard sound, worked fine with XP, I installed Vista and now I can't hear my own gunshots and my soundcard isnt even listed under audio,just generic options.

I realise windows vista has discontinued support for directsound directsound3d, so thank goodness for openal support or i would definatley not think about giving vista a try out sometime in the near future.

Link to post
Share on other sites

I'm getting the same sound problem with my new Creative X-Fi card.

I downloaded the latest drivers.

I am using a Logitech Premium USB Headset 350 headset. (This might be the problem?)

**Update: I think this has to do with my headset VS. my sound card, If I change the settings to my X-Fi card I have no sound at all, so I am forced to use the Generic settings. I will buy a "plug" version headset or find a USB to plug adaptor (never had that much luck with those) and test that and reply back with my findings.

Edited by c0w80y
Link to post
Share on other sites
I'm getting the same sound problem with my new Creative X-Fi card.

I downloaded the latest drivers.

I am using a Logitech Premium USB Headset 350 headset. (This might be the problem?)

**Update: I think this has to do with my headset VS. my sound card, If I change the settings to my X-Fi card I have no sound at all, so I am forced to use the Generic settings. I will buy a "plug" version headset or find a USB to plug adaptor (never had that much luck with those) and test that and reply back with my findings.

Yikes, I was thinking of switching to the exact same sound card and headphones. Desmond, what you recommend for sound card and headset?

Link to post
Share on other sites

Update: I purchased a Logitech premium stereo headset with the standard plugs and now I hear everything fine, all weapons sound great! So the USB version (I only used the Logitech 350) seems to cause an audio problem defaulting to generic sounds, missing out on the full atmosphere in game.

**Now, I don't know if this is a Micro$oft issue related to the USB interface translation or a Creative labs card driver (I know I don't get the advanced options when using the USB headset.) or just my system board on how it decodes the USB ports data. I do know that it does effect other games as well; RB6 Vegas, ArmA, Vietcong 1&2, M$ CFS3, all these had vast sound improvments once I switched to the standard plug headset.

Edited by c0w80y
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...