Jump to content

Mk12 mod 0 SPR - v3.1 patch


Brettzies
 Share

Recommended Posts

  • Replies 118
  • Created
  • Last Reply

Top Posters In This Topic

mk23_graw_06.jpg.w560h691.jpg

Larger Image

Funny, GRiN spends alot on the little details but they seemed to miss this one. They didn't parent the silencer align to the barrel_anim null. I noticed this when my empty mk.23 w/silencer was on the ground after I died and could see that it didn't move with the barrel. I thought maybe it was a limitation with skinning or something, but figured I'd try it out anyway. So I went back looked at the sample file and it wasn't parented. I changed that in my file and rexported the weapon with the silencer align parented to the barrel_anim. Sure enough, it moves with the barrel. You can see in the bottom image, the silencer is not aligned to the M9, but in the top one, it's stuck on there. Not a huge deal, but may as well do it correctly if possible.

Link to comment
Share on other sites

Thanks guy, I'm glad you like such a small addition.

I was wondering if anyone else noticed that the name of the Mk23. Socom .45ACP doesn't show up in the weapon selection menu. The gun is there and it works perfectly, but there is no name.

That is strange. You may have copied over the strings/weapons.xml on accident or not copied it at all perhaps? It only shows up as Mk.23 Socom, btw.

Link to comment
Share on other sites

Something I noticed and I hope it is my end, the M4 has intermittent sound. Every other shot is muted. Does anyone has the same problem with this version?

Mk23. Socom .45ACP

In the game it is set to 9mm, Is it suppose to be .45?

Edited by Bat21
Link to comment
Share on other sites

Something I noticed and I hope it is my end, the M4 has intermittent sound. Every other shot is muted. Does anyone has the same problem with this version?

Mk23. Socom .45ACP

In the game it is set to 9mm, Is it suppose to be .45?

I've documented both of these issues in the readme, you probably missed them because they are on the last page. The intermitent sound one I'm not quite sure about. Every now and then I get it, but usually it's once in a blue moon. Usually just reloading helps.

There's no way to actually make a new ammo set in the game properly, just change damage values to reflect a more powerful round. I thought I updated any "strings" the user will see in the interface, but you will still pick up 9mm mags on the ground and add them to yours unrealstically. I think there might be a way to change that, but I can't remember. I think it broke some other things when I tried it.

Link to comment
Share on other sites

Crash in application version: grpcrc1.35

data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: world_pos in type <void>

SCRIPT STACK

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Every time I tried to enter a server who don't have your mod instal and that is happening even if anti-cheat is off.And when I'm running my client server "F.O.A.D" with the anti-cheat off client who try to connect to it crashed if they don't have your mod on.I know that everytime you use something called "husk" that will crashed the game I have this experience when building map with the editor.I hope you will be able to fixed that cause your mod is very good and realistic like it was part of the original game.Everybody should be using it.Keep on the good work!

Link to comment
Share on other sites

Sorry to hear that you are crashing. That error is related to mod_id#s(weapon attachments) I think. Do you have any other weapon mods installed? Or have you added some weapons to secondary or attachments? I know that I've maxed out all the available id#s for attachments so if you have anything else and even if the server has the file, you will crash out. If you are running the server you will not crash out, even with extra mod_id#s(attachments). mod_id#31 is the max for mp.

So, if you have my mod running, and then have added on to that with another one and join a server, then pick a weapon with an attachment above #31, you should crash. If you don't have any other weapon mods installed, then I'm not sure. I'd say clear out and try again with v3.2

I'm not using anything called husk, that is just something the game does.

Link to comment
Share on other sites

Sorry to hear that you are crashing. That error is related to mod_id#s(weapon attachments) I think. Do you have any other weapon mods installed? Or have you added some weapons to secondary or attachments? I know that I've maxed out all the available id#s for attachments so if you have anything else and even if the server has the file, you will crash out. If you are running the server you will not crash out, even with extra mod_id#s(attachments). mod_id#31 is the max for mp.

So, if you have my mod running, and then have added on to that with another one and join a server, then pick a weapon with an attachment above #31, you should crash. If you don't have any other weapon mods installed, then I'm not sure. I'd say clear out and try again with v3.2

I'm not using anything called husk, that is just something the game does.

I was using the v3.2 an no I dont use any other mods or mixed mod at same time.Your mod is not compatible with other mods ,players need to have the same version as you or they're gonna be disconnected.The 2 person I have on my server today was able to join cause they have your mod but all the other who tried to join crashed.

Link to comment
Share on other sites

We are not having any issues on our server RPG, get on later and we can work on it and see what is going on.

You don't get my point Bat,of course I will not crashed if I join your server cause you all using the same mod and I don't crash on my server either ONLY PLAYERS WHO TRY TO JOIN MY SERVER AND DON'T HAVE THE MOD INSTALL WILL BE DISCONNECTED eVEN IF MY ANTI-CHEAT IS OFF.

Link to comment
Share on other sites

Settle down big guy, we have OGN,archangels, and other mod running by other players. We are not crashing.

Dedicated and client server don't have the same issues,you run a dedicated server I run a client server.Maybe it's the anti-cheat that is not really shutting off in a client server.I would like to know if anybody else has the same issues on a client server?I mean the server should be running M4v3.2 anti-cheat off and other trying to get in with a different mod.

I wanna know is that correct; I install the mod in my local folder and rename it then I change the "language" in the "context.xml" file to actvate or deactivate it easily.And it's working well for me.I mean everyboby should instal mod like this:

<script base="data" exec="menu/menu" editor="false" language="M4V3.2"/>

I wanna know any of you who tried to reach my server "F.O.A.D" what kind of error or crash did you get.Hitmanz3 if you read this I saw you got disconnect like 4 times...download this mod that should solve your problem.An join me on "F.O.A.D" usualy on evry day at 3 pm eastern time.

Link to comment
Share on other sites

I wanna know is that correct; I install the mod in my local folder and rename it then I change the "language" in the "context.xml" file to actvate or deactivate it easily.And it's working well for me.I mean everyboby should instal mod like this:

<script base="data" exec="menu/menu" editor="false" language="M4V3.2"/>

I actually like that method for using mods, but I think most people who have no clue about xmls and such would rather just rename the folders. It is possible that could cause problems as well. You would not think that would be the case, but then again, mod_id#32 and beyond for attachments works great in single player or if you are the server but causes issues in multiplayer.

Also, as far as having people join up who don't have the mods installed that the server is running, while it should work, it doesn't seem like something really desired since they wouldn't be able to see the weapons. The only useful thing about it would be so you could tell them to get the mods when they join up.

I don't want to blame GRiN for all these problems, but the game is very quirky when it comes to modding. It just has a lot of hiccups and guess-work. Certain things work one way but not another. Right now they are pre-occupied with GRAW2 so could care less about getting this game to work right with user made-mods.

I'm sorry you are having issues with this particular mod, but I'm having a hard time understanding why you would want or think it would work with people who don't have it installed? Even if they could join up, there are bound to be issues. Having different textures is one thing, but different unit files(weapons) and diesel files, weapon and mod_data.xmls is pushing expectations with this game in my mind.

@=AO=Stryck_9

I'm glad you are liking it and able to get some more enjoyment out of this game. Wish I could have made more progess on this about 6 months ago. Perhaps would have kept more interests and maybe Grin would have supplied more info on how to do certain things. Heck, the icons don't even work right and they wrote a tutorial on it.

Edited by Brettzies
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...