Jump to content

Could use some insight on rendering a map


MeanOldMan
 Share

Recommended Posts

Hi all

Before I delete an entire weeks work, I'd like to ask the group if anyone can help. I have put together a map using the 'industrial' set, but it will not render correctly for me. There are always completely dark areas in it. I have tried rendering with all the different detail options, and all the passes available. From draft at 1 pass to high detail at 5 passes. There are random dark areas, sometimes green trees and weapons. I have just a couple of sewer tiles in place, but they will not lighten up, always dark and blurry. I have also tried rendering with all my game details at lowest settings, and at highest settings. No joy.

Any insight would be greatly appreciated. Worst case is we start over from scratch, but half the map was done when I was slighlty tuned up on Absolute and OJ, so that part is gonna be tough... :hehe:

Thanking all

MOM

Link to comment
Share on other sites

Dont delete anything yet silly old man. Most likely your just doing something wrong. Draft and Low tend to render dark spots. Try medium 3 passes. Also keep in mind that not all the pieces listed in the editor have textures loaded for rendering.

This would show up like a checker board either black&white or blue&gold. The textures scope xml can be edited to correct the checker error.

Edited by GRIM-GENERAL
Link to comment
Share on other sites

Thanks for the help!!! I finally got it to render after deleting some of the map pieces. I'm still testing on whether the editor allows tiles to be placed that it just doesn't play well with. Getting to feel a real love/hate relationship with this editor...

Does running it windowed improve/reduce its performance? And what does exporting at high detail gain you? I have tried exporting at all detail levels (time consuming), but haven't seen much difference between med and high.

BTW, here's what I'm using to do this. It should render OK, shouldn't it?

eVga 680i

C2D e6600 w\Titan H2O cooling

eVga 8800GTX

4GB Corsair Dominator PC6400

2 74GB WD Raptors RAID

X-FI xtrememusic

Link to comment
Share on other sites

Most peoples computers cant render in the high setting. It takes alot of videocard mb and ram to do such a thing. I have a pretty good system, and cant render in high. Not to mention rendering in high will hold your pc hostage for days on end. Medium 5 passes seems to do very well.

Link to comment
Share on other sites

Does the high detail rendering improve the map visuals on the client end? The map I'm currently working on can be rendered at the high detail, but what will we gain from this? Would putting that much detail in it adversely affect the end users performance? Or it is only for the map makers benefit?

Thanks

Link to comment
Share on other sites

Yes but you'd hardly notice, The render modes: draft: low: med: high define

the amount of render detail that is made on a pass ( 1,2,3,4 etc ).

Optimum is med 3 pass for final

for testing draft 1 pass or low 1 pass.

Renders can be made in window mode (I do it all the time) but you machine

better be up to it.

TIP:

Out of memory errors come from the engine, just set your editor to low with

shadows low or off etc. then output (export) in med 3 pass for final.

black maps come from windowed renders when the system can not cope with

the mapping engine and desktop, switch to full screen render mode (no windowed editor).

Link to comment
Share on other sites

Renders can ONLY be done in windowed mode. Atleast thats what the instructions say. High render means bigger map files sizes, which means longer load times a could even cause lag and timeouts on some computer. Since my rig wont render in high , If you render it in high I would like to see it for myself if you dont mind. I bet the graphics would kick butt.

Link to comment
Share on other sites

LOL. Thru sheer ignorance, I have always rendered in full screen mode. So I tried in windowed, and it seems to work fine. I rendered the map overnite in high detail (takes 5+ hours), but when finished it had not rendered the sewer areas correctly. Dunno why. Rendering at medium for 5 passess works well. If I get it to work in high, I will send file to you. TBH, I didn't see that much difference between med and high, except one takes 5X longer to do than the other.

Link to comment
Share on other sites

Oh cool maybe Grin changed it to allow fullscreen rendering in one of the last patches.

I remember when I first started making maps it would crash in fullscreen. I would recommend always rendering in windowed mode to increase performance of the rendering process. I always render my maps at medium 5 passes. The quality is great and it dont take near as long.

Ok remeber above in this thread I said sometimes you will have to edit the texturescope.xml?

Thats whats wrong with your sewers. Sewer textures load with the industrail set. I think you said you done your map using the city set. You will have to edit the texturescope.xml to add the industrial set textures. I've done the texturescope.xml once before but cant remeber how I done so. Type texturescope.xml in the forum search field, there are some post with instructions. You can also add custom terrains in the same manner.

Edited by GRIM-GENERAL
Link to comment
Share on other sites

They definitely seem to render quicker in windowed mode. Thanks for the tip!

I am using the industrial set in the current map, so sewer tiles are already there. I tried again last nite to render at high detail, with the same result. Sewers are just blurry blocks. Everything else looks fine. So I'm sticking with 5 passes at medium detail. Actually looks about the same.

Link to comment
Share on other sites

I'm still having rendering problems with small road pieces.

In one map I made it was both the small 2 lane road and small 1 lane (brick/historical) that no matter what I did those pieces come out nearly black and with fuzzie black edges.

I have tried rendinging in and out of windows mode, still no change.

The only thing I am doing differently is using a texture from another map. (gp_dm07_landscape)

I'm not placing the pieces in the same area that the landscape was made for, that would be boring. Instead, since this landscape is so freaking huge, I am building in the middle of it, making the city look as though it was built on water. Very cool looking.

In the other instance I used gp_mission_06_landscape. Again, not building in the same places GRIN did. Trying to make the most of what I can drag out of the editor.

The map that is out there right now with these black areas is "Death becomes You". You can get it here if you want to look at it.

So far nothing I do keeps these pieces from blackening, and GRIN, the people who might know how to fix this, is not even responding here anymore.

See my specs below if you are considering my hardware being a problem. It never has before, and I have restaged my machine several times since this started happening. That too did not change anything either.

Any help would be appreciated.

Rav :zorro:

Link to comment
Share on other sites

  • 8 months later...

Dont delete anything yet silly old man. Most likely your just doing something wrong. Draft and Low tend to render dark spots. Try medium 3 passes. Also keep in mind that not all the pieces listed in the editor have textures loaded for rendering.

This would show up like a checker board either black&white or blue&gold. The textures scope xml can be edited to correct the checker error.

I am getting that very same black and white checkerboard effeft on some props. What do you have to edit in the xml file to fix this? Is there a certain line of code that needs adding or changing, and if so how can I find them for future problem fixing?

Link to comment
Share on other sites

  • 4 weeks later...

I''m having a related problem - the editor keeps telling me I am out of memory to do a render of a big map (remake of Guardrail IX). I already dumped everything off the map I don't need, but I still can't get it to go beyond low textures. Everything I try at medium fails.

I am running the editor full screen, lowest graphics setting possible. It takes about 510mb to run when it loads this map, while my box has 3GB installed with a 768Mb 8800GTX card. Whenever I try to export at medium texture quality, I get errors like this:


Wed Jan 02 00:35:05 2008



Crash in application version: grpcrc1.35


Out of memory allocating 141732240 bytes


SCRIPT STACK


	data\lib\managers\scriptlightmapmanager.dsf(0)

	data\lib\managers\scriptlightmapmanager.dsf(0)

	data\lib\managers\scriptlightmapmanager.dsf(0)

	data\lib\utils\dev\tools\editor.dsf(0)

	data\lib\utils\dev\editor\worldeditor.dsf(0)

	data\lib\utils\dev\toolbox.dsf(0)

	data\lib\setups\setup.dsf(0)

	data\levels\editor\editor.dsf(0)



what is even more bizzare is that yesterday it actually did start exporting at the very same settings, ut since it said 13 hours to go I had to abort the export at about 20% - needed the computer for something else. Now, a day later, I cannot get the editor to begin the export of fresh lightmaps at medium quality. The only texture set loaded is the historical set.

The OS is stripped down - 172mb used at idle. I killed every app that may be taking up memory that isn't needed.

Does the export in a window work better than full screen?

When I render it in low quality there's no problem - just that everything looks too fuzzy and that there are a few dark areas in town.

I deleted a few hundred props and statics from the original map as well, just to minimize the amout of RAM needed, but none of that does seem to help. Am I missing something here? How could these maps be rendered in the first place?

Link to comment
Share on other sites

hi

to minimice the ram usage:

1. all settings on low

2. window mode

3. if still haveing problems u can open the world.xml and cut out all the cover (dynamiks)

couse they have their own lightmaps and dont need to be rendert.

i had a cooperation with ratte and biber, and that map couldnt be rendert in medium, also the mem thingi.

if the map is to frecking big than u just can do a low render, but then a 5 pass ;)

Link to comment
Share on other sites

hi

to minimice the ram usage:

1. all settings on low

2. window mode

3. if still haveing problems u can open the world.xml and cut out all the cover (dynamiks)

couse they have their own lightmaps and dont need to be rendert.

i had a cooperation with ratte and biber, and that map couldnt be rendert in medium, also the mem thingi.

if the map is to frecking big than u just can do a low render, but then a 5 pass ;)

I'll try window mode, as everything else was already in place. Deleted all cars from the map (over 50) and have not added anything yet. Just testing if I can render before I spend more time on it.

I have twice the memory available the thing is complaining about, so I really hope to do medium in windowed mode. The low 5-pass leaves black areas littered all over the map and doesn't look good enough on all the far drawing disance sections of this map.

I made changes to some of the statics on the map, so I can't just steal the lightmaps of mission 01 and just run with those, however, I may need to do that if nothing else pans out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...