Jump to content

Crashing during export... anyone know what this script stack refers to


-Corax-
 Share

Recommended Posts

Anyone know what I've done wrong... why won't this map export? Here's the error message...

Crash in application version: grpcrc1.35

Out of memory allocating 94488160 bytes

SCRIPT STACK

data\lib\managers\scriptlightmapmanager.dsf(0)

data\lib\managers\scriptlightmapmanager.dsf(0)

data\lib\managers\scriptlightmapmanager.dsf(0)

data\lib\utils\dev\tools\editor.dsf(0)

data\lib\utils\dev\editor\worldeditor.dsf(0)

data\lib\utils\dev\toolbox.dsf(0)

data\lib\setups\setup.dsf(0)

data\levels\editor\editor.dsf(0)

Link to comment
Share on other sites

The problem is that while you are compiling the map, you are doing it at too high of a setting on your computer. A way to be able to up the number of passes/quality of passes would be to turn all your video options to as low as they go, along with resolution, exit the editor, start the editor back up with the low settings from the start, and re-compile the map.

Medium/5 pass works rather well for making the map look polished.

Edited by Nutlink
Link to comment
Share on other sites

There could be 2 problems:

1: do you have too many map folders in your work folder? if so only keep the one you are currently working on.

2: your far clipping plan is up to high, its found on your menu screen just above new, load,save and export. set it to 600,000 you should be go then,

if none of the work then I have no idea but I hope this helps you out.

Ministry-ASN

Link to comment
Share on other sites

:D Makes sense...

Those are all very helpful hints... Thanks.

I was able to render them out on draft and low... but it looked like poop.

New map soon if all goes well..

**UPDATE: Saturday, January 12, 2007

Turning all the video settings & resolution to low, did the trick... Thanks. I also upped my HD swap space...

Original ETA was approx. 12hrs

3hrs to go...

>> Just one question... does anyone have a way to actually utilize multi-threading when rendering out lightmaps?

Edited by -Corax-
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Orr maybe you just had my problem...NOT ENOUGH FREAKIN RAM! Lol

Im running 512, and ive managed to squeak by.

I have the same problem and this is my machine...

AeroCube- AeroCool Negra

Foxconn G9657MA-8KS2H

Core 2 Duo E6600

2 GB 800MHz

SeaSonic M12-600 600W 80Plus RoHS Modular

XFX GF8800GTX & Asus PhysX P1 Graw Edition

NEC AD-7173A

2xSeagate ST3320620AS

Zboard MERC & Logitech G5

Logitech Z-5400

I only can export in Low 5 pass

Any idea?

Edited by SuperCurro
Link to comment
Share on other sites

As stated before, try doing the following:

1. Load up the map editor.

2. In the options menu, lower the settings of all graphical options as low as possible, including resolution.

3. Exit map editor.

4. Reload map editor.

5. Compile!

I run 2 gigs of OCZ PC3200, so you should be fine on your RAM. Hope this helped.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...