Jump to content

OK, not quite given up...M4 in progress


SnowFella
 Share

Recommended Posts

Desided yesterday to see how hard it could be to get one of my models ingame and working.

After a few headaches with placement, forgetting to reset XForm, the model finally ended up in the right place and I have a fair idea about how to get the aimpoint aligned properly. But as will be aparent in the below screencap I've got some texture issues that keep persisting.

problem3.jpg

Just about see through M4 CQBR, look closely and you can spot the barrel...seems to only appear where there's lighting highlights. :wall:

Intended to be this model without attachments.

Thrown everything I can think of at it to no avail and as my GR:AW plain refuses to run for more than a few minutes without a CTD or lockup I'm calling it quits. :wall:

Link to comment
Share on other sites

  • Replies 325
  • Created
  • Last Reply

Top Posters In This Topic

or it could be the first time you try and get something into GRAW and thus run into the most obvious snags:)

would be more than happy to help out if you need it

if you are having that many problems with running it is more than likely something on your side that isnt set up right than the actual game, could you perhaps be running a bad version of the 1.3 patch?

post your model details and materials xmls and im sure ill be able to spot the error, its very likely something very simple you have overlooked!:) its easy to do that before you get used to the process!:)

Link to comment
Share on other sites

I had the ctd problems even before the patch but I could always try downloading and installing it again. Main problem testing vise I have right now is that I cleaned out my GR:AW installation totally last night and reinstalled again this morning, ofcource this whiped my savefiles so I'm now stuck back at the first mission = no equippment selection :wall:

Materials.xml is pretty straightforward.

<materials>
<material name="cqbr" src="skinned_bump_uv2_cube">
<diffuse_texture file="cqbr_df"/>
<bump_normal_texture file="cqbr_bm"/>
</material>

<material name="cqbr_nocube" src="skinned_bump">
<diffuse_texture file="cqbr_df"/>
<bump_normal_texture file="cqbr_bm"/>
</material>

<material name="cqbr_noskin" src="bump_cube_instanced">
<diffuse_texture file="cqbr_df"/>
<bump_normal_texture file="cqbr_bm"/>
</material>

<material name="casings" src="bump_cube_instanced">
<diffuse_texture file="casings_df"/>
<bump_normal_texture file="casings_bm"/>
</material>
</materials>[/code]

Here's a screencap of the rig and scematic view that I did yesterday, before having to reset the XForm.

Wire rig + scematic view

Need a cap of the material editor aswell?

Problem is I don't have overly much time to pour into this as I've got some freelance gigs on at the moment that needs finishing ASAP <_<

Edit: changed screenie to link, just that tad big for the forum :lol:

Link to comment
Share on other sites

First of all, your model and texture work looks amazing! Very clean. :thumbsup:

Second. Try this. Add a skin modifier to the loda mesh. Then select the skin_root dummy and add that to the skin modifier using the "add" button. I have no idea what the hell this does because I'm not a max user, however, when I did that, it seemed to work. Before adding that, I was getting what looked like all the points shooting to the origin, and hence an invisible weapon. I also have no idea why this worked.

Your case might be different though. It does look like something is there picking up highlights.

Give it a shot if you have the time, but I feel your pain. I don't mean to sound ungreatful, but the information provided for getting weapons into the game is very sparse. Most of what was provided in the tutorial was already known. Examining the sample files has been the most helpful, but still a bit of guess work involved. When it comes to lining up the sights, the answer I was given was: it's in the animation. Oh, of course, how simple. Animation of the weapons? Animation of the characters? combo? joint setup? what gets exported? all joints, entire character, what? How can I line it up myself. I realize it might be a complex process, but if so, please don't make it sound so simple. Ok, rant off. Sorry...got sidetracked :blush:

Also, I think EricJ or Jason FMX has a simple mod which will let you select equipment for mitchell in the first mission. Download that if you just wnat to mod and not go through the first mission, though, you'll still have to jump out of the plane.

Link to comment
Share on other sites

I've already got the skin modifier all set just like in the scar_l example file and got animations done for the bolt, bolt release, safety switch and trigger ;)

The model is most definately there but invisible, probably due to some alpha problem as I can see it's outline from 1st person as a clear area when walking through dustclouds.

Before I whiped the GR:AW installation and lost my ability to get to the equipment screen whenever I selected the CQBR I ended up with a dark seethrough "outline" of the weapon.

What I'm thinking about when it comes to the scope alignment is to simply put a spacer in instead of moving the scope_align dummy down till it sits perfectly on the reciever. If the scope dummy keeps its original hight above the center point (original hight as in the distance between them in the scarl example file) aiming ought to be working.

Think something along the lines of this mounted ontop of the recievers rail.

Picatinny%20Riser%20detail.jpg

This ofcource doesn't solve the problems with standard ironsights but might mean I can use both the aimpoint and eotech already in the game.

Oh well, in the meantime I'm going back to texturing my M14 DMR model....it looks kinda funky with only one texturepass done :rofl:

DMR - No texture

DMR - Pass 1 on the texture

Link to comment
Share on other sites

What I'm thinking about when it comes to the scope alignment is to simply put a spacer in instead of moving the scope_align dummy down till it sits perfectly on the reciever. If the scope dummy keeps its original hight above the center point (original hight as in the distance between them in the scarl example file) aiming ought to be working.

I thought about that too, and it should work. But it just seems like a workaround. I'd like to do it correctly via the character files if possible. But if it looks fine, you may as well do what works.

Your problem does seem file related or something. Like it's not picking up your texture. There are soooo many xmls pointing to dirs and defining things, it could easily be a typo somewhere. Could be an alpha channel problem in the texture file too. How many extra channels to you have. Just 1, or more. Maybe another one is used for transparency.

Do you hand paint all of your textures? Man, they look great. Have any good tutorials, or links to good ones?

Link to comment
Share on other sites

It would be different if I aimed to add ironsights to the model but as this is only a test I ought to be able to use the workaround for the sight alignment.

Currently I've got the standard colour layer and an alpha layer in my *_df.dds texture, identical to the way the SCAR's are set up ingame. I also have a plain coloured *bf_.dds file as bump, that might be the source of the problem but removing it fully seems to do nothing. :huh:

As for texture creation, most of my stuff is heavily edited photosources as I more or less suck at painting by hand..the DMR I'm working on now is 99% handpainted though as I can't find good enough reference.

Link to comment
Share on other sites

It's quite possible that I've screwed something up in the assignment of different materials or their naming.

Lets see now...I've got 3 materials in 3dsm, all 3 pointing at the same texturemap.

Material 1: cqbr...used on all animated parts of the loda mesh. IE: bolt, trigger, safety switch and boltrelease

Material 2: cqbr_noskin...used on all non animated parts of the loda mesh. IE: all of the rest

Material 3: cqbr_nocube...used on lodb and lodc meshes.

Looking at the example scarl file that means I've screwed up and swapped the *_noskin and *_nocube the wrong way around. <_<

Link to comment
Share on other sites

:huh::oops:

Would of been easier if you would of got the GRIN boys to translate said tutorial into their native language...I am a swede after all :P

In my defence though...fixing the texture assignment issue fixed the problem of a see through M4 CQBR...but brought back another problem. Here's what it looks like in the equippment screen after the changes.

problem4.jpg

To me a clear indication there's something seriously wrong with either my textures, texture paths or material.xml file. Or could it be me once again not Reading TFM and not doing the atlas texture bit? 0:)

Link to comment
Share on other sites

Quite probably...lol

I'm having no luck with creating and atlas set at the moment though, could be because it's nearly 11pm, I've had a few drinks and have been up since 5:30am this morning.

I'll have another go at it in the morning after coming home from work though. At the moment the correct way of setting things up for creation seems to be way out of my league...after all I did flunk programming at Uni :rofl:

Link to comment
Share on other sites

Well from the screen that you have a "SCAR" as what Brettzies is doing as a "base" which doesn't help with texes. However, you see that only in the inventory screen and the above shows? No textures? You are saving it as DXT5 right? Maybe perhaps extracting one of the textures in the quick.bundle and reverse engineering?

Link to comment
Share on other sites

YAY Snowfella!

Looks beautiful, I hope you get this in game as I look forward to as many sweet GRAW mods as there were [GR] mods!

Afraid I can't help much, haven't done much at all with textures for GRAW, if you need help with the equipment files though I would be happy to lend a hand.

Clark

Link to comment
Share on other sites

@Eric: Reverse engineering is what I've done sofar, what I haven't done though is create an atlas file that will tell the game where to look for the textures. Plain and simple an oversight from my side as I've just started feddling with this and didn't really know it was needed.

@Lancer: I was never really gone mate...just taking a break modding for GR games :P

@Procaz: :whistle:

@Wille: Main problem I'd say would of been the 4 or 5 beers and 2 shots of vodka-redbull I had in my system last night...combined with a serious lack of sleep :rofl:

I'll dig into it again now though as I'm sober and fairly well rested.

Link to comment
Share on other sites

Alright...I'm ready to toss in the towel here again and can modding GR:AW even before I've really got going. :wall: Nomatter what I try I just can't get the F*ing thing to create and atlas set properly.

VBS1 work here I come :bye:

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...