Jump to content

The AI Mexs dont run.... Help!


Ministry
 Share

Recommended Posts

Ministry here,

For the passed few weeks, I have been teamed up w/ Jasonfmx, Ducky and Aussiereg, we've been all working on our own maps but w/in a group effort on teamspeak. Ducky has released his ( hope you guys enjoyed it) and Jason and I are still currently working.

My Map "No Way Out" is 90% done(script and all )and I would like to share it to the community by Friday. It's a 2 level mission map meaning there is a fight on a surface level, a fight in the sub level and plus an objective to complete. Lots of surprises installed "BUT" I got one problem. The Mexs troops on the surface level do not patrol or chase they just crouch and shot. All troops on the map spawn on que. The troops on the sub-level patrol and chase you down; but the troops on the sub-level spawn then crouch and shot. What's the problem here?

I set my AI graph node all over the 2 levels make a web-like design. MY question is :

1. Are limited to the number of AI enemies and vehicles to be use on a map?

2. (MOST IMPORTANT) How can I make the troops on the top level do their part? ( The snipers who are much higher have no problems shooting and looking for me down.

3. Is there a corelation to assigning the movement of the troops to the type of troops you choose?

4. How do you fix the Blackhawk sound error when it comes it at the extraction point?

I really like this map and I know the Community would like it too; so I am asking for some help. I know it is possible because I had it working for a day and of course it was by an accidential find but due to minor fixs on props and vehicles; I lost it(stupid of me). I looked backed at all the world xml file and could not it find the file so

So if anyone has the answer please tell me... HINT, HINT Grin Guys....I would be thankful... I would like to fix it by Thurs night and ship it out you the community.

Minstry

Link to comment
Share on other sites

Yeah, I'm working on my second map now... worked really hard to set it all up and when I went to run it I found three major bugs.

1. I can randomly just fall right through the ground... and no i didnt leave a 5mX5m space open. I just fall right through the ground mid mission

2. I get a crash that says "smovelogics" isnt right on line (-1) , then the scriptstack says a AI hive brain error. I know that usually means a AI graph node problem right ?? but I cant find anything wrong wtith the graph. And its completely random... i could play for 1 minute or 10 minutes before it does it.

3. theres this one section of shanties where the AI can completely see me and shoot me right through them like they werent even there but I cant see or shoot them through it.

we're trying to figure this... ministry's problem also has us completely boggled.

my last map had a few minor hangups that i could never figure out but it was playable so I released it (hall of mirros, I named it that becuase when looking at it from above its made of the same 4 corners and looks like a reflection of a mirror)

1. problem one was the obs barrier walls when viewed out of the clip range had blue and yellow stripes on them.. but when you get closer they filled in with proper colors... its extremely minor and sometimes hard to notice but still there.

2. the mini map is all dark, when i try to do a 3 pass medium all browns turn to purple in the game and the ground and walls are completely black (without color or light) . so I was stuck with doing a multiple pass draft version... which didnt turn out bad at all but i would of rathered the medium or high version.

I guess we're at the mercy of grin here to give us a hint if they so wish to help beucase i doubt anyone from the community as acquired enough knowledge and experience enough to help us out. (hopefully I'm wrong). I honestly dont get how the average person is suppose to use thie editor. None of us are stupid, we've figured out alot about this game entirely on our own yet we are totally boggled at this. there just seems to be no consistant reason for all the problems we've had and been having ( yes theres a whole bucket load more on top of the ones listed already in this post... these are just the more major ones, or ones we haven't fixed on our own yet)

Link to comment
Share on other sites

2. I get a crash that says "smovelogics" isnt right on line (-1) , then the scriptstack says a AI hive brain error. I know that usually means a AI graph node problem right ?? but I cant find anything wrong wtith the graph. And its completely random... i could play for 1 minute or 10 minutes before it does it.

This graph is a main graph, that the level on export makes a whole network of smaller graphs out of every object in the game, which the ai navigates through. The game will crash if enemies are placed and can not find a graph.

Allthough a little confusing, you will on larger levels need the vehicle graph even if you do not have any vehicles in the mission.

This graph is used by human AI on distance, and the game will crash if they do not find it.

Im more pointing out the part about vehicle graph since you stated that it is random so i assume all AI are placed in the AI graph. Note vehicle graph is needed on large maps even if you dont have vehicles. Just a thought.

Link to comment
Share on other sites

postal, i dont have any vehicles in this level at this current time so thats not doing it. and as far as having the AI graph... i have it spiderwebbed all over the map, theres plenty of paths for the AI to choose from.... and the all connect, there are no loose nodes or dead ends.

ive made a functioning map i released obviously (hall of mirrors) plus countless test maps and never once have i had this problem. I have NO clue whats wrong

Link to comment
Share on other sites

postal, i dont have any vehicles in this level at this current time so thats not doing it. and as far as having the AI graph... i have it spiderwebbed all over the map, theres plenty of paths for the AI to choose from.... and the all connect, there are no loose nodes or dead ends.

ive made a functioning map i released obviously (hall of mirrors) plus countless test maps and never once have i had this problem. I have NO clue whats wrong

Wow...lol...your welcome for trying to help...LMAO

Now...re read what i put and you will see ..."Allthough a little confusing, you will on larger levels need the vehicle graph even if you do not have any vehicles in the mission."

But i can can see the mentality you take...so keep up the good work... :thumbsup:

Link to comment
Share on other sites

postal, i dont have any vehicles in this level at this current time so thats not doing it. and as far as having the AI graph... i have it spiderwebbed all over the map, theres plenty of paths for the AI to choose from.... and the all connect, there are no loose nodes or dead ends.

ive made a functioning map i released obviously (hall of mirrors) plus countless test maps and never once have i had this problem. I have NO clue whats wrong

Wow...lol...your welcome for trying to help...LMAO

Now...re read what i put and you will see ..."Allthough a little confusing, you will on larger levels need the vehicle graph even if you do not have any vehicles in the mission."

But i can can see the mentality you take...so keep up the good work... :thumbsup:

umm.. what i wrote was not rude at all... being a bit over sensitive ?

sorry i didnt see that part. my only excuse is i was in a rush to get out the door earlier today and i was reading your post as i had someone "hey come on we gotta go "

and yes i do appreciate your help..

now whats this comment at the end of your post ? looks like your the one being rude. I made literary mistake, yes i admit that, im sorry.

duck, yeah ill get on here in a bit... no one has any help for ministry ??

Link to comment
Share on other sites

aaah, forget about it, i already have

anyway... we're gonna get a joint effort going to TRY and fix ministry's game.

duck figured my problem out... get this in the ghetto scene there are statics that are errored. it was causing me to just drop through the floor and that wasnt limited ot the AI.. when they fell through the ground it errored. the errored statics to the AI werent even there, but to us they were.

so... watch out for that kinda stuff when your map making.

thanks to duck for fixing that headache for me and apologies to ministry for hijacking his thread... hopefully we get it fixed and its forgotten.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...