Jump to content

GRAW-OGR Coop Map error


Gator-WOF
 Share

Recommended Posts

Hi all,

Like everyone else, I'm already tired of the original 3 maps and decided to start some work on new ones. I'm able to follow the tutorial (included with GRAW) as best as I can, and the map exports fine, but I get the following error when I try to launch my map in-game:

data\lib\script_network\gametype\gametypempcoop.dsf(-1): GametypeMPCoop: init_zones: No objective zone detected for mymission!

SCRIPT STACK

data\lib\script_network\gametype\gametypempcoop.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\levels\mymission\mymission.dsf(0)

however, I did create the necessary 2 zones (base 1 and base 2) as you can see from my zones.xml file:

<zones>

<zone name="alpha" base="1">

<rect corner1="24400 -12000 0" corner2="21500 -14900 0"/>

</zone>

<zone name="bravo" base="2">

<rect corner1="-28500 21800 0" corner2="-22700 24100 0"/>

</zone>

</zones>

Now I know that the tutorial is a little weak and that others are probably coming out with new supplemental material, but I was wondering if there was something simple that I am missing?

Thanks for any help you can offer!

-Gator

Link to comment
Share on other sites

do you have xfire?

nope - never installed it - but I can. msn only, I'm afraid.

Here zip it up, the "your mission" folder in the work folder, and email it to me. I PMed ya my Email. Ill have to take a look at it for ya if you want me to help. That sounds alittle weird cause you do have your zones. So do that, and I can take a look at it, and if I can get it for ya, ill email ya back and explain what was wrong.

-Ducky-

Link to comment
Share on other sites

Evilducky:

Thanks for the offer, but I just got it running. In my experimentation, I messed up the subfolders in my custom_levels folder. Works fine, although the minimap is black. More work for me to do still.

BTW: I picked up your BHD map yesterday. Looking forward to trying it with my team later this week perhaps.

Link to comment
Share on other sites

Sweet congrats. I got the same error today making my second map. Found out that it was the bases were outside the map size area and it was causing that. But good luck on your map and hope you enjoy mine. If you need any other help shoot my way. Ill try and help ya.

-Ducky-

That makes perfect sense ... These were the lines i had to add to my zones.xml file ...

<borders tl="-10000 10000 5000" br="10000 -10000 5000"/>

<center pos="0 0 80000"/>

Any idea at what time during the editing process this get's written to the zones file or why it wouldn't be there correctly?

Edited by Gator-WOF
Link to comment
Share on other sites

Here's a question:

Just for kicks, I just unbundled one of the built-in missions (mission02) and noticed that it doesn't have a zones.xml file ... None of the "missions" do. It only appears in the [GR] Coop missions and some of the other MP types.

Edited by Gator-WOF
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...