Jump to content
Ghost Recon.net Forums

Recommended Posts

I got that same script error about it not being found.

Then I had to re-install the whole game to get it to start... <_<

Maybe I did something wrong, I dunno. But I think I'll stick to manually putting my mods in there. I just have to move the local folder anyway, seeing as I didn't have it before...

Link to post
Share on other sites

I believe that the problems that people are running into are due to the fact that the base and exec attributes of the script tag are left blank in the context.xml file that you provided. Not sure why they're blank, as it works fine with my copy. I'm running it on Vista as well and the game is installed in a non-default location, no problems at all.

Try entering the following values into the ModLauncher's options screen and exiting the application to ensure that it writes the changes to the file, then verify that the values were written to the context.xml file.

Base: data

Exec: menu/menu

Link to post
Share on other sites

Wouldnt it just be easier to get the install location from the users registry? That way your application will support custom installs and will remove some of the crashes. Also try to do some error trapping in your coding and give meaningfull error messages.

Link to post
Share on other sites

wow...now i tried it again and i get another error:

Crash in application version: grpcrc1.02

Script: not found!

here my context.xml:

<?xml version="1.0" encoding="utf-8"?>

<context xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<script base="" exec="" editor="false" language="SCAR_Mod" />

<layer_config file="\data\settings\layers.xml" />

<scene_config file="\data\settings\scenes.xml" />

<unit_database file="\data\units.xml" />

<sound settings="/data/sound/settings.xml" />

<network settings="/data/settings/network.xml" />

<static_texture_scope file="\data\settings\static_texture_scope.xml" />

<skeleton_def file="\data\objects\def.xml" />

<animations def="\data\anims\anims.xml" state_machine="\data\anims\state_machines.xml" />

<texture base="\data\textures" />

<effects file="\data\effects\effects.xml" />

<decals file="\data\effects\decals\decals.xml" />

<default_shader_config file="\data\shader\default_shader_config.xml" />

<default_render_templates file="\data\shader\default_render_templates.xml" />

<physics settings="\data\settings\physics_settings.xml" fps="60" novodex="hardware" />

<global_materials file="\data\settings\materials.xml" />

<gui file="\data\gui" optimized="true" />

<camera shakes="\data\settings\camera_effects.xml" cameras="\data\settings\camera_settings.xml" />

<bundler make_logs="false" />

<nls_lookup size="64" />

<installer use="false" />

<calc_video_mem_adjust value="false" />

<compile xml="true" scripts="true" mopps="true" texture_db="true" />


and my appconfig.xml:

<?xml version="1.0" encoding="utf-8"?>

<AppConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<GamePath>D:\Spiele\Ghost Recon Advanced Warfighter\</GamePath>



i tried it with compilexml-false but this doesnt work, too :-(

thanks for looking

Your context.xml file has been altered from the original.

NONE of the values in the compile section should be true, be default they should all be false.

As well, ...script base="" exec=""... that section looks like it's been messed with as well. Should read base="data" and exec="menu/menu"

It almost looks like you went into the settings menu of the mod launcher and messed with all the settings in there.

Link to post
Share on other sites

I have added some error trapping, this is what causes the dialog box to pop up and notify you that the game isn't installed in the default location, and that you should go into Options > Settings to select the game path. If someone feels the need to change the default installation location, they should be able to select the game path that they've installed to.

I would go and search the registry, and I may just do that, but I can't right now with my time constraints. Today is day 2 of 6 at work, so after that I will put some more work into the application.

I'll also look at adding in a restore to default button.

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...