Jump to content
Ghost Recon.net Forums

Recommended Posts

Alright, I'm releasing this a little sooner than I had originally intended. I would have liked to have added a few more options, such as the ability to disable intro movies and what not, however that requires that the bundle file be unpacked, and I'm in need of some sleep.

So here it is, ready for download. Basically enables you to run GRAW with any mod that is stored within its own folder under the 'Local' folder. There is a catch however, in order for the mod to be recognized, a small XML file must be placed within the mod folder. Its a simple file that takes two seconds to put together. The application also enables you to customize a few more advanced options within the context.xml file.

I'm going to hold off on further development for this project until GRIN comes out with their June patch. If by then they have included, or have announced that they will be releasing, a mod launching utility, then I will cease production completely. If not, then I'll see what else I can add, and polish it up a bit to make it more presentable.

Download Link

Note: Please feel free to distribute throughout the community. No permission from the author is required to host this file. Source code is available upon request.

System Requirements: .NET Runtime Version 2.0

Edited by SierraSeven
Link to post
Share on other sites
  • 2 weeks later...

just a note to those releasing mods. If you'll use the mod launcher system, and rename the "language" folder in \local to your mod name

\local\grawcommunitypack\

then it'll be much easier for users to install and use the mods you're making.

Link to post
Share on other sites

Hi SierraSven....

i've got a little bit trouble with your mod launcher...i get this error message

"Crash in application version: grpcrc1.10

c:\Code\Engine\dieselx\source\utility\Archive.cpp(1745)Cannot open d:\spiele\ghost recon advanced warfighter\data\gui\cross_com_zoomed_hud.xml.bin"

what is this path? (c:\Code\Engine\dieselx\source\utility\Archive.cpp(1745))

i've put the GRAW Mod Launcher.exe in the local dir. in my local folder i created some subdirectory like local\bloodmod or local\greencamo

then i've put the modinfo.xml in each directory end edited it (description and name)

what did i wrong? would you please help me out?

Link to post
Share on other sites

Have heard of problems from people who have the game installed to something other than the default directory. If you have it installed to a different folder/drive, then after launching the mod launcher the first time it should create a file called appconfig.xml in your GRAW root folder.

Edit that file, look for a setting called GamePath and change that to whatever you installed the game to. Should help some people out.

As well to pestbeule, the file "Graw Mod Launcher.exe" should be in your GRAW root folder, not the local folder. So far as I can tell the program LOOKS for a local folder and any subfolders within that, so if you've already got the program in your local folder, then that might be causing your problems.

Link to post
Share on other sites

I had the same problem, but only with other mods in the local folder (and not all mods...I just haven't figured out what exactly it was. I've got numerous private projects I'm working on, so it could've been any of those as well). Once I removed the local folder, ran the game once, then made the folder again and put a few mods back in, it seemed to do just fine. Mind you I haven't put them all back yet.

just an observation.

Link to post
Share on other sites

It sounds like the game path has been specified as being blank in the options window. Make sure that in the options window you specify the game path. When you first start the application for the first time, there is no configuration file for the mod launcher, and therefore it should assume the default installation path for GRAW.

Try specifying the game path in the options window, clicking apply, and then restarting the application. Let me know if it still poses a problem.

With regards to the multiple mods in the local folder... it should work fine as long as you have one mod per folder within the local folder. If you could provide me with more information as to the directory structure of your local folder, as well as the information provided to you when the mod launcher crashes, it'd help me immensely in tracking down the problem.

Edited by SierraSeven
Link to post
Share on other sites

hi...

@tedSmith: when i'm back home i'll try to install GRAW in the default directory. i also tried to launch the mod launcher from the GR root directory. the path in the appconfig.xml is all right...

@DonMiguel: maybe i wanted too much with my three mods in the local directory (each in another subdir) ... i'll try to check it one-by-one...i hope it will solve the prob. But the mods work if i put them in the local dir. it looks like a prob of the launcher.

and whats:

Crash in application version: grpcrc1.10

c:\Code\Engine\dieselx\source\utility\Archive.cpp(1745)Cannot open d:\spiele\ghost recon advanced warfighter\data\gui\cross_com_zoomed_hud.xml.bin

both files and paths did not exist...

@sierraSeven: the game path in the options window is correct. i only wondered why the is "language: bloodmod"...makes no sens to me...

my dir structure:

local/bloodmod

local/greencamo

and so on

modinfo.xml are in the subfolders...

thanks for your reply

pestbeule

Link to post
Share on other sites

Still wondering how I should go about all this, seeing as I don't even have a folder with the name "local"...?

The local folder method is fast becoming the standard method for installing mods. It's much easier and promotes faster loading times than the old method of extracting the full quick.bundle file and renaming it.

Any mods you install should create a local folder within your GRAW root folder, and then another folder inside local named to whatever the mod is if they were initially set up to support the mod launcher. This launcher actually requires that the mod maker set up their mod to support it and if that hasn't been done it will cause you problems. Of course you can fix mods that haven't been set up for it yourself by renaming the subfolder that the mod installed to and adding a modinfo.xml file (there's an example included with the mod launcher package.

To pestbeule:

The reason it says language bloodmod is because of the way modders are setting up their mods to function. It's a bit of a dirty hack, but it works. The game essentially has a localization function built into it, so when it loads up, it searches a local folder for a subfolder named after the language it was installed in. Thus if you installed it and chose english, when the game loads, by default it looks for a "..\Ghost Recon Advanced Warfighter\Local\English" folder to see if there are any files it needs to load that aren't stored within the bundle file. (I presume it's looking for alternate language voice overs and strings.) What the mod launcher does is change the language to match the folder a mod is installed to so that the game will look within -that- subfolder (..\Ghost Recon Advanced Warfighter\Local\Bloodmod in this case) instead of the language you initially installed to.

I'm not sure myself if this system messes with the language in-game for anyone that installed the game as something other than english, but for the time being it's the easiest and most efficient way we've got.

Link to post
Share on other sites

dunno if it will help, but this error:

Crash in application version: grpcrc1.10

c:\Code\Engine\dieselx\source\utility\Archive.cpp(1745)Cannot open d:\spiele\ghost recon advanced warfighter\data\gui\cross_com_zoomed_hud.xml.bin

seems to be related to the "compile xml" parameter set to true in the context.xml

Link to post
Share on other sites

dunno if it will help, but this error:

Crash in application version: grpcrc1.10

c:\Code\Engine\dieselx\source\utility\Archive.cpp(1745)Cannot open d:\spiele\ghost recon advanced warfighter\data\gui\cross_com_zoomed_hud.xml.bin

seems to be related to the "compile xml" parameter set to true in the context.xml

Thanks for the info on the crash. I'll try and have a look at whats going wrong. Could you possible provide me with your context.xml file so that I can ensure that it is being written properly by the mod launcher? Thank you.

And thanks above for explaining why the language is set to the name of the selected mod.

Link to post
Share on other sites

wow...now i tried it again and i get another error:

Crash in application version: grpcrc1.02

Script: not found!

here my context.xml:

<?xml version="1.0" encoding="utf-8"?>

<context xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<script base="" exec="" editor="false" language="SCAR_Mod" />

<layer_config file="\data\settings\layers.xml" />

<scene_config file="\data\settings\scenes.xml" />

<unit_database file="\data\units.xml" />

<sound settings="/data/sound/settings.xml" />

<network settings="/data/settings/network.xml" />

<static_texture_scope file="\data\settings\static_texture_scope.xml" />

<skeleton_def file="\data\objects\def.xml" />

<animations def="\data\anims\anims.xml" state_machine="\data\anims\state_machines.xml" />

<texture base="\data\textures" />

<effects file="\data\effects\effects.xml" />

<decals file="\data\effects\decals\decals.xml" />

<default_shader_config file="\data\shader\default_shader_config.xml" />

<default_render_templates file="\data\shader\default_render_templates.xml" />

<physics settings="\data\settings\physics_settings.xml" fps="60" novodex="hardware" />

<global_materials file="\data\settings\materials.xml" />

<gui file="\data\gui" optimized="true" />

<camera shakes="\data\settings\camera_effects.xml" cameras="\data\settings\camera_settings.xml" />

<bundler make_logs="false" />

<nls_lookup size="64" />

<installer use="false" />

<calc_video_mem_adjust value="false" />

<compile xml="true" scripts="true" mopps="true" texture_db="true" />

</context>

and my appconfig.xml:

<?xml version="1.0" encoding="utf-8"?>

<AppConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<GamePath>D:\Spiele\Ghost Recon Advanced Warfighter\</GamePath>

</AppConfig>

@DiGiTALY -TC-:

i tried it with compilexml-false but this doesnt work, too :-(

thanks for looking

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...