Jump to content

Cross-Com commands + Mouse wheel


Recommended Posts

solution to the problem:

In the Ghost Recon Advanced Warfighter\Settings\ctrl_set_def.xml

1.06:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

1.10:

<button id="hud_select" binding="2" device="mouse" group="misc"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

As you see, they changed the group from interface to misc. If you change the line in the 1.10 patch file to this:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I hope this work for you as it did for me.

Link to comment
Share on other sites

  • Replies 51
  • Created
  • Last Reply

Top Posters In This Topic

So i reinstalled patch 2 again to try the tip above and guess what...things worked ok right after the install, without changing anything :blink:

The hud_select/up/down/ actions now are grouped in the misc tab in the controls screen, where they weren't when i first installed the patch.

I have no idea how and why things are working now, but finally i can go on playing :thumbsup:

:o=

Link to comment
Share on other sites

In additon to fixing the ..\Settings\ctrl_set_def.xml file to set group="interface" instead of group="misc"

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I found that I had to double check my ..\Settings\profiles\graw_profile_default\profile.xml

and make sure it was synced with the ctrl_set_def.xml file.

When I check my profile.xml it was set as :

<button id="hud_select" binding="j" device="keyboard"/>

Which was a setting I had tried after Patch 1.10 caused my cross-com to stop working.

As a result any change I made to the ctrl_set_def.xml did not work.

Once I changed the profile.xml file to "match" or sync with my ctrl_set_def.xml file like this:

<button id="hud_select" binding="2" device="mouse"/>

Everything worked perfectly!

So make sure to check both files. FYI

Edited by Fragged
Link to comment
Share on other sites

solution to the problem:

In the Ghost Recon Advanced Warfighter\Settings\ctrl_set_def.xml

1.06:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

1.10:

<button id="hud_select" binding="2" device="mouse" group="misc"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

As you see, they changed the group from interface to misc. If you change the line in the 1.10 patch file to this:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I hope this work for you as it did for me.

:whistle: Thank you! Oh ,Thank you! Finally a solution that works! I looked high and low, for about two weeks, seeeeeeeeking a solution to the mysterious GRAW v1.10 Mouse Interface Problem. Thanks again! Cheers! :thumbsup:

Link to comment
Share on other sites

Same happened to me. My problem came when I reinstalled the game and went straight to the 1.10 patch.

Looks like you have to patch in order...1.06 then 1.10.

Seems like the laser mice are affected. (I have razer copperhead)

Hope this helps.....currently running 1.10 with everything working.

Link to comment
Share on other sites

Hi Guys.

OK. I downloaded and installed the 1.10 retail patch. I have a wheel mouse and was perfectly happy with the original WheelDown/Scroll/WheelDown command of the Team and the Artillery/Apaches/Airstrikes.

Since the 1.10 install, the wheel does not work anymore. Can't command Artilllery to strike the Havoc chopper. How can I get the old command mapping? I tried reset to default and it didn't work. I'm now stuck. Please help!

[Moved to correct forum + Merged into existing thread - Please search before starting a new thread]

Edited by Pave Low
Link to comment
Share on other sites

I've tried everything, nothing works. So I uninstalled, reinstalled and applied patch 1.06. Now the confirm button works again. It's the only solution, i'm afraid, GRIN XXXXXX up big time on the 1.10 patch.

Guys, here's what I did.

I noted that the XML file noted above (profile.xml) had the following section:

<button id="hud_down" binding="mouse wheel down" device="mouse"/>

<button id="hud_select" binding="" device="mouse"/>

<button id="hud_up" binding="mouse wheel up" device="mouse"/>

I noticed that one thing appeared to be missing. Notice the middle line next to binding? It's EMPTY. I then looked at some other files and found that the number 2 was used for the middle mouse button so I put a 2 between the quotes after binding, saved the file and all now works just fine. I push the button and up comes the menu (or hitting a team member number like "1") and I can scroll up or down and then I push the button again and it selects. I suspect that this is the bug.

Link to comment
Share on other sites

I have the logitech Mx1000 or whatever the damn thing is called...I tried mouseware, and setpoint and it screwed everything up. I am now on the default mouse driver and I have the following

Fire = Left Mouse

Run = Right Mouse

XCom = Wheel Button

Sel weps/Xcom menu = wheel

Zoom = Forward Button

Reload = Back Button

The only functionality I cannot get to work is the wheel left/right combo as well as the scroll up/down buttons in front of the mouse wheel.

I posted this in another thread, but will say it again here.

When you have been trying to map buttons, and changing the default, the mouse wheel will not be recognised, you need to reset all buttons to defualt and then map everything EXCEPT the mouse wheel, DO NOT assign anything to the mouse wheel. The try in-game.

This has worked for me and many others.

Link to comment
Share on other sites

My problem is the mouse middle button won't work for the cross-com select function.

My mouse is a Logitech LX7 cordless optical. I've re-installed setpoint, GRAW, and adjusted key script and key bindings to different settings. My setpoint is set with left and right buttons, and all other buttons generic and middle button for the top two.

Its really annoying because I can't call an airstrike in...so I'm stuck with the retardo mouse...

anyone know a fix?

[Post moved to correct thread]

Edited by Pave Low
Link to comment
Share on other sites

I have just re-read this topic, i'm somewhat perplexed, ha. Well there can't be anything wrong with the 1.10 patch and cross-com use, because it works for people in game, it works right with my mouse setup, i have never had a problem with it.

This is how i have my mouse setup in GRAW using logitech g5 laser.

CONTROLS

MISC

CROSS-COM prev mouse down

CROSS-COM use mouse 3

CROSS-COM next mouse up

Job done, click mouse 3, (side button G5 laser) activate cross-com, scroll up, scroll down, issue commands, attack, cover orders, call in airstrike etc.

Link to comment
Share on other sites

no none of those ideas work

-assigning key's

-using a diferent mouse

-profile for the mouse

the big problem is that in single player mission some require airstrike

the air strike do not have a key asihned (unlike your man 1,2,3)

so if there is no menu, there is no airstrike = mission impossible

plus even if i would somehow get to the menui could not enter the selection - just browse

any new ideas i could try (besides reinstallin the game)?

Edited by siiix
Link to comment
Share on other sites

no none of those ideas work

-assigning key's

-using a diferent mouse

-profile for the mouse

the big problem is that in single player mission some require airstrike

the air strike do not have a key asihned (unlike your man 1,2,3)

so if there is no menu, there is no airstrike = mission impossible

plus even if i would somehow get to the menui could not enter the selection - just browse

any new ideas i could try (besides reinstallin the game)?

It's not the answer you want to hear, but I would suggest reinstalling via the steps below ...

1) Back your profile directory which contains your game saves and settings for your profile.

2) Uninstall the game.

3) Delete the entire game directory if there is one there still.

4) Reinstall the game.

5) Apply patch 1.10.

6) Launch the game and setup a fresh game profile, including mapping all of your keys.

7) Quit the game and place the saved games you backed up in your profile directory.

8) Grab the "campaign_last_event" and "campaign_progress" line items from your original profile.xml file editing your new profile.xml file.

End result, if your mouse is not to blame your problem is solved and you've still retained your saved games. I wouldn't pull my hair out over this (if I had hair), and take the 15 minutes or so to uninstall and reinstall the game as I've outlined. I have several basic Logitech mice, a couple no-name mice, and a Logitech G5, all which work fine in game. I can assign the middle mouse button for each to hud_select and they work. Just as well I can assign any given keyboard key to hud_select and it works that way. I control all aspects of the crosscom via the keyboard only, which includes hud_select, and hud_up, and hud_down. I only use my mouse for moving forward, backward, looking around obviously, and comms programs. I for one am happy that the game devs enabled hud_up, and hud_down via patch 1.10, so that one could remap these functions "in-game". It should have been that way to begin with. I feel bad that some have had problems such as yourself, but the change via patch 1.10 needed to be made. There are plenty of keys on the keyboard. For a PC title to force us to use predefined keys without the ability to remap is just not good design in my opinion. Irrespective of how one sets up their keys I think everyone should get behind making any given function in game available to map if possible. It will only serve to help make this game the best it can be for all players.

Edited by Low Profile
Link to comment
Share on other sites

I changed that bit of code and put it on OS implementation and it finally ######ing works. Thanks a lot. Now I have to get my mods working again...haha

Glad the edits worked and you didn't have to take the long route. Just a suggestion now that you've got things working again. Backup any game files prior to editing them. :-) Will make for a quicker fix next time something gets messed up for whatever reason. Edited by Low Profile
Link to comment
Share on other sites

ok i read your post to late

i already :

i made a complete backup of the profiles folder

then i uninstaled and reintaled to 1.00 - i did NOT patch

aftet this i copy paste the "profiles" folder back

started the game, profiles did not show BUT mouse working

then i set up my profile again with the same name

exit the game and over wrote the profiles folder AGAIN

went back my saved games are still a no show, but mouse buttons work

-----------------------

PLUS i open up the file you mention and i see:

<campaign_last_event value="7361766567616d65" />

<campaign_progress value="1602061b0a" />

now you say edit ! but what this dont tell me anything just a bunch of numbers

is there any hope to get my saved games back ?

____________

EDIT:

OK I GOT IT !!

Edited by siiix
Link to comment
Share on other sites

solution to the problem:

In the Ghost Recon Advanced Warfighter\Settings\ctrl_set_def.xml

1.06:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

1.10:

<button id="hud_select" binding="2" device="mouse" group="misc"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

As you see, they changed the group from interface to misc. If you change the line in the 1.10 patch file to this:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I hope this work for you as it did for me.

:whistle: Thank you! Oh ,Thank you! Finally a solution that works! I looked high and low, for about two weeks, seeeeeeeeking a solution to the mysterious GRAW v1.10 Mouse Interface Problem. Thanks again! Cheers! :thumbsup:

I'm a noob to rebinding games, but I tried the above instructions to no avail... I want to confirm, lines 2 & 3 of the correction should point to "misc" ??? My v1.10 was working fine up until yesterday when I upgraded to a Logi G5. That threw it all out of whack because I reloaded v1.10 and it must have opened up this problem. :rofl: Any stability or significant problems if I just reload and stay with v1.06? Lastly, please QC me here...I've tried the rebinding, reloaded the game, updated to v1.10 again, what else can be done? The Cross-Com still won't even take keyboard commands...here's to waiting for a new patch :wall:

Link to comment
Share on other sites

solution to the problem:

In the Ghost Recon Advanced Warfighter\Settings\ctrl_set_def.xml

1.06:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

1.10:

<button id="hud_select" binding="2" device="mouse" group="misc"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

As you see, they changed the group from interface to misc. If you change the line in the 1.10 patch file to this:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I hope this work for you as it did for me.

:whistle: Thank you! Oh ,Thank you! Finally a solution that works! I looked high and low, for about two weeks, seeeeeeeeking a solution to the mysterious GRAW v1.10 Mouse Interface Problem. Thanks again! Cheers! :thumbsup:

I'm a noob to rebinding games, but I tried the above instructions to no avail... I want to confirm, lines 2 & 3 of the correction should point to "misc" ??? My v1.10 was working fine up until yesterday when I upgraded to a Logi G5. That threw it all out of whack because I reloaded v1.10 and it must have opened up this problem. :rofl: Any stability or significant problems if I just reload and stay with v1.06? Lastly, please QC me here...I've tried the rebinding, reloaded the game, updated to v1.10 again, what else can be done? The Cross-Com still won't even take keyboard commands...here's to waiting for a new patch :wall:

Go into your ghost recon advanced warfighter directory, then settings, then profiles, then your profile, and rename the profile.xml file to profile.bak. Remove any .bin files from here and from the Settings directory. Restard the game. Your settings will be reset, but the key keybindings list should be bindable and working properly.

Link to comment
Share on other sites

ok I'm using a MS laser mouse 6000 with wireless keyboard i have two buttons on top, two on th e side and the scroll wheel. I use the mouse button(or did on the left side small long one) for selecting what team, apache,drone or my team and then hit it again to execute the command

Wireless_Laser_Mouse_6000.jpg

Link to comment
Share on other sites

solution to the problem:

In the Ghost Recon Advanced Warfighter\Settings\ctrl_set_def.xml

1.06:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

1.10:

<button id="hud_select" binding="2" device="mouse" group="misc"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

As you see, they changed the group from interface to misc. If you change the line in the 1.10 patch file to this:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I hope this work for you as it did for me.

Thanks for this response, believe it or not on my LASER MX1000 I decided to get the 1.10 patch. I wanted to wait a few days to see how other people liked it. Playing the game this weekend I ran into that exact problem and it freaked me out for hours, because the setup I had b4 worked perfectly.

As anyone tried lfm3 suggestion? Hopefully that will work for me tonight when I try it.

Also any reason as to why they changed this?

Thanks...

Link to comment
Share on other sites

I am still needing help on my MX1000 laser mouse. I uninstalled the game/patches and reinstalled everything, and to no avail it didnt work. I tried setting my mouse setings to default and what another person wrote above.

That didnt work, this is really freaking me out.

So now I am down to trying to open the .bin files another person posted, now how do I open this .bin file so I can edit it:?

solution to the problem:(another person posted this)

In the Ghost Recon Advanced Warfighter\Settings\ctrl_set_def.xml

1.06:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

1.10:

<button id="hud_select" binding="2" device="mouse" group="misc"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

As you see, they changed the group from interface to misc. If you change the line in the 1.10 patch file to this:

<button id="hud_select" binding="2" device="mouse" group="interface"/>

<button id="hud_up" binding="mouse wheel up" device="mouse" group="misc"/>

<button id="hud_down" binding="mouse wheel down" device="mouse" group="misc"/>

I hope this work for you as it did for me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...