Jump to content

Frustrated - Game does not run smooth


Recommended Posts

Hello,

I am trying to figure out if I am just not going to be abl to have smooth gameplay with this game. I have viewed the Minimum Requirements and I exceed those pretty well. I have and AMD643000+ Geforce 6600 256MB PCI Express 2gigs of pc3200 ram a audigy Sounblaster ZS.

I really love this game but it does not run smooth for mr even on low settings in single player, COOP or MP.

It feels sluggish and it is making it so I can not even enjoy the game! Before I purchased this I checked the System Requirements and since I was well above those I assumed I could play the game with a worst worst case Scenarion on low settings.

This is not the case it feels very sluggish and when I try to move it feels laggy.

I run other games like BF2 on Medium and high settings and it runs as smooth as a babies but but this game even on the lowest settings still has the same fgeel of sluggishness.

I am frustrated at this point because I have waited years for this game and I just bought a new PC about a year ago and thought I was in pretty good shape for awhile and every game I buy runs great except for this one.

As I said I love the game and I like playing it but the constant sluggishness is starting to frustrate me. I have tried everytjhing even the new Beta Drivers from Nvidia and I still have the same thing.

Any tips or help would be much appreciated,

DD

Link to comment
Share on other sites

Ive notice the same thing although the game play is pretty smooth and no lag but i notice that the mouse movement is the whole problem its not very smooth i thought it was my FPS for a while untill i realized that it felt like my crooss hair was moving like it was attached to a sponge.

im Running An Intel 3.0 ghz dual Core with 2 gigs DDR2 ATI 1800 you may want to make sure nothing in your bios is turned on that dosnt need to be i had a problem with a few games spiking and it ended up being my onboard sound card was enabled in bios when im running an Audigy 2

so that fixed my problem..

Edited by d0youlikecheese
Link to comment
Share on other sites

Hey mate, you're not alone. Many, many people are reporting the same issues. The general attitude is play around with your settings but mainly, all of us are waiting for the "all important patch" due in June before we upgrade anything.

Good luck,

Fresh

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...