Jump to content
Ghost Recon.net Forums

GRAW Pegging my AMD CPU, Therefore no TS2, Ideas?


Recommended Posts

I have an AMD 64bit 3500 Processor with 2 gig ram and a Geforce 7800 GTX card. I bought the retail version of GRAW last night and had problems when trying to run TeamSpeak 2 at the same time for voice.

I had about 41 processes running in Task Manager but my system was 99% idle before starting the game. After starting the GRAW game my system was using 98-99% CPU the entire time. This basically didn't allow any other processes like TS2 to run correctly I think.

Any ideas? I'd start killing processes but NONE of them were taking up any CPU time so I'm not sure that would help.

Also I noticed that when in the multiplayer screen at times I'd click JOIN on a server and nothing would happen. Anybody else have that problem?

Thanks,

TritonBill

Link to post
Share on other sites

I've had the join button problem, just keep spam clicking it until you join.

With the CPU max out, i assume your using the latest nvidia beta drivers. I've had loads of issues with EAX sound maxing out my PC, try disabling EAX.

Link to post
Share on other sites

No i'd say it's more or less the MP in this game chewing up so much upload bandwidth you are simply losing packets to and from teamspeak.

You get the same effect while trying to use teamspeak while uploading files.

Link to post
Share on other sites

Haven't had this problem yet, but I haven't toyed with MP all<i>that</i> much. I'm also running a similar config (A64, 7800GTX, but onlny 1 GB of RAM).

Of course, if it's bandwidth related, we may be seeing the biggest difference there.

Gotta ask, what type of MP games are you trying? just domination? just coop? do you have problems with both?

Link to post
Share on other sites

ye i got this problem, but i used my head and started teamspeak before i started graw

Also when u couldnt join a server, i think thats cause the host disconnected the server but it still appears in the list.

Edited by pangbang
Link to post
Share on other sites
I have an AMD 64bit 3500 Processor with 2 gig ram and a Geforce 7800 GTX card.   I bought the retail version of GRAW last night and had problems when trying to run TeamSpeak 2 at the same time for voice.

I had about 41 processes running in Task Manager but my system was 99% idle before starting the game.  After starting the GRAW game my system was using 98-99% CPU the entire time.   This basically didn't allow any other processes like TS2 to run correctly I think.

Any ideas?  I'd start killing processes but NONE of them were taking up any CPU time so I'm not sure that would help. 

Also I noticed that when in the multiplayer screen at times I'd click JOIN on a server and nothing would happen.  Anybody else have that problem?

Thanks,

TritonBill

I forgot to mention that I have a Sound Blaster X-FI sound card.

I'm using the latest drivers from Nvidia 84.21 maybe? I don't think they are beta though.

I also have started TS2 before starting the game.

Edited by TritonBill
Link to post
Share on other sites

hmm ok, i just tried it, its nothing to do with sound, i disabled EAX, i tried software based sound instead of hardware, its not to do with sound. So i thought it might be the video in the menu that is causing it, which infact it isnt. Next ill try graphics, doubt its that, maybe its just the engine, and grin need to patch it for it to be normal, like in css.

Link to post
Share on other sites

Yep, I've noticed that TS2 doesn't work well when GR:AW is loaded.

I was sounding just fine, having long conversations with some people, and then when I loaded up GR:AW to play some Co-Op with a buddy, he would say that my voice was choppy and screwing up.

I was at the weapons load out screen when he first noticed it, didn't help when I was in the actual game either lol...

Once I got out, no complaints.

gg graw. ;P

Specs:

AMD 3500+ (2.2 GHz)

DFI LanParty Ultra-D

ATi Sapphire x1900XTX

OCZ 520w PowerStream

2GB Corsair XMS

Creative X-Fi XtremeMusic

2x74GB Raptors (Raid0)

Edited by SillyHalfMexican
Link to post
Share on other sites

k just played with video settings, i dont think its that, its either the game itself, or its a driver related problem, other than that i have no idea, you will have to wait till GRIN come on, or maybe someone could try some driver versions

Link to post
Share on other sites

I think you will find it IS soundcard related.

Basically I was helping a friend yesterday and he had exactly the same problem, really choppy TS.

I noticed that the only two options he had under sound renderer were Generic Hardware and Generic Software.

Mine actually lists my soundcard (SB Audigy 4)

I got him to update his drivers from the creative site, rebooted the game and he had his soundcard listed (SB Audigy 2).

No choppy TS, cured.

This seems to be quite a common problem for some reason, basically you SHOULD see your soundcard listed in-game in the sound options.

Link to post
Share on other sites

Kill every system process you can. You don't even need 20 of them. Just go through and kill as many as you can. Kill Explorer, even. Then use task manager with "New Task" to start GRAW, Teamspeak, and TSO if you need to. I'm running an AMD 3000+ with 1.5GB of RAM and (Single Player, anyway...) I don't have this problem. The only ones you don't want to kill are svchost, and the ones you can't kill. I made an image of what's needed to run your system. The items in black are items I did not kill (as I am not currently am not playing GRAW and like my music while working on things and posting..) but you should kill before playing. The items in red are ones the you SHOULD NOT (or cannot) kill. Feel free to experiment. There may be some things that you should not kill, the worst that can happen is you have to restart your computer. The best that can happen is TS works!

Task_Manager.jpg

EDIT: hmm... it could be soundcard related... I don't know. I have an AC'97, though, and I don't have any problems.

Edited by Cookie
Link to post
Share on other sites

Just updated my Audigy2 ZS drivers to the latest from Auto-Update - I can now see the sound card selectable in the AUDIO tab, but the game still max's the CPU at 90-100%.

If you ask me, the engine needs some major fixes to run this bad.

I notice the game is 1.02, the demo was 1.04 (didnt have any issues with the demo that I remember)

Link to post
Share on other sites
Just updated my Audigy2 ZS drivers to the latest from Auto-Update - I can now see the sound card selectable in the AUDIO tab, but the game still max's the CPU at 90-100%.

If you ask me, the engine needs some major fixes to run this bad.

I notice the game is 1.02, the demo was 1.04 (didnt have any issues with the demo that I remember)

If you tried all thoswe things and the CPU is still pegged then it's the game, which isn't surprising. This game seems to tax every single system in the computer so unless you have driver issues, which it sounds like you do not, then the game would need to be optimized somehow to reduce the cpu usage.

I imagine that is going to be pretty difficult as I mentioned everything is being taxed. Havok uses a ton of CPU for regular physics, but even more so if they are using it to drive thier character animation as well.

-John

Link to post
Share on other sites
Kill every system process you can. You don't even need 20 of them. Just go through and kill as many as you can. Kill Explorer, even. Then use task manager with "New Task" to start GRAW, Teamspeak, and TSO if you need to.  I'm running an AMD 3000+ with 1.5GB of RAM and (Single Player, anyway...) I don't have this problem. The only ones you don't want to kill are svchost, and the ones you can't kill. I made an image of what's needed to run your system. The items in black are items I did not kill (as I am not currently am not playing GRAW and like my music while working on things and posting..) but you should kill before playing. The items in red are ones the you SHOULD NOT (or cannot) kill. Feel free to experiment. There may be some things that you should not kill, the worst that can happen is you have to restart your computer. The best that can happen is TS works!

Task_Manager.jpg

EDIT: hmm... it could be soundcard related... I don't know. I have an AC'97, though, and I don't have any problems.

Cookie, Good idea, I'll look at your list and try killing some of mine.

My Soundblaster X-FI is also identified in the game so I think I'm ok there. I think we are going to find that there are a few problems and maybe a patch down the road will fix.

I think its a pretty fun game though even without being able to use comms. I'm coming from the BF2 game so I gotta learn not to run and gun so much! :)

Thanks all for your help.

Link to post
Share on other sites

Well I know this wouldnt help Single Core users out but GRIN might consider making it Dual Core compatible to perhaps balance the load some. I know with my P4 E with HT It is using only 50-60% of one thread and the other is lying there like a dead worm. Now of course I would agree the game does need some optimizations and Im sure they will do some.

Edited by LT.INSTG8R
Link to post
Share on other sites
Well I know this wouldnt help Single Core users out but GRIN might consider making it Dual Core compatible to perhaps balance the load some. I know with my P4 E with HT It is using only 50-60% of one thread and the other is lying there like a dead worm. Now of course I would agree the game does need some optimizations and Im sure they will do some.

Good point, someone mentioned to me maybe I should by a dual core processor. So are you saying that TS2 and GRAW wouldn't necessarily benefit from a dual core? I'd hate to spend the money just to find out it made no difference and didn't balance out the load on both processors??

Link to post
Share on other sites
Well I know this wouldnt help Single Core users out but GRIN might consider making it Dual Core compatible to perhaps balance the load some. I know with my P4 E with HT It is using only 50-60% of one thread and the other is lying there like a dead worm. Now of course I would agree the game does need some optimizations and Im sure they will do some.

Good point, someone mentioned to me maybe I should by a dual core processor. So are you saying that TS2 and GRAW wouldn't necessarily benefit from a dual core? I'd hate to spend the money just to find out it made no difference and didn't balance out the load on both processors??

Dual Core is great and all, but the app needs to specifically support it and I have no idea if GRAW does. Havok does, but GRIN would have had to specifically license that version for it to work. If GRAW is not Dual aware, then the second core would oofload some OS stuff and most likely any secondary apps like TS running just because XP is multi-threaded and can generally police itself.

As for HT.... it is a bit of an oddity in that intel bills it as a second processor of sorts and it uses "unused" threads and cycles in the cpu, but is is far from efficient enough to actually fill up all those unused threads/cycles. Out of order execution that modern cpu's do, still has waste.... especially in games. That second thread you are seeing as idle is most likely idle becuase the entire processor is fully saturated by the game therefore there is nothing to report being done.

ot sure if that last bit made sense, but basically XP reports 2 threads, but that doesn't mean the cpu actually has 2 threads available.

-John

Link to post
Share on other sites
Well I know this wouldnt help Single Core users out but GRIN might consider making it Dual Core compatible to perhaps balance the load some. I know with my P4 E with HT It is using only 50-60% of one thread and the other is lying there like a dead worm. Now of course I would agree the game does need some optimizations and Im sure they will do some.

Good point, someone mentioned to me maybe I should by a dual core processor. So are you saying that TS2 and GRAW wouldn't necessarily benefit from a dual core? I'd hate to spend the money just to find out it made no difference and didn't balance out the load on both processors??

You could run your Teamspeak or other comms on one other CPU while GRAW maxes out the other. Of course, if the engine needs optimization, that may end up being better.

Link to post
Share on other sites
I have an AMD 64bit 3500 Processor with 2 gig ram and a Geforce 7800 GTX card.  I bought the retail version of GRAW last night and had problems when trying to run TeamSpeak 2 at the same time for voice.

I had about 41 processes running in Task Manager but my system was 99% idle before starting the game.  After starting the GRAW game my system was using 98-99% CPU the entire time.  This basically didn't allow any other processes like TS2 to run correctly I think.

Any ideas?  I'd start killing processes but NONE of them were taking up any CPU time so I'm not sure that would help. 

Also I noticed that when in the multiplayer screen at times I'd click JOIN on a server and nothing would happen.  Anybody else have that problem?

Thanks,

TritonBill

more evidence this game has a very short half life for ladder play... given MP ladders need comm software to run in the background. nice design. :angry:

Link to post
Share on other sites

I don't see antivirus/ firewall on your processes list...................

Do you really connect to the net without a rubber?

But then I don't have a dedicated gaming PC :(

I find 'End it all' works for killing unwanted apps (it automatically leaves the useful stuff alone)

Sorry, just trying to help ;)

Link to post
Share on other sites

I think you will find it IS soundcard related.

Basically I was helping a friend yesterday and he had exactly the same problem, really choppy TS.

I noticed that the only two options he had under sound renderer were Generic Hardware and Generic Software.

Mine actually lists my soundcard (SB Audigy 4)

I got him to update his drivers from the creative site, rebooted the game and he had his soundcard listed (SB Audigy 2).

No choppy TS, cured.

This seems to be quite a common problem for some reason, basically you SHOULD see your soundcard listed in-game in the sound options.

My system:

WinXP Pro SP 2

AMD 64 3200+

MSI KN8 Diamond motherboard w/Sound Blaster Live 24 bit "chip"

2x BFG PCI Express Nvidia GForce 7800GTX OC in SLI mode

Corrsair Memory TWINX-3200C2PRO DDR400 4x512mb= 2048MB

2x WD Raptor 36GB=72GB @ 10,000 RPM and 8MB Cache Raid`0

Custom Thermaltake Xaser III Lanfire Series Case in "Ice Blue"

SliverStone 650w power supply

AT&T DSL @ 6 megabits per second (really around 4.9 is what I get)

I just updated my sound "chip" as my motherboard has the Sound Blaster Live 24 bit "chip" on it. so I don't need a card.

I rebooted GR3 and still not listed and says Generic Hardware , can I manually add my sound blaster chip thru the XML settings and how should it be listed? (wrote out)

Thanks for all the support

Edited by V00D00
Link to post
Share on other sites

Me and 2 other ppl I personally knows has the the same issues as the topic-starter (Retail GRAW) and we all have AMD64 cpu with nF4-chipset. The sound gets choppy and have long delays(up to a minute sometimes) in the game. If I go to desktop it takes very long time get any respond and I cant start vent or TS. If I started the coms before I launch the game it usually crasches

But if I use an image-file to play the game (yes I have it so I can PLAY the game) I can go to desktop in an instant without any delays , the sounds is on high and EAX on and I have no delays what so ever , I can start vent or TS with no problem at all and even during a gameplay I can start the coms , I can even start other programs and couple of FF and the game runs a smooth and nice.

So what makes the retail DVD impossible to use?

Please please help me or us

_______________________

AMD3500(venice)

2 GB RAM (2-2-2-7)

Asus 6600 GT top 128 (oc)

NEC DVD-R 3520A

Raptor 74GB

Audigy 2 ZS

100/10 Mb LAN (BBB)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...