Jump to content

Ghost Recon Future Soldier


Photo

[texture Faults & Very Dark/black Places On Map ?]


10 replies to this topic

#1 stephan187

stephan187

    Recruit - 3rd Class

  • Members
  • Pip
  • 11 posts

Posted 27 August 2008 - 11:07 AM

Hello.

I have some problems in working with the editor. If I export a created mission, no matter which rendering quality, there are a few texture faults in the map. The failure is on walls, rocks and some flowerbeds (only props). The surface of these props are chequered and in strange colours.
Another problem is that there are some very dark or even black places or building walls on the map, even though there should be enough light. All different export settings didn't fix the problem. Does anybody have a solution for this ?

Thanks...

#2 AmEyeBlind

AmEyeBlind

    Scout - 3rd Class

  • Members
  • PipPip
  • 241 posts
  • Gender:Male
  • Location:Ibbenbüren

Posted 27 August 2008 - 09:52 PM

hi there
the strange checkered stuff sounds like a texturescope problem.
is the strange couler blue and yellow or black and white?
if so its the texturescope.xml what is created during the export.
i cant tell you what exactly u need to add without seeing the map.
if u want we can meet up on ts and walk throu that.
if so pm me a ts ip, or i can give u 1 were i m usually at , and a time to meet up.

the black spots are normaly happening when u mix up different layers or overlay textures.
sometimes u can fix that with lights.
Posted Image

#3 viiiper

viiiper

    Ghost - 2nd Class

  • GR.net Supporter
  • 2,010 posts
  • Location:WY UK.

Posted 28 August 2008 - 07:43 AM

Hello.

Another problem is that there are some very dark or even black places or building walls on the map, even though there should be enough light. All different export settings didn't fix the problem. Does anybody have a solution for this ?

Thanks...


If you place a wall and it intersects with a building, it can form a section of wall that becomes practically black, (quirk) try to not have the wall intersect a building. I went through my picture collection but can't find a saved example.

But you see it after render in low or high mode.


viii
Posted Image

#4 stephan187

stephan187

    Recruit - 3rd Class

  • Members
  • Pip
  • 11 posts

Posted 28 August 2008 - 11:10 AM

Hello.

Thank you for your quick help. I solved the problem with the blue and yellow coulours with the texture_scope.xml.

But the problem with the dark bulidings and walls is still there. The walls don't intersect with buildings at that places. I placed some different small houses (props) free on the map, most of them (not all) are very dark or even black. Are there favourite export settings you choose at all your maps ?

Thanks...

#5 AmEyeBlind

AmEyeBlind

    Scout - 3rd Class

  • Members
  • PipPip
  • 241 posts
  • Gender:Male
  • Location:Ibbenbüren

Posted 28 August 2008 - 03:15 PM

i usually try to export with 3 pass medium.
and depending on the map day or night. the night option will turn all the lights on.
like i wrote above, sometime u can fix those dark black spots with lights ;)
Posted Image

#6 fishmonger

fishmonger

    Recruit - 1st Class

  • Members
  • Pip
  • 198 posts

Posted 28 August 2008 - 04:01 PM

those black areas only show up on low qual exports on my maps, plus usually only on some sky/cube combos. The brighter the sky, the less trouble. Last map I could not export on medium because it was always running out of memory had black areas until I chose hh02 sky and mission02 cube - that's very bright and it fixed it on that map, no other changes

#7 AmEyeBlind

AmEyeBlind

    Scout - 3rd Class

  • Members
  • PipPip
  • 241 posts
  • Gender:Male
  • Location:Ibbenbüren

Posted 28 August 2008 - 07:09 PM

i got black spots on medium render as well, mission4 sky and cube.
but i know its becouse of mixing layers and overlaying some walls.
i got most of that spots fixed with lights, what fits in the theme with the mis4 sky anyway.
and i kind of like those black spots here and there if they are not in the middle of the street or something.

what surprised me were the historic 2lane 10m street peaces.
those were really messed up on a low render, but on a medium its all good.
Posted Image

#8 vmtrCallaway

vmtrCallaway

    Recruit - 3rd Class

  • Members
  • Pip
  • 13 posts

Posted 28 August 2008 - 09:29 PM

Last map I could not export on medium because it was always running out of memory had black areas until I chose hh02 sky and mission02 cube - that's very bright and it fixed it on that map, no other changes



Try exporting in the "windowed" video mode and not full screen video mode. I had the same issue with larger maps running out of memory. Once I unchecked the "full screen" box, it went smoothly. Just a thought.
:)

Edited by vmtrCallaway, 28 August 2008 - 09:31 PM.


#9 viiiper

viiiper

    Ghost - 2nd Class

  • GR.net Supporter
  • 2,010 posts
  • Location:WY UK.

Posted 28 August 2008 - 10:36 PM

3 pass Medium, render always in a window & make window small 800x600 etc. to save memory some renders move to 1Gb plus, mine use to crash at upper mem limit, so like 'vmtrCallaway' said windowed mode.
Posted Image

#10 stephan187

stephan187

    Recruit - 3rd Class

  • Members
  • Pip
  • 11 posts

Posted 29 August 2008 - 08:48 AM

My problem is solved ! Usually i exported with minimized window, because it was much faster. Now i tried to export in full screen mode, 3 passes medium. Everything looks great ;) No more black areas there. Seems that the editor doesn't export that well in minimized window mode.

Anyway, thank you for your help !

#11 fishmonger

fishmonger

    Recruit - 1st Class

  • Members
  • Pip
  • 198 posts

Posted 29 August 2008 - 09:36 PM



Try exporting in the "windowed" video mode and not full screen video mode. I had the same issue with larger maps running out of memory. Once I unchecked the "full screen" box, it went smoothly. Just a thought.
:)


what I do with my renders is the following

set the editor to 800x600, windowed, LOW QUALITY TEXTURES, every effect low or off, and then Iload the map and quit. Then I restar the editor and start rendering from that setting. It uses much less memory on the load after you change the video settings. Also, some bigger maps still ran out of memory at that point, however, on a second try, they then did render (when it sez rendering light maps, this may take a while..." it will work)

There's no way to make this take more than 1GB, unless there's a way on a 64-bit XP system. I have not been able to get any confirmation if the editor uses more than 1GB on a different OS, but I doubt it. The stupid thing doesn't even use more than one core...

What I think Grin did for the larger maps is to render them in two separate batches, first 5000 objects for one export, then the other 5000 or whatever it takes to make the whole map. Then you just need to merge them and delete those lightmaps that overlap between your map halves. Problem is you gotta build you map in two stages, otherwise you'll never get the left form the right half separated down an exactly line like a main road going down the middle.

I may build my next map like that, planning from the first object placed that the map lightmaps will be rendered in two separate batches.
I've done this approach before on meatshields to replace one area that was changed from the original map, then just merged those two sets of light maps with a modified texture_scope file and things worked like a charm.

oh, yeah, and DON'T minimize that render window! did that just recently and got very similar bad results. Rule of thumb - if it goes fast, it probably isn't working :-)

Edited by fishmonger, 29 August 2008 - 09:37 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users