Jump to content
Ghost Recon.net Forums
ApexMods

Ghost Recon on Mac OS X 10.7 (Lion) and later

Recommended Posts

You may need to control-click and select „Open“ from contextual menu to run it.

Share this post


Link to post
Share on other sites

Ok, so I got it to work after doing the command.  When playing there is a stripe of brightly colored pixels whenever I move around in the map.  The FixMe.command itself had a runtime error (see below).  Same thing happened on wife's computer.

____________________

Clearing quarantine from /Users/claw/Downloads/Ghost Recon Wrapper

xattr: [Errno 1] Operation not permitted: '/Users/claw/Downloads/Ghost Recon Wrapper/Ghost Recon.app/Contents/Resources/dosdevices/z:'

xattr: No such file: /Users/claw/Downloads/Ghost Recon Wrapper/Ghost Recon.app/Contents/Resources/drive_c/users/Wineskin/Desktop/My Mac Desktop

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

[Process completed]





 

Share this post


Link to post
Share on other sites

The command ran fine, that error is normal. A stripe in the map however is not. 🤔 

Share this post


Link to post
Share on other sites

Have a look at the ReadMe how to access the Wineskin utility. Launch it, click „Advanced“, then „Tools“, then „Refresh Wrapper“. Wait for it to finish, close Wineskin, and try the wrapper again.

Share this post


Link to post
Share on other sites

Any news here? Did that solve your graphics issues?

Share this post


Link to post
Share on other sites

This stipe is on both of your Macs? What type of Macs?

Share this post


Link to post
Share on other sites

Yes - we have Macbook 12 retinas (2016 and 2017), both with High Sierra (10.13.6).

Share this post


Link to post
Share on other sites

Same hardware as mine, but I‘m on macOS Mojave 10.14.6, and have also tested on a MacBook Air 13‘ (Early 2015) with macOS Catalina 10.15.5.

The previous wrapper version (2018-05-23) should still work fine on your OS. I may have to list both in the OP.

Edit: Done. Old wrapper linked in OP.

Share this post


Link to post
Share on other sites

So, everything working now?

Hello? Buller? ... Buller? ... Buller? 🙂

Share this post


Link to post
Share on other sites

Oh man - my computer is in pieces - I have a new laptop on the way - the stripe was still there.  I will let you know how the new one does when it arrives.

  • Like 1

Share this post


Link to post
Share on other sites

Sorry to hear that. I feel your pain, my little MacBook is falling apart, too. Guess the times when Apple produced quality are long gone. Ever since Steve left us, it‘s been going downhill. Shame.

Share this post


Link to post
Share on other sites

I have the new computer up and running - went to the wrapper on page 1 of this thread and it said the file is no longer available?

  • Thanks 1

Share this post


Link to post
Share on other sites

Fixed now. Sorry, apparently Dropbox changed their link system (again).

Share this post


Link to post
Share on other sites

Hi - I have my new macbook pro (2020).  I tried the new file, did the fixme.command and then when I started up the game it blacked out the screen as it was about to begin (like normal), then I saw my mouse cursor enlarged a bit on the screen, then the program stopped and my desktop screen returned to normal.   Weird.  I tried refreshing the wrapper, but nothing changed.

  • Like 1

Share this post


Link to post
Share on other sites

I think I may know what’s going wrong there. It has something to do with the intro movies.

You could fix that by either installing Perian (which is probably no longer supported), or disable the quartz override in Wineskin > Advanced > Wine Config (not trivial).

I’ll try to work an easier solution.

Share this post


Link to post
Share on other sites

This is weird. Tried the wrapper again on another macOS Catalina MacBook Air without issues. Maybe it’s your MacBook Pro switching from integrated to discrete graphics card the wrapper doesn’t recognize or handle right. You can force which card to use with this: https://github.com/CodySchrank/gSwitch

Maybe that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×