Countdown until Ghost Recon Wildlands!
Sign in to follow this  
Followers 0

["insert CD" message after patching a D2D version]

12 posts in this topic

Posted (edited)

My dad doesn't have an account here so I'm posting this for him. He had an issue with GR so he uninstalled and installed it again. It ran fine and he tried to join a game and remembered he didn't patch it. I sent him the 1.35 and 1.4 patches, and after installing 1.35 or 1.4 he couldn't start the game. Upon start up it says to insert the original CD. He doesn't have it since he downloaded the game from D2D. So that's pretty much it. Any idea what we can do?

Edited by rileyfletcher_01

Share this post


Link to post
Share on other sites

Posted

If its d2d from, someone like steam, its already patched to 1.4 :whistle:

Share this post


Link to post
Share on other sites

Posted

No, we got it five years ago. I don't even know if the patch was out then. I still had to patch it upon downloading. When he joined my game it said incorrect software version, so....

Share this post


Link to post
Share on other sites

Posted

I think it already comes at 1.3, not sure,

Share this post


Link to post
Share on other sites

Posted

Island thunder has 1.35 patch included, so if you have all the games you only need 1.4. Applying the 1.35 patch will give you the error mentioned. Need to do a clean reinstall

Share this post


Link to post
Share on other sites

Posted

Yeah, Tinker got it. I had the same issue installing GR Gold Edition.

Share this post


Link to post
Share on other sites

Posted

Will try and post results later.

Share this post


Link to post
Share on other sites

Posted

He followed the steps you said, Tinker. Still didn't work.

Install GR (from folder, not disk)

Install Desert Siege

Install Island Thunder

Works at this time, starts up right. Cannot join other games, incorrect software version (1.35)

Update to v1.4 with RSE 1.4 patch.

Asks for CD upon startup.

wall.gif

Share this post


Link to post
Share on other sites

Posted

All right, I had an idea and it worked! smile.gif I kept thinking we should do it EXACTLY like the first time, and then I thought, wait--we had the patches years before we ever got the expansion packs. So I told him to install 1.35 and 1.4 after installing GR, and it worked. Then he installed DS and IT and it still starts up and works fine. Thanks for the help.

Share this post


Link to post
Share on other sites

Posted

Glad you made it work :thumbsup:

Share this post


Link to post
Share on other sites

Posted

I sent him the 1.35 and 1.4 patches, and after installing 1.35 or 1.4 he couldn't start the game. Upon start up it says to insert the original CD.

~

He doesn't have it since he downloaded the game from D2D. So that's pretty much it. Any idea what we can do?

The Boxed retail game uses a CD check as DRM

But Direct2Drive being a download media used it's own License checker as DRM.

you cant use Retail game patches with most D2D games for exactly this reason, You need to patch with the D2D specific GR patches

as it said on the D2D website:

    You must use patches we provide for Direct2Drive games. Outside files cannot be used to patch Direct2Drive games.

    Direct2Drive games are not compatible to expansion packs purchased at retail stores on cdrom.
    Only expansion packs offered by Direct2Drive are compatible to Direct2Drive games.

There have been several previous threads on the huge drawbacks of D2D before

EG

http://www.ghostrecon.net/forums/index.php?showtopic=29414

http://www.ghostrecon.net/forums/index.php?showtopic=36349

http://www.ghostrecon.net/forums/index.php?showtopic=33703

But since D2D was bought by gamefly not sure of a working link for the D2D GR patches anymore (or if they are even still available).

and then I thought, wait-we had the patches years before we ever got the expansion packs.

Patch 1.3 was issued after DS and Patch 1.4 was issued after IT

So I told him to install 1.35 and 1.4 after installing GR, and it worked. Then he installed DS and IT and it still starts up and works fine.

by installing the expansions after using the retail patch you have just undone some of the benefits of the patches, in effect unpatching parts of the game (which is why you don't get the CD check anymore despite using a retail patch) which will cause you issues down the line

you really need to uninstall completely, install GR, DS & IT and then patch using the D2D patch (if can still get it/them)

*If you cant get the D2D patches, no worries as can just get GR/DS/IT from Steam or a box set for a few Pounds/Dollars nowadays

Share this post


Link to post
Share on other sites

Posted

.....don't want to argue with you, but first of all I already fixed it. Secondly, we had the patches before WE GOT DS and IT, not before they came out. I just found out about DS and IT last year. Sorry for confusion. Everything's fixed though, so.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0