Jump to content
Ghost Recon.net Forums

Really bad performance with Ghost Recon :(


Recommended Posts

Hey guys, I found this forum completely by accident :P

Today I installed Ghost Recon for the first time in YEARS, and my performance is dismal to say the least. I set all detail settings to maximum and the resolution to 1024x768 and it stutters like crazy. At times my framerate is as low as 3fps. Zooming in with the sniper rifle affects it most, as well as urban areas (level 6 I think, I can't play it because it's jerking so badly). My computer more than meets the requirements:

Athlon FX-55 @ 3.05GHz

1.5GB RAM @ 236MHz 1.5-2-2-5

Radeon 4670 @ 820/1180

Windows 7 64bit

Please help, this is the best game ever written, back when gameplay was more important than graphics!

Link to post
Share on other sites

I agree you have plenty of computer to play the game.

You could try turning shadows off and dead bodies off to see if that helps at all.

Do you have anything running in the background.

I really note a hit in performance when a scheduled virus scan is running.

Run a dxdiag and post here. Maybe Windows 7 doesn't have that?

I'm completely unfamiliar with Win7 but is there a way to run the game in an XP emulator with Win7?

Link to post
Share on other sites

:unsure: Im running GR on Windows 7 and its silky smooth and its not running under XP mode

Only suspect i can think of is the Ram ? They say W7 uses 1.5GB to run its self, just maybe its coming up short for the running the game :unsure:

Intel i7 3.4ghz

Asus Rampage II

6GB Patriot DDR3 ram

GeForce GTX285 1024MB DDR3

Windows 7

Edited by Hammer
Link to post
Share on other sites

I've just tried XP compatibility mode, same thing. Level 5 nets me between 1fps and 6fps, monitored with FRAPS. If I turn all shadows off I get several HUNDRED frames per second, it doesn't take anything away from gameplay but seriously, shadows don't hurt that much...

I see you ninja edited, according to Task Manager I have over a gig free, and I have no problem with other (newer) games such as Oblivion, Fall Out 3, etc. I have another rig which I can try this on, Phenom 2 @ 4.7ghz, 4gigs DDR3, 5870 1GB but this machine is way over powered for the game as it stands. I remember playing it on a Celeron 1GHz with 192MB RAM and a TNT 2 graphics card...

Edited by Oj0
Link to post
Share on other sites

Just noticed you have posted this in the GRAW forums?

when you talk about Ghost Recon are you talking about the original game ? Ghost Recon . Desert sege & Island Thunder or About Ghost Recon Advanced Warfighter ??? Just so we know :thumbsup:

Edited by Hammer
Link to post
Share on other sites

I seem to have a habit of making mistakes whenever I post from my phone, this is the Ghost Recon, not the new 'rubbish' :P

LOL :whistle: No problems Oj0 Im sure one of the Mods will move it to the right place.

Oh and Welcome to the Forum :thumbsup:

Link to post
Share on other sites

I thought I'd outgrown gaming, the last game to keep my attention for more than a few minutes was Half Life 2. I fired up Ghost Recon for the first time in about half a decade and boom, three hours have flown by :D Thanks for the welcome :)

Link to post
Share on other sites

I used to play it perfectly back on my TNT 2, and my the shadows are taking my performance as low as 1/400th normal frame rate. If it were half I could live with it but it's down from 400 to as low as 1. FRAPS works fine with Oblivion which I'm sure uses ten times as much RAM as Ghost Recon, so I'm not convinced the problem lies there either. Besides, with it running and shadows off I'm still hitting 400fps at times.

Link to post
Share on other sites

I've just spent the last half hour browsing the forum archives and it seems hundreds of people get rubbish performance with shadows enabled, the engine just can't handle it. I've also compared framerates with the toggleframerate command and FRAPS and the difference is next to nothing? It's well within the margine of error. Anyway, special thanks to wombat for suggesting I turn shadows off :D And thanks to you, hammer, for your suggestions :)

Link to post
Share on other sites

If you want to go to the trouble of updating your video card and sound device drivers that may pay off.

GR at one time was notorious for needing sound device drivers updated to make the game perform better.

But that was eons ago.

I always hated updating video card drivers and you having Windows 7 64bit may or may not make it any easier for you. I always stumbled through a video card driver update myself. :)

Welcome to the forums Oj0.

Link to post
Share on other sites

Just one question, do you have a dedicated sound card at all installed on your PC? GR was notorious for bringing PCs with integrated sound to it's knees and inducing single digit frame rates on such systems, I had that problem myself and once I installed a dedicated sound card, frame rates increased.

Welcome to the forums.

Link to post
Share on other sites

I don't, I'm using onboard sound with the 'Realtek Xfi' drivers. Basically hacked drivers to enable all the software sound enhancements of the Creative Xfi which now get done on the CPU, so if sound kills performance I definitely have my suspect. Oh well, I can live without the shadows, the game is so immersing you don't notice anyway :P Thanks again for the welcome :)

Link to post
Share on other sites

I realize this thread hasn't been visited for almost a week, but Ojo's performance problem is perplexing to me. I'm averaging about 60 fps on a PC with this wimpy spec:

AMD x64 3200

1 GB PC3200 RAM

Geforce 7600

SB Audigy II

I'm also running with everything maxed in game and with my Vid card settings set to max for visual quality. The only compromise I've had to make was to set Anti Aliasing from 8s to 4x, and that was only only because performance dipped to about 35fps a few times in Island Thunder and some of the community mods. Of course one difference big difference for me is that I'm still running WinXP w/SP3 and at a rez of 1280 x 720.

I'm not that familiar with the FX-55 CPU, but if it's dual or quad core, something I've read in a number of forums is that dual and quads sometimes have problems scaling older Windows games. There's a utility called IMAGECFG that allows you to set affinity for any EXE to only 1 processor. I know it works with Vista, but I'm not sure if it works on Windows 7, but It might be worth giving it a try to see if it helps. It's available from a lot of sites on the web, just google for it.

Link to post
Share on other sites

My money is with the onboard sound. Stick a sound card in there :thumbsup:

Yup...that's a good point, and one of the differences between his specs and others that have been posted here. I'd personally never go without a dedicated Sound Card. I'm amazed at how many posts I've read on various forums however, where people claim onboard sound chips are less CPU intensive. :blink: As far as I'm concerned 90% of the performance is in the quality of the drivers, and I don't see the incentive for manufacturers of 1-size-fits-all onboard chips to really optimize. Not that Creative Labs and Turtle Beach haven't occassionally come up with some real duds in the driver department. >_<

Link to post
Share on other sites
  • 1 month later...

Lets not forget that Windows 7 is also involved. We do lots of testing at my work, and i have noticed at times that Win7 sitting at idle consumes 1.5 meg just to keep happy.

I don't suppose that the problem system is duel core? If so, you could move your security packages and some other system processes to a dedicated processor.

If it were me, I'd bump the memory up to at least 4 Gig, XP can handle most of that, would allocate some more to other system proc's.

My 2 cents worth..

Seekerii

aka Stormlord

Link to post
Share on other sites

I'm surprized no one noticed this. Shut off your overclock and see how it runs.

(unless i'm reading you wrong most people put an @ before the speed meaning that it originally doesn't

run @ that speed)

Also try running the game in compatibility for XP. (right click the shortcut, left click properties..)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...