Jump to content
Ghost Recon.net Forums
Sign in to follow this  
Flogger23m

Help placing spawns on a map

Recommended Posts

I need help making a spawn area in my GRAW map. I just want to be able to place one player on the ground without falling through the street/map. How would I do this?

I did this before and it worked fine, now no matter where I place the "Player" in the editor I always fall through the map. I see no place to place "spawns" in the editor either. All I want is to be able to test the map in real time without falling through the ground.

I remember looking at an online manual a long time ago as well, which might be of help. I looked on this site (where I thought it was) and found a mapping tutorial in the GRAW downloads section, but that was different and of no help.

Edited by Flogger23m

Share this post


Link to post
Share on other sites

whith gametype is this for?

if ogrcoop, you will need to create 2 zones in the multiplayer layer.

alpha set to base 1, and zulu set to base 2.

base 1 is your spawn zone. place 1 or more spawndummy´s in its shape.

those dummys are in the probs layer.

and that should be it.

if its a different gametype it could be different.

Edited by AmEyeBlind

Share this post


Link to post
Share on other sites

when placing the spawn_dummies on the map, make sure you first hit the "N" key to make the little green orb thingie snap to the map surface, not to the default elevation 0, which can be below the surface of many objects, causing your ghosts to spawn below the world surface and fall through.

Share this post


Link to post
Share on other sites

I tried to recompile the map, and this time it worked, I no longer fell through the map. However, this time I got a different error. Half of the textures on my map were checkered in black and white. Does anyone know how this could have happened?

Also, can someone clarify how exactly do I place spawns for players in deathmatch?

Edited by Flogger23m

Share this post


Link to post
Share on other sites

Half of the textures on my map were checkered in black and white.

well i just guess that you rendered all lightmaps, so i would say its a texture_scope problem.

look in the work_temp folder for the texture_scope.xml and edit it.

the editor just sets 1 line according to the layer set you used.

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/historical/*)"/>

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/industrial/*)"/>

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/city/*)"/>

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/ghetto/*)"/>

1 of these lines gonna be in there allready, you just need to add the once for the sets that are checkered blue and yellow , or black and white.

when you edited it set it to read only, so it stays like it even when you export the map again.

Share this post


Link to post
Share on other sites

Thanks for the response, I will try this again some time. But before I attempt another compile, can someone clearify how to place spawn areas?

multiplayer layer in the editor

how exactly, depends on the type of map you are making.

Share this post


Link to post
Share on other sites

Half of the textures on my map were checkered in black and white.

well i just guess that you rendered all lightmaps, so i would say its a texture_scope problem.

look in the work_temp folder for the texture_scope.xml and edit it.

the editor just sets 1 line according to the layer set you used.

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/historical/*)"/>

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/industrial/*)"/>

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/city/*)"/>

<xi:include href="/data/settings/set_texture_scope_editor.xml#xpointer(/include/ghetto/*)"/>

1 of these lines gonna be in there allready, you just need to add the once for the sets that are checkered blue and yellow , or black and white.

when you edited it set it to read only, so it stays like it even when you export the map again.

Replying to my ancient thread... I never got around to try this until recently.

I opened this file and added those lines and right clicked on the rifle after I saved it and put it as Read Only, but some of the textures still how up as black and what. Some show up as yellow and blue still.

So maybe this is a light maps issue. If so, how do I render this?

Share this post


Link to post
Share on other sites

must have been ######faced when i did that post, forgot the main thing. sorry. :whistle:

you do not render the map again, you just need to bundle it again.

you do so by using this line in the dos run box.

"E:\Ghost Recon Advanced Warfighter\tools\bundler" -vvb quick-bundle -r "E:\Ghost Recon Advanced Warfighter\custom_levels\work_temp\1" -D "E:\Ghost Recon Advanced Warfighter map editor\custom_levels\map_name.bundle"

you need to edit that line, so that it matches you file path. and of curse the map name.

watch out that it doesn't have more than 255 characters in it, i had once that problem that it wouldn't work, caused by too many characters in that line.

plus there are some textures what might need extra lines in that file, like the landscapes for example.

Share this post


Link to post
Share on other sites

My install directory looks like this:

C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter

So start, run, CMD and in the box I would write:

C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\tools\bundler" -vvb quick-bundle -r "C:\Ghost

Recon Advanced Warfighter\custom_levels\work_temp\1" -D "C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced

Warfighter map editor\custom_levels\map_level.bundle

Or so I have that completely wrong?

Share this post


Link to post
Share on other sites

nope you got it.

you can use it strait in the run box, dont even need the cmd.

but there are some problems now,

1. you forgot "Program Files (x86)\Ubisoft\" on the 2nd path

2. you left some " out

"C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\tools\bundler" -vvb quick-bundle -r "C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\custom_levels\work_temp\1" -D "C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter map editor\custom_levels\map_level.bundle"

3. that line you have now has 300 characters, that might not work. if so try this

"C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\tools\bundler" -vvb quick-bundle -r "C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\custom_levels\work_temp\1" -D "C:\map_level.bundle"

and do you really want to call your map "map_level" ? :P

---

note: just for better understanding.

1st path is to locate the bundler

2nd path is to locate the map in the work temp folder

3rd path is the output

Edited by AmEyeBlind

Share this post


Link to post
Share on other sites

Can I change the name after I bundle it?

I plan on editing it some more later for proper spawn areas. As of now I am just trying to get the textures to work.

Edit: When I copy and paste it, I get an error:

"Windows can not find 'C:\Program'. Make sure you typed the name correctly, and then try again.

Well, I still must be doing something wrong. :o

Share this post


Link to post
Share on other sites

not sure about the name change, but i guess it will work, as long you have the name according to the name you use in the files.

for the error, did you copy the line with all the quotation marks?

and witch line did you use? the 1st or 2nd?

and double check the paths, just to make sure the are alright.

Share this post


Link to post
Share on other sites

Ok, I copied them with the quotations this time.

The first one did not do anything, but the shorter one did show something happening in the dos box.

I checked the paths, and they all seem there.

I loaded up the map in game and still have this issue.

Should the first part be bundler.exe ?

I will also recompile it to get spawn positions correct. Anything else lighting and texture wise that I should be looking for to prevent any issues?

Share this post


Link to post
Share on other sites

nope, the line is correct the way it is.

did you place any statics or probs after you rendered the lightmaps?

if so you will need to render the lightmaps again.

Share this post


Link to post
Share on other sites

I might have.

I will render the map all over again today.

Not surprisingly, I forgot how to add spawns to a Deathmatch map. How would I do that again?

And when I render it, I click Export correct? Any settings I should or should not use?

Share this post


Link to post
Share on other sites

never did a deathmatch, so no idea.

yes you use export for lightmap rendering.

for the export i would use a 5 pass medium for the final, or a 5 pass draft for beta.

make sure that no backround apps are running during the rendering. also no screensaver.

and leave it alone while it renders. more passes means less render mistakes.

if your map is big you might need to reduce the video settings, and use window mode.

you will see if you need it when the editor crashes at the 1st minutes of the rendering with an out of memory message.

mission time day sets lights to off, unless its forced on on the lightning prop.

mission time night will set the lights to on, unless forced off on the lightning prop.

backdrop cube sets light on or off for the backdrop tiles.

thats all i can think of right now.

i dumped graw months ago, and forgot already some stuff. :whistle:

Share this post


Link to post
Share on other sites

Ok, I decided to Export it again. Used the settings you suggested.

Got this:

Crash in application version: grpcrc1.35

Custom level bundle my_level contains an invalid file path

Tried to do this again:

"C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\tools\bundler" -vvb quick-bundle -r "C:\Program Files (x86)\Ubisoft\Ghost Recon Advanced Warfighter\custom_levels\work_temp\1" -D "C:\map_level.bundle"

Same issue. Well, looks like my install is messed up now.

Edit: Deleted the content in the folder, it works now.

So I am back to where I was 2 years ago. Setting up spawn issues and texture issues.

I have 4GB RAM, AMD 9950 and an N######ia GTX 260 <--- maybe this is the issue? Nivida is pure garbage, so maybe that is giving me rendering issues. Anyone know if you can make a map with Nvidia?

Edited by Flogger23m

Share this post


Link to post
Share on other sites

Ok, I deleted that version.

I rerendered an older version and I can load the map up fine.

All I need to do now is fix the texture issue. I will get screens up soon. Just black and white checkered textures, mainly on walls.

Most of the textures work.

My other issue is that when a round ends, the game crashes. I set the timer to 50 minutes and played for 20 or so minutes with a friend fine.

Share this post


Link to post
Share on other sites

yee the good old crash on 2nd round start crash.

start a brand new map on the ghetto layer. put 1 static in there, save it and quit the editor.

then copy the latest world.xml in your new folder and render it again, that should fix it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×