Jump to content
Ghost Recon.net Forums
Brettzies

Brettzies Weapons Pack V2.*

Recommended Posts

Gotcha, will try. I thought I had patched up. Odd. Thanks.

Share this post


Link to post
Share on other sites

Gotcha, will try. I thought I had patched up. Odd. Thanks.

You did, the crash # was for the post above yours. Try the other things though, hopefully they help. Good luck.

Share this post


Link to post
Share on other sites

I just gave this mod a shot last night, and it's been pretty awesome so far. I've run into a repeatable crash, though. In the first mission of Act 2, Welcome to Juarez, I get a CTD every time I try to enter the bombed out underground bunker, whether I try to enter from the loading dock/warehouse or the bombed out section. Here's the error message

"aaaaaCrash in application version: 30899.3048data\lib\units\types\weapons\multigrenadeweapon.dsf(-1): cant find member: player_data in type <void>Renderer: threadedPhysics : threaded"

It was a clean install of the game, patched up to the latest, after which I installed the 2.05b version of the mod. After going through the thread, I tried using the unbundled version of the mod, but I still keep getting the same error in the same spots. Thanks for any help.

Share this post


Link to post
Share on other sites

Hmm. Weird error. I have to admit, after v1.4 I haven't gone through all the missions with the v2.x mod. I was more concerned with getting the mp/coop stuff to work better. Are you using the 6 barrel grenade launcher by chance? Just looking at the error, that's the only thing I can think of off the top of my head.

Might be something I missed in that bunker, however, in SP, all attachments for all weapons should work. They don't have the same "out of range" problem that mp/coop does. What's in that bunker normally? Any MrCs? I did have to change their name which use to cause a crash in the Training Grounds, but I thought I checked all the other levels for instances of that weapon. RPG maybe? I'll try to look at it when I get home.

Also, did you try removing or renaming your english dir? Sometimes that causes strange hiccups.

Share this post


Link to post
Share on other sites

Yeah, I tried renaming, then deleting the /local/English folder. No luck.

As for the bunker, if my memory serves, there is an M32 grenade launcher in there somewhere, I think maybe lying on a table. It was definitely my first thought, so I loaded up the training mission and equipped the M32 to see if it would cause the crash there as well. It worked fine. As for the presence MrCs, I don't know, but I don't think they'd be there.

Thinking about it, I think the bunkers can actually be ignored, so I guess I'll try that for the time being.

Share this post


Link to post
Share on other sites

Hi. I just get into this 18 pages.

But i dont find a solution do set up the dedicated server.

Want to do the 3rd person variation for the coop movie.

If there is a solution, maybe do an extra thread for it and link that to the first post in here?

Kind Regards

Ares

Share this post


Link to post
Share on other sites

Try contacting Zeno (legions of sparta) clan. They had a server up for the first person version. I know it was a little tricky for them to get it running. The only difference in the third person version is like 2 xmls and some zoom settings. See the first page for Zeno.

Share this post


Link to post
Share on other sites

Thanks Brettzie, i send him a PM.

If somebody else can help. here is what i tried before.

- I tried:

the bundled version in the "MOD" folder

the bundled version in the "Local" folder

the unbundled version in the "MOD" folder

the unbundled version in the "Local" folder

changed the context, context_standalone, brettzies_context x,l files

- language alterated to the mod

- exec to level/dedicated

Then i started the game with the common dedicated_server.exe , but the game wasnt modded. - Standard. :wall:

After that i tried to start it on the server with the .bat file .. but that was an rediculess trie btw. :blush:

Please help.

Regards

Ares

Share this post


Link to post
Share on other sites

Ares,

We run the Brettzies mod on our server almost all the time. Viper from AGB showed me how to do it. We both use a dedicated server from "clanwarz.com". Here is what we do, although it seems like you have already tried this.

1) Upload the Brettzies mod bundle to the "mods" folder.

2) Upload a new "context_standalone.xml" which points to the mod bundle.

3) Rename the current "context_standalone.xml" to something else like "context_standalone_REAL.xml".

4) Give the xml that points to the modded bundle the name "context_standalone.xml"

5) Run the game.

It was that easy for us. When we want to run regular weapons we rename the files again so that the "context_standalone.xml" file is the original one that came with the game.

If you have already tried this, then I am at a loss to help you. You may want to try using "clanwarz" instead of your current server provider. Clanwarz will let you "test drive" one for 48 hours so you can see if you can get the Brettzies running on it. It works well for AGB and TAW. I'm sure it would work just as well for you.

BTW, it is curious that you mention having a "local" file for your dedicated server. Our server does not have a "local" folder at all. Are you using a PC as your dedicated server? If so, then I really can't help you. Our guys have been trying to do that for a long time with no success. We gave up on it just decided to rent one from the online server farm. If you find a way, please PM me and let me know how you did it.

Hope this helps.

Rahn

(TAW_Rahnman)

Share this post


Link to post
Share on other sites

Eh, iam a fag.

I edited the context.xml the wrong way.

Now the server is running the bundled version. 1 st person.

But if iam joined and choose a new weapon i spawn with a normal.

Everytime i start a match on it, i get a crash on my pc:

Crash in application version: 30899.3048

data\lib\units\types\weapons\bulletweapon.dsf(-1): cant find member: addon_data in type <Unit>

SCRIPT STACK:

data\lib\script_network\weapon.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\extensions\huskinventory.dsf(0)

data\lib\units\types\beings\mods_human\huskonfoot.dsf(0)

data\lib\units\types\beings\humanhusk.dsf(0)

Renderer: threaded

Physics : threaded

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "coop_assault_34"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\guiscreens.dsf(0)

data\lib\managers\guiscreens.dsf(0)

Renderer: threaded

Physics : threaded

Iam able to be ingame for around 5-10 seconds.

Choosen the M4A1 i spawn with an other weapon, M416 ... and then the crash appears.

Any ideas?

It would be great if the Post of EBDA will be connected to the first post. Thats the solution to do a dedicated server. Maybe its the best to upload a ready to go "context.xml".

@rahnman:

Thanks for help.

We running 4 gameservers on a rootserver, rented from a server farm. One core with 2,66 GHZ + 4 GB ram for every gameserver. The "local" folder isnt that problem. Its empty. I only use the "local" folder to make "INZANES 3rd person mod" available.

Regards

Ares

Share this post


Link to post
Share on other sites

I'm terribly sorry if this has been asked and answered before, but I'm having trouble getting the latest version of this mod going when trying to play the campaign (assuming its even compatible with it?)

I have all the files in their correct places and use the .bat file to run the game, but when trying to start a new campaign I get the following error message:

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "STONE"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\script_network\gametype\gametypecampaign.dsf(0)

data\lib\script_network\networkmanager.dsf(0)

data\lib\setups\setup.dsf(0)

data\level\level.dsf(0)

Renderer: threaded

Physics : threaded

If anyone has any ideas as to what is wrong and have some solutions that may allow me to use the latest version of the mod I would be greatly appreciative.

I tried also using a older version of your mod aswell, but I'm guessing there might be some incompatibility with the 1.05 patch for GRAW 2. (I think its the first version you introduced the "new look ghosts" using the mexican sf model I think.)

Edited by Delta One Zero

Share this post


Link to post
Share on other sites

That error usually means the game isn't reading the mod correctly. the best option is to try the un-bundled version if you haven't already. Here's are the 3 best solutions:

1. if you have a local/english dir, try renaming or deleting it. (strange but sometimes works)

2. try the un-bundled version (usually works for people with issues)

3. if you're on vista, there's a method to delete xmb(complied game) files, which can cause problems:

>>> To clean out XMB files in Vista, go to your user folder, into

>>> AppData/Local/GRAW2 and kill all XMB files except those in the

>>> "settings" folder. Then it will recompile with whatever mod you are

>>> using.

>>>

>>> It usually works.

>>>

>>> Remember that to stop using the mod you may need to to the same

>>> thing again.

Those are the 3 main solutions I can offer. Good luck. Also make sure you have this version of the mod: v2.05

It needs the last patch for GRAW2 as well, which it looks like you are using. There shouldn't be incompatiblity issues with that.

Share this post


Link to post
Share on other sites

This is a fantastic mod, but there is a problem. In multiplayer coop, there is no way to select a rocket launcher. Since missions have tanks that *require* this, we are rendered unable to use the mod for coop.

Is there a way to add a rocket launcher into the list of selections?

Share this post


Link to post
Share on other sites

I thought I added RPG and the Zeus to the demo kits specifically for that reason. Almost positive they are both in there. I know there is a small issue where you have to manually switch after you fire the guided one back a to a weapon, bu otherwise it should work.

......I just played both 1st and 3rd person versions. They are both in there and usable so I have no idea what you are talking about.

Now that I remember, the Zeus was actually requested which is one reason I added it. RPGs take longer to kill tanks. To make the icon show up I had to change it's weapon gui slot or something which is why it keeps looping the pull down anim. But, you just switch back to primary or secondary to get out of it.

Edited by Brettzies

Share this post


Link to post
Share on other sites

Right now you can't. If there were unlimited mod id#s available I could just make special versions, though I could look into doing it how I re-did the m4/m16 attachments - by using a riser and keeping the actual scopes the same id #. Might work if they line up correctly. I do remember the M14 had a flipped attachment point which made the scopes backwards.

Basically the same problem for the m203 on an M468, it wouldn't fit correctly, but you can add it just by editing the weapon.xml Visually it will look wrong though.

Share this post


Link to post
Share on other sites

Hi, I'm new to installing mods on GRAW 2 and I can't seem to install this mod on my Steam version of GRAW 2. Here's a quick rundown of what I've tried:

I put the bundle file in the 'mods' folder, I put the 'bp_weapons_pack_v2.05' folder in the Local folder, I've put the batch file and context file in the main GRAW 2 folder, and I've copied the context file and renamed it context_standalone, which probably did nothing.

Any suggestions?

Share this post


Link to post
Share on other sites

You shouldn't rename the context file unless you are going to run a stand alone server, and even then you should make a new one. There are some tricks about stand alones which others know better then me.

As for the mod, just run the batch file with the context_bp... named to whatever it was originially. Otherwise, you can edit the included bat file to point to whichever context file you like. Everything else sounds fine, but you do have to run it from the included bat file. If it doesn't work for some reason, try editing the original context file to point to bp_weapons..... or rename the folder you put in local to "english" and make sure your language is set to "english" in the context file. Basically the language is just pointing to a folder for "extra" files. I only recommend renaming it to english as a last resort. You can also try the un-bundled version as stated in previous posts.

Share this post


Link to post
Share on other sites

Thanks, the unbundled version worked like a charm. However, there is a small error that occurs: I tried to join my friend's server (running the bundled version of your mod) and I got an error saying "Server is using a different version" or something like that. Not a big deal; he downloaded the unbundled version and that fixed it.

Share this post


Link to post
Share on other sites

Thanks, the unbundled version worked like a charm. However, there is a small error that occurs: I tried to join my friend's server (running the bundled version of your mod) and I got an error saying "Server is using a different version" or something like that. Not a big deal; he downloaded the unbundled version and that fixed it.

Unfortunately, that can be a problem. You can try going back to the bundle version, but you'll have to use the supplied context . xml. There is a line in there telling it which mod to use, mod=bp_weapons.... or something like that and the language set to bp_weapons.... as well. Also, make sure you remove or rename the unbundled verions in local/ if you want to still have it.

What I usually do is just put in x_ in front or _x in back of the folder I don't want it to see. I know it's all kind of a pain, but the game was just never fully tested for modding before they released it. There shouldn't even really be a need for a folder inside of local/ when you have bundle, but then the custom sounds and intro movie don't work.

I really wish the whole single file bundle thing worked, would have made installs and such much easier. I suppose the un-bundled version is kind of like that.

Share this post


Link to post
Share on other sites

hi,

I have (s)crash when i use brettzie weapon pack ( not whit 3rd brettzie mod strangely...) :

Crash in application version: 30899.3048

data\lib\managers\groupmanager.dsf(-1): No soldier template named "coop_assault_15"

SCRIPT STACK:

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\groupmanager.dsf(0)

data\lib\managers\guiscreens.dsf(0)

data\lib\managers\guiscreens.dsf(0)

Renderer: threaded

Physics : threaded

someone can help me ?

Share this post


Link to post
Share on other sites

for planting C4 on the vehicles you just need to look down the vehicles and lean into the vehicles and you will get plant option. It took me awhile to figure that out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×