Jump to content
Ghost Recon.net Forums
Sign in to follow this  
spotH3D

Making bullet hole decals & explosion decals stay longer

Recommended Posts

Does anyone know how to make it so that the bullet hole decals stick around longer than 15 seconds? I editted the sustain="15" field in the decals document (in the effects folder) but it seems to have no effect.

If anyone could tell me how I would appreciate it, it would greatly add to immersion to see the area all tore up after a wicked firefight.

Share this post


Link to post
Share on other sites

That's exactly what controls it. To determine what surface has what decal, look at the material name and it'll tell you what decal will show up for an impact.

Unless you're referring to my mod, then it's under:

bullet_asphlt_mark_df
Grenades craters are under:
grenade_hit_df

If you do a search for those exact lines, you'll come up with the string of code that controls the decal, and sustain will be in there.

Edited by Agent Smith

Share this post


Link to post
Share on other sites

I've got a little mod setup that is only Local/English/effects/decals.xml

I have increased values on all sustain="15" but it seems to have no effect on making the decals stick around longer.

Share this post


Link to post
Share on other sites

I've got a little mod setup that is only Local/English/effects/decals.xml

I have increased values on all sustain="15" but it seems to have no effect on making the decals stick around longer.

Upload and PM me the .xml that you're using and I'll take a look at it.

Share this post


Link to post
Share on other sites

Hopefully in the next patch I might be able to figure something out about this.

Share this post


Link to post
Share on other sites

Hopefully in the next patch I might be able to figure something out about this.

The .XML you PMed me I wasn't able to download, it kept giving me an error.

Share this post


Link to post
Share on other sites

I looked it at, and what you did should make it work. I'm very confused, going to have to test it on my system.

Share this post


Link to post
Share on other sites

Thanks a ton.

When I use your mod it works fine, when I try to switch around my Local folders and use that simple file nothing happens.

Share this post


Link to post
Share on other sites

Two things:

1. You don't actually have the file in the Local/English/effects/decals folder. Sounds stupid, but it happens, even to the best of us. Sometimes we save the files in a different spot.

2. You over-rided it with another .xml which has changed values.

It works on my system, so the file is ok. It looks like it's on your end.

Share this post


Link to post
Share on other sites

Argh!

#1 was right, I forgot the decals folder under effects!!!!

Thanks a ton Agent Smith!!!

Share this post


Link to post
Share on other sites

Argh!

#1 was right, I forgot the decals folder under effects!!!!

Thanks a ton Agent Smith!!!

Well there you go. :rofl:

Just double check next time. :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×