Jump to content
Ghost Recon.net Forums
Sign in to follow this  

newbie modding problem

Recommended Posts


AIs don't shoot after they've been made visible, vulnerable


I've just started modding [GR] missions and I ran into a problem I can't seem to find any answers for - I'm guessing it's a simple mistake on my part. Hopefully someone can help point me in the right direction.

I have a mod where there are a number of enemy platoons that onStartup are set to:

1) undetectable, invisible

2) assigned a plan that sets them to recon, hold, upright, bored

3) set a timer

Later on a timer expired event those same platoons

1) are told to abort their plan

2) made visible and vulnerable

3) assigned a new plan that has a path and movement ROE

They follow their path, but do not react to player actions; nor do they shoot.

I've tried giving them explicit suppress combat orders, turning AI on, and a variety of other plan actions.

I'm pulling my hair out trying to find a fix for this issue - any help would be greatly appreciated.



Share this post

Link to post
Share on other sites

I found what appears to have been the problem - I had 2 startup scripts; when I removed one all these problems seemed to go away.

Share this post

Link to post
Share on other sites

As an aside, you should not need the first plan. At least if memory serves.

I have not scripted for a while, but I do not think it was needed....

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this